Cursor stays on previous line in textareas

RESOLVED DUPLICATE of bug 42112

Status

()

P3
normal
RESOLVED DUPLICATE of bug 42112
19 years ago
18 years ago

People

(Reporter: baptiste, Assigned: mozeditor)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build 2000061320

While entering bugs in Buzilla, I noticed some very odd behavior of the cursor.
 Sometimes it does nto respond to enter keypresses or even wraps.  It will often
stay one line above where it should be.  Othertimes it will stay in teh right
place, but the typed text won't appear (though the cursor moves)

This has caused problems with the auto scroll bars which appear when you have
typed enough text.  If the cursor does not stay with the currnet text position,
the text stays hidden below the textarea box until the cursor finally syncs up
with teh text.

The text not appearing seems to happen most often after the scroll bar appears
on thright.

Note that when teh cursor does not move like it should, the window knows the
proper position since the next character you type appears where it should and
the cursor will jump down to join the latestt text.


I also noticed that if you highlight a section of text in teh textarea and then
tyoe, the highlighted text is not replaced.  I also cannot delete the
highlighted text using the delete or backspace key.  Very odd.

Comment 1

19 years ago
reassigning
Assignee: rods → mjudge

Comment 2

19 years ago
there seems to be two bugs in this report - the one issue is the caret doesn't 
wrap appropriately. The second issue is the disappearing text (which I can only 
reproduce on win32 -- I am opening a new bug for that.

The caret issue: Mike, I can't repro the caret issue on win98 using the build 
from 6/16, I can test on mac but not on linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Cursor not staying in proper position in TEXTAREA → Cursor stay son previous line in textareas
(Reporter)

Comment 3

19 years ago
I can still reproduce the caret problem on 2000061820 Windoze 98

Most often I reproduce it by hitting Enter twice to double space text.  The
cursor only jumps down one line, but when I type the text appears two lines down
like it should.


It only appears to happen after I type some stuff on one line.  Also, if I use
the arrow keys after it happens, the cursor will jump two lines sometimes when
I've only hit the arrow once.  Bizarre.


Comment 4

19 years ago
I see this on Macintosh too.
OS: Windows 98 → All
Hardware: PC → All
Summary: Cursor stay son previous line in textareas → Cursor stays on previous line in textareas

Comment 5

19 years ago
reassigning to Joe
Assignee: mjudge → jfrancis
Target Milestone: --- → M17
(Assignee)

Comment 6

19 years ago
i think this is more enderlite weirdness.  this only happens in text areas.   
I've already assigned a duplicate of this to mike.  I'll leave this one open to 
cover the deletion problems mentioned.
Status: NEW → ASSIGNED

Comment 7

19 years ago
build 2000062520

It seems to me that what's happening is, when the cursor's supposed to be at the
beginning of a line, but there's text in the line before it, it appears at the
end of the previous line instead, so it appears that it's not moving when you
hit "enter". If you hit enter again, the line before it is blank, and it decides
to show up in the correct line.

At least it was doing this to me before. Right now it's doing just the opposite
behavior - when it's supposed to show up at the end of a line, such as when you
hit "End", it's appearing at the beginning of the next line instead.

Comment 8

19 years ago
*** Bug 43980 has been marked as a duplicate of this bug. ***

Comment 9

19 years ago
is this a duplicate of bug #42112?  Seems like it to me...
(Reporter)

Comment 10

19 years ago
Looks like it is, though before marking as dup, make sure a new ticket was 
opened to handle the disappearing text issue.  If another wasn't opened, I'd use 
this for the disappearing text (which may or may not be related to the caret 
issue)
(Assignee)

Comment 11

19 years ago
dup of 42112


*** This bug has been marked as a duplicate of 42112 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma
You need to log in before you can comment on or make changes to this bug.