consistantly inconsistant certificate behavior

RESOLVED INVALID

Status

Thunderbird
Security
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Peter Miller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Thunderbird: 20080213

Hello - 

I'm a bit desperate for a solution to certificate behavior of thunderbird 2.0.0.12

I'm on vista. 
I launch thunderbird. 
I have my settings to get e-mail *only* on demand, not automatically. 
I ctrl-shift-t to force e-mail update. 
I *always* get an invalid certificate warning at this point. Sometimes it's one kind of warning, other times it as a different warning. Happy to send screen shots if that's helpful. Without fail, if repeated enough times, I get my e-mail updated. Then during the same session I get more certifiacte warnigns when I force and update, but if I hammer through all the repeated warnings by repeating *the same command* I eventually get a new e-mail update. So what's the point of invalid certificates if you just repeat them to get around them? and Why do they happen 2/3of the time? It's really frustrating. My e-mail service is a large national company by the way(web.com), so I don't think the problem is on their end, especially with the behavior of thunderbird so "sometimes I'll do it and sometimes I wont" behavior. Also, I have gone into my settings multiple times and deleted previously existing certificates, to no avail. Out of desperation, I've looked to disable certificate security as well, to no avail (I just coulnd't find how to) 

To me, all of a sudden 2/3 of my e-mail updates fail due to "invalid certificates" pop up windows, so I always have to try 3 times minimum. 

Any help, or workaround, from anyone, genuinely appreciated! And, if I can help clarify with any additional specific workflows or details, please let me know. Desperate to get past the, what appears to me, default behavior of rejecting e-mail updates at least 2/3 of the time.



Reproducible: Always

Steps to Reproduce:
1. be on vista
2. setup an e-mail account with web.com
3. delete all previous certifictes
4. setup a web.com account
5. turn off automatic e-mail updates every x minutes
6. quit and restart thunderbird
7. ctrl-shift-t to force update
BUG: 
cerfiticate error of some kind.
8. ctrl-shift-t to force update again 
cerfiticate error of some kind, maybe the same as first maybe not. 
repeat ctrl-shift-t  until an e-mail update occurs. 
9 Several minutes later, start cycle all over again. mail update fails around 2/3 of the time, consistantly, inconsistantly. 
Actual Results:  
Read steps to repro.

Expected Results:  
setup certifiacte once, be done with it.

any workarounds very much welcome. happy to help on e-mail or phone to walk through repro steps.

Comment 1

10 years ago
What is the name of the server and the port number?

Details of the certificate errors might also be useful.

Sometimes what looks like one server is really several servers balancing the load. This is more common in a large organization.  If there are three servers, and only one of them has a valid certificate, then the outcome might be as you describe.

Comment 2

10 years ago
As ctrl-shift-t is "check all accounts", does it work if you only check one account by clicking the button?

Can it be some old account laying around, and a bug which is causing tb to check them too? Do you see the problem if you set up a new thunderbird profile? IMAP or POP? (For pop you'd have to move the message folders over to the new profile afterwards.)
(Reporter)

Comment 3

10 years ago
rod and magnus - thanks for your input. Sorry for late reply - was on vacation. 

Magnus I think you might have nailed it. The reason I ctrl-shift-t, is because pushing the button doesn't update my normal account. I'd forgotten this fact because I've worked around it for so long - that when I go to Tools -> account settings, there are *two* accounts for me listed for some reason - I think due to imported e-mails from long ago? And I *cannot* delete the unnecessary one because it is "special". And I think when I click the "get mail" button, it only attempts to do update the weird special account, and I don't get normal update, so I have to ctrl-shft-t. So I guess this bug is transforming to "how to I get rid of "special" accounts that always trigger invalid certificates?"

BTW - I would love to send you screen shots. Let me know if there's a way to do it, if you think that would be at all helpful. 

Any input on removing the special account would be very appreciated! Thanks again!

Comment 4

10 years ago
It's probably set as default. Choose the other account, and make that default, there is a button for that in the lower left corner of the account settings. 

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

10 years ago
Magnus - I'm afraid this bug is still open, although now it should read "cannot change default accounts". To summarize, I have two e-mail accounts set up (one which I never really tried to create but appeared during an import process, and which is marked "special",), and a third "outgoing server (SMTP)"  , but the "Set as Default" button is grayed out when any of these are selected in the list. So I am unable to set the "proper" account to being the one "default" account. 

Is there a text file I can manually adjust? Or a start-over workflow of some kind?  Any workaround appreciated. Happy to send screenshots if you would like. 
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Bugzilla is particularly bad for technical support, and that seems to be what you need right now. Please try the technical support newsgroups or web forum listed at http://www.mozilla.org/support/#community (or IRC chat if you prefer, but the #thunderbird channel isn't as well staffed as #firefox).

If you are sure that the certificates are really sent from your mail server you should be able to remember the override and not see the errors again. I have no clue about your frozen-default problem, maybe something in your profile is read-only. Community support can help you find and check that.
Assignee: dveditz → nobody

Comment 7

10 years ago
(In reply to comment #5)
> Is there a text file I can manually adjust? Or a start-over workflow of some
> kind?  Any workaround appreciated. 

You can always create a new profile, using "thunderbird.exe -P" 

Closing again, since the original problem got resolved.



Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.