Installer corrupted: invalid opcode

RESOLVED INCOMPLETE

Status

()

Firefox
Installer
--
critical
RESOLVED INCOMPLETE
10 years ago
9 years ago

People

(Reporter: Greg Watson, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

The error message said "Installer corrupted: invalid opcode"
FireFox has been running slow and locking up recently, so I was/am optimistic that this update (install of new version) will correct my problems, but I am uncertain that it even installed correctly, given the error message.  What should I do to make sure I have an uncorrupted version, try the download and reinstall it again... and see if I get the same error message?  Please advise. Thank you guys for all your great work!!!  I love FireFox and have been using it for years. This error message happened the last time I tried to update. Greg 404-831-0951 (cell phone)

Reproducible: Always

Steps to Reproduce:
1.download new version
2. run install
3. error message appears
4. install completes as if everything is OK, but the error message appears next time I try update I get the same error message
Actual Results:  
During normal use I got this: "Fail to get XMLDocument from http:..dl.ask.com/toolbar/moz/tbintalled.jsp?v=2.0 yatta...yatta...yatta...  [Exception..."Component returned failure code: 0x80004005 (NS_ERROR_FAIURE) [nxIXMLHttpRequest.suend]"  nsresult: 0x80004005 (NS_ERROR_FAIURE)"  location: "JS frame : : chronme://snipit/content/snipit.js :: ReportToWhatzup :: line 1571" data: no]

Expected Results:  
Expect to hear from you.

That's it folks.  Thank you.
Greg
Can you reproduce with Firefox v2.0.0.14 ?
Version: unspecified → 2.0 Branch

Comment 2

10 years ago
xref: Bug 442702 New: install of TB20014 fails with "invalid opcode" error message.  I note in this bug, that I get "Same "invalid opcode" error attempting to install FF 2.0.0.14 on same machine."

Greg appears to be gone.
Component: General → Installer
QA Contact: general → installer
Summary: Installer corrupted: invalide opcode → Installer corrupted: invalid opcode
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

9 years ago
I am not gone, but I don't know what you expect me to do?
I think I eventually reinstalled FireFox (after several tries -- had to go back to a couple of MS Windows "system restore" points), which seems to be working OK now.  What did you guys do? Do you know what caused this and what I can do to avoid in future?
Greg
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
We didn't change anything. Chances are this was either a corruption in the download or an extremely rare setting on your system. Are you still able to reproduce?
No response to comment #4. Resolving -> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.