Closed Bug 425274 Opened 12 years ago Closed 12 years ago

Drag&Drop of icons in toolbar customization window broken after initial first time

Categories

(Core :: Widget: Cocoa, defect)

All
macOS
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 426380

People

(Reporter: marcia, Assigned: jaas)

Details

Seen using Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b5) Gecko/2008032604 Firefox/3.0b5. This works fine on the equivalent Intel Mac build.

STR:
1. With a new profile, customize toolbar and try to drag and drop and icon to the toolbar.

Actual: unable to drag and drop
Expected: able to drag and drop

This works on PPC Mac using Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008032604 Minefield/3.0b5pre
Summary: Unable to drag and drop icons to toolbar (PPC Mac only) → Unable to drag and drop icons to toolbar (PPC Mac only) using B5 RC1 candidate
I started again with a new profile, and this time on the first try I was able to add a few icons, but after resetting to default and trying again, I could not drag and drop. juanb also had errors in his console when trying this, but I do not get them on the lab machine.
Summary: Unable to drag and drop icons to toolbar (PPC Mac only) using B5 RC1 candidate → Unable to consistently drag and drop icons to toolbar (PPC Mac only) using B5 RC1 candidate
Error in console: Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsITransferable.getAnyTransferData]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/nsDragAndDrop.js :: anonymous :: line 90"  data: no]
(In reply to comment #0)
> Seen using Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b5)
> Gecko/2008032604 Firefox/3.0b5. This works fine on the equivalent Intel Mac
> build.

> This works on PPC Mac using Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4;
> en-US; rv:1.9b5pre) Gecko/2008032604 Minefield/3.0b5pre

Is that a nightly and a beta? Seems odd that they have the same build date - just a coincidence?

Could it be that this is 10.4 only, as opposed to PPC only?
Assignee: nobody → joshmoz
Component: Toolbars → Widget: Cocoa
Product: Firefox → Core
QA Contact: toolbars → cocoa
I have observed this as well while testing the Fx3b5 release candidate: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

The way I came to see this was by adding a few icons to the toolbar, then clicking Done, then trying to remove some of the icons I had added, at which point I was unable to do so. The error console did not show this error or any other error. So I restored the default set of icons (OK) and then tried adding a few icons, again. I was not able and this time I saw the same error as in comment #2.
Marcia, does it only happen when d&d icons to the toolbar or is each d&d action affected for PPC builds?
I get an error in the console when I try to drag and drop a favicon to the toolbar as well, but a different error: Error: [Exception... "'Container view not found' when calling method: [nsINavHistoryResultViewer::itemInserted]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///Applications/Firefox.app/Contents/MacOS/components/nsPlacesTransactionsService.js :: PCIT_doTransaction :: line 374"  data: no]
Source File: file:///Applications/Firefox.app/Contents/MacOS/components/nsPlacesTransactionsService.js
Line: 374

I think there may be already a bug on file for the error above because it looks familiar. 

I also tried to dragging and dropped a bookmark to the desktop but I don't get an error doing that operation.
The build ID I was using for the error reported in Comment 6 is  Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5.
I tested this using the nightly build as well, Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008033104 Minefield/3.0pre and I see the same issues.  More specifically:

(1) Once you initially drag and drop an icon(s) to the toolbar, you lose the ability to make any other changes to the toolbar (dragging and dropping back to customize toolbar dialog, or dragging any new icons to the toolbar . Even resetting the toolbar to default does not restore this functionality.

(2) You can add a new toolbar using the latest nightly, but you can't drag and drop any icons to it.

Nominating since this happens on the trunk and is a bad user experience.
Flags: blocking1.9?
Summary: Unable to consistently drag and drop icons to toolbar (PPC Mac only) using B5 RC1 candidate → Toolbar customization broken after initial first time dragging and dropping icons (PPC Mac only)
Not only PPC related. Also happens for me with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008033104 Minefield/3.0pre ID:2008033104

I can see the same error message as Marcia already mentioned in comment 2. 

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/toolkit/content/nsDragAndDrop.js&rev=1.10&mark=127&#102

Using Venkman shows me following values:

0001: aFlavourSet
$[0] = [Object] [class: Object] {3}
0001: flavour
$[0] = [Object] [class: Object] {0}
0001: data
$[1] = [Object] [class: Object] {0}
0001: length
$[2] = [Object] [class: Object] {0}

I will run a test later under Windows if it's happen for each OS.
Hardware: Macintosh → All
Summary: Toolbar customization broken after initial first time dragging and dropping icons (PPC Mac only) → Drag&Drop of icons in toolbar customization window broken after initial first time
Does not happen under Windows. So it seems to be a OS X only issue.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426380
Sorry, I had forgotten about this bug when I filed that one :(
Status: RESOLVED → VERIFIED
Keywords: relnote
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.