If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Paragraph optional end tag is not optional in strict and transitional DTDs

VERIFIED DUPLICATE of bug 42312

Status

()

Core
HTML: Parser
P3
normal
VERIFIED DUPLICATE of bug 42312
18 years ago
17 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: rickg)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
The three test cases attached are identical except for the DOCTYPE.

They contain content similar to:

   <p> some text
   <div> some more text </div>

...which should be interpreted as:

   <p> some text </p>
   <div> some more text </div>

...since end tags on <p> are optional in the SGML version of HTML4. (i.e., not
in XHTML.)

Currently, it would seem that the strict (and transitional?) DTDs are not taking
the fact that "</p>" is optional into account, and are doing strange things to
the DIV (like not including it or something).
(Reporter)

Comment 1

18 years ago
Created attachment 10138 [details]
Test case 1: strict doctype
(Reporter)

Comment 2

18 years ago
Created attachment 10139 [details]
Test case 2: transitional doctype
(Reporter)

Comment 3

18 years ago
Created attachment 10140 [details]
Test case 3: invalid doctype
(Reporter)

Updated

18 years ago
Blocks: 7954
Keywords: testcase
(Assignee)

Comment 4

18 years ago
Fix in hand. Marking dup of 42312.

*** This bug has been marked as a duplicate of 42312 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.