Last Comment Bug 425338 - hovering over text on wikipedia causes jiggling text
: hovering over text on wikipedia causes jiggling text
Status: VERIFIED FIXED
: regression, relnote, testcase, top100
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Trunk
: All All
P1 major (vote)
: mozilla1.9
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://www.wikipedia.org/
: 427326 429265 429825 431896 433623 437498 (view as bug list)
Depends on: 424631
Blocks: 423130
  Show dependency treegraph
 
Reported: 2008-03-26 22:45 PDT by John Daggett (:jtd)
Modified: 2008-07-31 02:47 PDT (History)
26 users (show)
pavlov: blocking1.9+
jruderman: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase, reduced with all styles included (36.64 KB, text/html)
2008-03-26 22:46 PDT, John Daggett (:jtd)
no flags Details
better testcase (993 bytes, text/html)
2008-03-26 22:53 PDT, Gary Kwong [:gkw] [:nth10sd]
no flags Details
smaller testcase (275 bytes, text/html)
2008-03-27 14:43 PDT, Uri Bernstein (Google)
no flags Details
possible reftest [checked in] (2.37 KB, patch)
2008-03-27 15:58 PDT, Jesse Ruderman
no flags Details | Diff | Splinter Review

Description User image John Daggett (:jtd) 2008-03-26 22:45:09 PDT
Steps:

1. Go to wikipedia
2. Move the mouse over the list of languages listed under 10,000+

Result: the layout of the line suddenly switches back and forth between two states.  Occurs over multiple lines, starting with the language after Azərbaycan in the list.
Comment 1 User image John Daggett (:jtd) 2008-03-26 22:46:16 PDT
Created attachment 311973 [details]
testcase, reduced with all styles included
Comment 2 User image Gary Kwong [:gkw] [:nth10sd] 2008-03-26 22:53:54 PDT
Created attachment 311974 [details]
better testcase

Here's a simplified testcase.
Comment 3 User image Gary Kwong [:gkw] [:nth10sd] 2008-03-26 22:56:22 PDT
some things of note, re: my testcase

- remove the line "a {	text-decoration: none; }" and the issue doesn't occur.
- remove the line "a:hover { text-decoration: underline; }" and the issue doesn't occur.
- remove the tag "<span>" a line under the body tag (and the corresponding </span>) and the issue doesn't occur.
Comment 4 User image Simon Montagu :smontagu 2008-03-26 23:04:02 PDT
The patch for bug 424631 fixes this for me.
Comment 5 User image Carsten Book [:Tomcat] 2008-03-26 23:23:26 PDT
(In reply to comment #4)
> The patch for bug 424631 fixes this for me.
> 

confirmed, the patch also fixes this problem for me on mac with the testcase
and also the real wiki site
Comment 6 User image Mike Beltzner [:beltzner, not reading bugmail] 2008-03-27 08:19:34 PDT
Do we know how common this pattern (see comment #3) is on the web? I've been browsing some bidi websites that aren't Wikipedia, and things seem to work fine. Some examples:

http://mozilla.org.il/evangel.shtml
http://www.ynet.co.il/home/0,7340,L-8,00.html

We've run across limited examples where it doesn't work:

http://he.wikipedia.org/wiki/%D7%A2%D7%9E%D7%95%D7%93_%D7%A8%D7%90%D7%A9%D7%99

but so far they're all on Wikipedia. Anyone in the bidi community able to comment? I would imagine that Mano would have screamed if this was more common ;)
Comment 7 User image Mano (::mano, needinfo? for any questions; not reading general bugmail) 2008-03-27 09:10:19 PDT
I don't use the Internet as much as you think I do :p
Comment 8 User image Daniel Holbert [:dholbert] (vacation, returning 2/27) 2008-03-27 13:25:47 PDT
Was this fixed by the checkin for bug 424631 @ noonish today?
Comment 9 User image Gary Kwong [:gkw] [:nth10sd] 2008-03-27 13:58:42 PDT
Consolidating IRC discussion / discoveries for possible related jiggles:

http://www.google.ae/ - near the middle, click and hold on "English".
http://ma7room.com/ - highlight email address near top, webmaster @ ...
http://study4uae.com/vb/index.php - near the bottom, hover.

All of the above are Alexa Top100 sites, some Arabic etc.
Comment 10 User image Uri Bernstein (Google) 2008-03-27 14:43:42 PDT
Created attachment 312130 [details]
smaller testcase

This has only two levels of nested inlines. Hover to see the effect.
Comment 11 User image Uri Bernstein (Google) 2008-03-27 15:01:11 PDT
(In reply to comment #8)
> Was this fixed by the checkin for bug 424631 @ noonish today?
> 

Yes, this is fixed by that checkin (tested locally. I'll try to also pull an "hourly" build and verify).
Comment 12 User image Uri Bernstein (Google) 2008-03-27 15:40:08 PDT
Verified fixed with
Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008032714 Minefield/3.0pre.

I'll leave it for someone else to double-check and mark this VERIFIED.

Not sure whether there is a decision on respinning b5 for this. I think it makes sense to do so.
Comment 13 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2008-03-27 15:50:26 PDT
(In reply to comment #12)
> I'll leave it for someone else to double-check and mark this VERIFIED.

Will do that when the build is ready.

> Not sure whether there is a decision on respinning b5 for this. I think it
> makes sense to do so.

Otherwise adding a relnote?
Comment 14 User image Jesse Ruderman 2008-03-27 15:58:23 PDT
Created attachment 312141 [details] [diff] [review]
possible reftest [checked in]

These reftest use height instead of underline, since height can be changed without affecting the rendering when everything is working correctly.

Only 'b' fails in a build with the bug.  'a' is included for sanity.

Both pass in a build with the patch.
Comment 15 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2008-03-27 16:37:46 PDT
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko Minefield/3.0pre ID:2008032723

Until this isn't definitely fixed for beta5 lets set the TM to mozilla1.9.
Comment 16 User image Jesse Ruderman 2008-04-05 22:35:43 PDT
*** Bug 427327 has been marked as a duplicate of this bug. ***
Comment 17 User image Carsten Book [:Tomcat] 2008-04-06 04:46:43 PDT
*** Bug 427326 has been marked as a duplicate of this bug. ***
Comment 18 User image Jesse Ruderman 2008-04-19 15:33:47 PDT
*** Bug 429825 has been marked as a duplicate of this bug. ***
Comment 19 User image Simon Montagu :smontagu 2008-05-07 00:26:13 PDT
*** Bug 431896 has been marked as a duplicate of this bug. ***
Comment 20 User image Simon Montagu :smontagu 2008-05-07 00:27:10 PDT
*** Bug 429265 has been marked as a duplicate of this bug. ***
Comment 21 User image Jesse Ruderman 2008-05-14 11:58:35 PDT
*** Bug 433623 has been marked as a duplicate of this bug. ***
Comment 22 User image Uri Bernstein (Google) 2008-06-09 09:49:03 PDT
*** Bug 437498 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.