Closed Bug 425462 Opened 14 years ago Closed 14 years ago

patcher's fast-mode doesn't work on 3.0b4-3.0b5

Categories

(Release Engineering :: General, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nthomas, Assigned: rhelmer)

References

Details

Attachments

(3 files)

Attached file error log
Hit this for update generation for 3.0b5rc2:

Traceback (most recent call last):
  File "/builds/updates/firefox-3.0b5/patcher/mozilla/tools/update-packaging/make_incremental_updates.py", line 440, in <module>
    main(sys.argv[1:])
  File "/builds/updates/firefox-3.0b5/patcher/mozilla/tools/update-packaging/make_incremental_updates.py", line 437, in main
    create_partial_patches(patches)
  File "/builds/updates/firefox-3.0b5/patcher/mozilla/tools/update-packaging/make_incremental_updates.py", line 383, in create_partial_patches
    partial_filename = create_partial_patch(work_dir_from, work_dir_to, patch_filename, shas, PatchInfo(work_dir, ['channel-prefs.js','update.manifest'],['/readme.txt']))
  File "/builds/updates/firefox-3.0b5/patcher/mozilla/tools/update-packaging/make_incremental_updates.py", line 290, in create_partial_patch
    process_explicit_remove_files(to_dir_path, patch_info)
  File "/builds/updates/firefox-3.0b5/patcher/mozilla/tools/update-packaging/make_incremental_updates.py", line 252, in process_explicit_remove_files
    for line in list_file:
IOError: invalid data stream
Intending to move the RELEASE_AUTOMATION_M8_1 tag on Bootstrap/Step/Updates.pm after landing this.
Attachment #312083 - Flags: review?(rhelmer)
Attachment #312083 - Flags: review?(rhelmer) → review+
Attachment #312083 - Attachment description: Disable fast mode for 3.0b5 → [checked in, tagged] Disable fast mode for 3.0b5
Assignee: nrthomas → nobody
Priority: -- → P3
I can reproduce this on 1.9 staging, the failure is because make_incremental_updates.sh is doing a binary diff of removed-files then trying to open and read the diff (hence the "invalid data stream" when doing for line in list_file).

If add removed-files to path_exclusion_list then this works fine. I don't understand why this works on 1.8 staging and not 1.9 staging though.
Summary: patcher's fast-mode doesn't work on production-1.9-master → patcher's fast-mode doesn't work on 3.0b4-3.0b5
Assignee: nobody → rhelmer
We want to understand what's going on here, to make sure it isn't an underlying bug. I don't see why this works for 1.8 and not 1.9.
Status: NEW → ASSIGNED
Priority: P3 → P1
Ok, the problem is that removed-files changed between 3.0b4 and 3.0b5, so make_incremental_updates.py created a patch then attempted to populate update.manifest from the patch. 

This is a bug in make_incremental_updates.py, patch incoming.
Priority: P1 → P2
Attachment #312122 - Flags: review?(mtschrep)
Attachment #312122 - Flags: review?(mtschrep) → review+
Comment on attachment 312122 [details] [diff] [review]
[checked in] removed-files file should be excluded from diff

Checking in make_incremental_updates.py;
/cvsroot/mozilla/tools/update-packaging/make_incremental_updates.py,v  <--  make_incremental_updates.py
new revision: 1.5; previous revision: 1.4
done
Attachment #312122 - Attachment description: removed-files file should be excluded from diff → [checked in] removed-files file should be excluded from diff
Moved UPDATE_PACKAGING_R3 from 1.4 to 1.5 on make_incremental_updates.py
Comment on attachment 312083 [details] [diff] [review]
[backed out] Disable fast mode for 3.0b5

Backed out and the tag moved to rev 1.41 (same as the original 1.39)

Checking in Bootstrap/Step/Updates.pm;
/cvsroot/mozilla/tools/release/Bootstrap/Step/Updates.pm,v  <--  Updates.pm
new revision: 1.41; previous revision: 1.40
done
Attachment #312083 - Attachment description: [checked in, tagged] Disable fast mode for 3.0b5 → [backed out] Disable fast mode for 3.0b5
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Component: Release Engineering: Talos → Release Engineering
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.