Last Comment Bug 425499 - Enabling Firebug 1.1 on page with extjs dom scrolling code crashes Firefox [@ js_Invoke][@ nsXPCWrappedJSClass::CallMethod]
: Enabling Firebug 1.1 on page with extjs dom scrolling code crashes Firefox [@...
Status: VERIFIED FIXED
[firebug-p1]
: crash
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- critical (vote)
: mozilla1.9
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
: 425648 426758 426892 431206 487417 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 13:29 PDT by David Humphrey (:humph)
Modified: 2011-06-13 10:01 PDT (History)
17 users (show)
bob: in‑testsuite-
bob: in‑litmus-
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image David Humphrey (:humph) 2008-03-27 13:29:35 PDT
I've been developing a web app using extjs, and I was trying to debug some dom scrolling code, and the browser crashed.  I was able to reproduce it just about every time, and it seemed to happen when Firebug (1.1) was installed and enabled.

I've attached a reduced test case so you can see for yourself.

Steps to Reproduce:

1) Install Firebug 1.1
2) Unzip and open crash.html
3) Enable Firebug for Local Web Pages
4) Click a node in the treepanel.

This should cause it to crash--it does for me every time.
Comment 1 User image David Humphrey (:humph) 2008-03-27 13:38:22 PDT
My zip is too big, with extjs included, so here is a link:

http://cs.senecac.on.ca/~david.humphrey/tmp/firebugcrash.zip
Comment 3 User image John J. Barton 2008-03-27 13:55:21 PDT
See also 425452, top frames are the same.
Comment 4 User image Brian Crowder 2008-03-27 15:57:15 PDT
I can't get this to crash with firebug1.2, and I can't get firebug1.1 (from a very recent svn) to work (ie, show UI at all) in my trunk nightly.  John J. Barton:  Is there a fix/patch for firebug1.1 that I need?
Comment 5 User image John J. Barton 2008-03-27 16:10:59 PDT
You could use the release at http://getfirebug.com.

If you use branches/firebug1.1 you'll need to run ant build.xml to get install.rdf . http://code.google.com/p/fbug/source/browse/branches/readme.txt
Comment 6 User image Brian Crowder 2008-03-27 16:35:42 PDT
I did run ant.  Nevertheless, I get a number of "failed to load XPCOM components" (for things in my .svn directory, weirdly) and then an "Error: no element found" from chrome://firebug/content/browserOverlay.xul line 1, followed by a "failed to load overlay" warning.

I'll try the release.
Comment 7 User image John J. Barton 2008-03-27 16:48:38 PDT
(In reply to comment #6)
> I did run ant.  Nevertheless, I get a number of "failed to load XPCOM
> components" (for things in my .svn directory, weirdly) 

This is a FF3 "feature", happens when you rebuild your profile.  Just run FF again if you don't like the messages, I can't do anything about them.

> and then an "Error: no
> element found" from chrome://firebug/content/browserOverlay.xul line 1,

Also a FF message, very unlikely the error is on line 1. Or even in that xul file :-(  I've not seen this.

> followed by a "failed to load overlay" warning.

Wow, that's cool! I've never actually seen a message when overlays fail.

You might just try it with FF2, I don't know that 1.1 has been run off of svn against FF3.

> 
> I'll try the release




Comment 8 User image David Humphrey (:humph) 2008-03-27 19:51:44 PDT
fwiw I'm using FB 1.1.0b11 - http://getfirebug.com/releases/firebug/1.1/firebug-1.1.0b11.xpi
Comment 9 User image John J. Barton 2008-03-28 08:54:57 PDT
I've requested blocking FF3 for this crash. I have a similar one if this one can't be reproduced.
Comment 10 User image Brian Crowder 2008-03-28 09:42:52 PDT
John:  Please describe your "similar one" fully?
Comment 11 User image John J. Barton 2008-03-28 10:07:28 PDT
Please see bug 425452
Comment 12 User image Mike Shaver (:shaver -- probably not reading bugmail closely) 2008-03-29 02:57:50 PDT
Do we know when this regressed?
Comment 13 User image Henrik Skupin (:whimboo) 2008-03-29 10:45:19 PDT
*** Bug 425648 has been marked as a duplicate of this bug. ***
Comment 14 User image Henrik Skupin (:whimboo) 2008-03-29 10:48:31 PDT
Igor, possibly a regression from your patch on bug 421266?
Comment 15 User image John J. Barton 2008-03-29 11:02:55 PDT
(In reply to comment #12)
> Do we know when this regressed?
> 
I have crashes from 3/14 (FF3b4) that could be similar if we assume the stack is bogus per 425452:
http://crash-stats.mozilla.com/report/index/9a2b04c5-f250-11dc-ba3e-001a4bd46e84
Frame  	Signature  	Source
0 	@0x20202a 	
1 	js_Invoke 	
2 	@0x46a06011 	
3/18 (FF3b5pre) is closer 
http://crash-stats.mozilla.com/report/index/ae1c3c9c-f501-11dc-a170-001a4bd46e84

I used FF3b4 quite a bit so I'd put my bet on early in b5pre.
Comment 16 User image Igor Bukanov 2008-03-29 11:10:36 PDT
(In reply to comment #14)
> Igor, possibly a regression from your patch on bug 421266?
> 

Is it based on the stack trace alone? AFAICS the trace just tells that the crash happens somewhere in js_Interpret.
Comment 17 User image Henrik Skupin (:whimboo) 2008-03-29 11:14:52 PDT
Got the same crash under OS X 10.5 after installing Firebug 1.1b12, visited the following crashreporter site and clicked on Frames. Seems to be a simpler testcase as the one from comment 1.

bp-43687935-fdb7-11dc-8adb-001a4bd43ef6
Comment 18 User image Henrik Skupin (:whimboo) 2008-03-29 12:34:14 PDT
(In reply to comment #16)
> Is it based on the stack trace alone? AFAICS the trace just tells that the
> crash happens somewhere in js_Interpret.

Yes, and I'm sorry. The assumption was wrong. I did a regression test and found a regression window between 20080322-04 and 20080323-04.

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-03-22+03%3A00%3A00&maxdate=2008-03-23+05%3A00%3A00&cvsroot=%2Fcvsroot

Igor, bug 424376 would fit into this timeframe. Could this be the cause?

It's reproducible for me when logging into Gmail. I have to wait some seconds, then Firefox crashes.
Comment 19 User image Paul-Kenji Cahier 2008-03-30 09:41:15 PDT
I cant see how this is intended behaviour?
Forbidding a download based on a filename policy that can not be disabled/seen anywhere?
Comment 20 User image Mike Shaver (:shaver -- probably not reading bugmail closely) 2008-03-30 09:44:57 PDT
(In reply to comment #19)
> I cant see how this is intended behaviour?
> Forbidding a download based on a filename policy that can not be disabled/seen
> anywhere?

Are you commenting in the right bug?
Comment 21 User image Paul-Kenji Cahier 2008-03-30 09:45:40 PDT
Sorry about that one, wrong manipulation.
Comment 22 User image Henrik Skupin (:whimboo) 2008-03-30 16:03:35 PDT
(In reply to comment #15)
> I have crashes from 3/14 (FF3b4) that could be similar if we assume the stack
> is bogus per 425452:

Mmh, I think that I was wrong with my latest tests. If you really have crashes from 03/14 I probably see a different bug which has mainly the same stacktrace and is caused by some other inconsistencies. I'll try to find some time tomorrow to take a look at the mentioned testcase from comment 1. I hope to find the real regression window now.
Comment 23 User image Paul-Kenji Cahier 2008-03-31 16:47:06 PDT
On a side note, disabling firebug seems to have fixed the crashes here(not a single one in two days, vs 2-3 before)
Comment 24 User image John J. Barton 2008-03-31 17:04:16 PDT
(In reply to comment #17)
> Got the same crash under OS X 10.5 after installing Firebug 1.1b12, visited the
> following crashreporter site and clicked on Frames. Seems to be a simpler
> testcase as the one from comment 1.
> 
> bp-43687935-fdb7-11dc-8adb-001a4bd43ef6
> 

This one has Firebug on the stack.  Can you try with FF3pre? 
Comment 25 User image Chris Tyler 2008-04-01 14:02:37 PDT
We've done some regression testing and it looks like the problem first appeared on 03-23 (03-21, 03-22 are ok, 03-23 onward crash -- 03-29 didn't seem to crash either (?)).
Comment 26 User image Brian Crowder 2008-04-01 14:28:54 PDT
That would incriminate bug 424376, which has been backed out.  Recent builds should no longer exhibit this issue.  Is that the case?
Comment 27 User image John J. Barton 2008-04-01 14:45:29 PDT
2008032805 crashed for me
2008033105 did not.
This is for my version of this crash.
Comment 28 User image Brian Crowder 2008-04-01 14:47:41 PDT
Marking fixed by the backout of bug 424376.
Comment 29 User image Matthias Versen [:Matti] 2008-04-03 09:22:28 PDT
*** Bug 426758 has been marked as a duplicate of this bug. ***
Comment 30 User image Bob Clary [:bc:] 2008-04-04 23:06:14 PDT
a non-firebug test case would be greatly appreciated by all.
Comment 31 User image Brian Crowder 2008-04-11 15:08:03 PDT
*** Bug 426892 has been marked as a duplicate of this bug. ***
Comment 32 User image Paweł Smoliński 2008-04-28 14:45:00 PDT
*** Bug 431206 has been marked as a duplicate of this bug. ***
Comment 33 User image Arie Paap [:wildmyron] 2009-07-16 21:35:54 PDT
*** Bug 487417 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.