Display of endless loop after posting page. Worked fine with Firefox 2.0.0.7 and all other browsers (Opera, IE 6/7 etc.)

RESOLVED INCOMPLETE

Status

()

Firefox
Security
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Sascha G. Ernst, Unassigned)

Tracking

({regression})

2.0 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

Enter any amount under "Kreditbetrag:" and select any option under "Verwendungszweck", press the "Weiter" Button and post the page. You get an endless loop "Ihr Wunschkredit wird berechnet" and not the requested page. Worked fine with Firefox 2.0.0.7 and ist still working fine with other browsers (Opera, IE 6/7 etc.)

Reproducible: Always

Steps to Reproduce:
1. Enter https://ssl.naspa.de/konto_finanzspielraum/privatkundenkredite/naspa_online_kredit/naspa_online_kredit.html?no_cache=1

2. Fill out form with any amount under "Kreditbetrag:" and select any option under "Verwendungszweck", then press the "Weiter" Button and post the page
Actual Results:  
An endless loop "Ihr Wunschkredit wird berechnet" will be shown

Expected Results:  
"Ihr Wunschkredit wird berechnet" should be displayed for about 5-15 seconds only. After that a result page should appear.

Should display result page like Firefox 2.0.0.7 (Windows-Plattform) or Opera or IE 6/7
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0 Branch
Wfm with Firefox 2.0.0.13 on win32.

Reporter: Do you get the same problem if you run Firefox in the Firefox safemode ?
http://kb.mozillazine.org/Safe_Mode
(Reporter)

Comment 2

10 years ago
Same problem if running Firefox in safemode:

"C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode
I don't know why this works for me then.
You could try to clear the disk cache and cookies and if that doesn't work you could try to create and use an additional firefox Profile.

(http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows )
(Reporter)

Comment 4

10 years ago
You get a result page containing a credit offer after posting the mentioned page? If you get the "Ihr Wunschkredit wird berechnet" loop and nothing more you see the problem. 

I tried it on several PCs and one Apple Mac with version 2.0.0.12 and 2.0.0.13. It won t work there. What version are you using? 

Changes to cookies or cache won t resolve the problem. I also tried several firefox Profiles. Nothing worked at all ;(
Sorry, you are right, it doesn't work forme  now but I tested it at comment #1 (wfm= works for me) but it's possible that I used by an accident Firefox 3 beta4.

This works in the trunk (Firefox Beta4, Seamonkey trunk) but not in the branch.
Someone needs to test when this broke on the branch and must find a good component for this but I don't think this will be fixed in FF2.0.0.X because it works on the trunk (the coming Firefox3)
ok, i get this error when the content should be displayed.
Error: uncaught exception: Permission denied to call method Location.toString
Status: UNCONFIRMED → NEW
Component: General → Security
Ever confirmed: true
Keywords: regression
QA Contact: general → firefox
Can someone find a smaller regression range, using the -mozilla1.8 builds from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/ ?

This might have been caused by script on the page breaking due to security changes.
Keywords: qawanted
works in 2007-08-07-03-mozilla1.8/ (Gecko/20070807 BonEcho/2.0.0.7pre)
broken in 2007-08-08-04-mozilla1.8/

But my triage in this bug really sucks, i didn't notice that used a trunk build instead of of branch and the error message from comment #6 seems to be unrelated because i get this error also in a working Firefox build and also in my SM trunk
I can confirm the regression range, though 1 out of about 5 attempts with the 2007080804 build didn't get stuck. Bonsai query:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=MOZILLA_1_8_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-08-07+00%3A00&maxdate=2007-08-08+04%3A00&cvsroot=%2Fcvsroot

candidates: bug 390488 and bug 354595. Neither looks likely to me.

Only other thing I noticed is that the loading animation is actually a flash object.
Does the failing build give that toString() error?
Bz: You get the string error in all builds (working and not working) and this is only broken in the branch but works on the trunk
For what it's worth, my (Linux) branch build pulled on Friday is not showing the problem...  If someone has a self-build that does, they could try disabling the patches mentioned in comment 9...
FWIW, the test page no longer renders any content.  Considering the age of this bug and its lack of activity, resolving incomplete.  Please reopen if you can reproduce this bug on the latest Firefox and provide a valid testcase.

Thanks.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: qawanted
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.