offline dialog checkboxes can't be (un)ticked

VERIFIED FIXED

Status

Thunderbird
Mail Window Front End
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Tuukka Tolvanen (sp3000), Assigned: philor)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

2.81 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
Account settings -> an imap or nntp account -> offline & disk space -> select newsgroups for offline use: click at checkboxes next to folders:
result: no effect
expected: checkbox state changes

tbird trunk linux 20080323
Flags: blocking-thunderbird3.0a1?

Comment 1

10 years ago
It would be interesting to try and narrow down the regression range here.  This problem has been around for at least a month or so, possibly considerably longer.
Keywords: regression
Whiteboard: qawanted

Updated

10 years ago
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 2

10 years ago
Sigh. Regression window would be 2008-03-02 16:03, because http://mxr.mozilla.org/seamonkey/source/mailnews/base/resources/content/msgSynchronize.js#127 depends on the definition of msgWindowContractID that used to be in mail/base/content/mailWindow.js, and mailnews/base/resources/content/msgSelectOffline.xul thinks that by including mailWindow.js, it can save 15 characters of typing in  msgSynchronize.js (at the expense of rather extreme action at a distance).
Blocks: 416666
Whiteboard: qawanted
(Assignee)

Comment 3

10 years ago
Created attachment 312423 [details] [diff] [review]
Fix v.1
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #312423 - Flags: superreview?(neil)
Attachment #312423 - Flags: review?(neil)
(Assignee)

Updated

10 years ago
Duplicate of this bug: 426072

Comment 5

10 years ago
(In reply to comment #2)
> mailnews/base/resources/content/msgSelectOffline.xul thinks that by including
> mailWindow.js, it can save 15 characters of typing in msgSynchronize.js (at
> the expense of rather extreme action at a distance).
Was this the only reason it included mailWindow.js?
(Assignee)

Comment 6

10 years ago
Created attachment 312838 [details] [diff] [review]
Fix v.2

Indeed, near as I can tell that's the only thing it was providing. Of course, I'm the same one who reviewed causing the regression in the first place, so it's hard to say just how well I can tell...
Attachment #312423 - Attachment is obsolete: true
Attachment #312423 - Flags: superreview?(neil)
Attachment #312423 - Flags: review?(neil)
Attachment #312838 - Flags: superreview?(neil)
Attachment #312838 - Flags: review?(neil)

Updated

10 years ago
Attachment #312838 - Flags: superreview?(neil)
Attachment #312838 - Flags: superreview+
Attachment #312838 - Flags: review?(neil)
Attachment #312838 - Flags: review+
(Assignee)

Comment 7

10 years ago
mailnews/base/resources/content/msgSelectOffline.xul 1.29
mailnews/base/resources/content/msgSynchronize.js 1.22
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

10 years ago
v 2008051911 that checkbozes get and lose ticks on click as expected
Status: RESOLVED → VERIFIED
Flags: blocking-thunderbird3.0a1?
You need to log in before you can comment on or make changes to this bug.