Closed Bug 425859 Opened 14 years ago Closed 12 years ago

Decryption problems cause login to fail with a non-descriptive error

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: hello, Unassigned)

References

Details

When an incorrect passphrase is given, openssl fails with an error which weave doesn't correctly process.

There is also another, nastier, class of openssl failures which seem to occur with the correct passphrase.  Cause or STR are unknown.
Depends on: 426655
Duplicate of this bug: 426655
Duplicate of this bug: 428388
Targeting 0.2 (P1).
Changing title to remove openssl, since we'll have some of these problems with NSS as well.
Priority: -- → P1
Summary: Login or sync fails with openssl errors → Decryption problems cause login to fail with a non-descriptive error
Target Milestone: 0.1 → 0.2
Blocks: 433899
Depends on: 433949
Duplicate of this bug: 437999
Punting this for 0.3.
No longer blocks: 433899
Target Milestone: 0.2 → 0.3
These bugs need to be triaged, removing 0.3 milestone setting.
Target Milestone: 0.3 → Future
Component: Weave → General
Product: Mozilla Labs → Weave
QA Contact: weave → general
Component: General → Sync
Priority: P1 → --
QA Contact: general → sync
Target Milestone: Future → ---
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.