Closed Bug 428388 Opened 14 years ago Closed 14 years ago

Weave frequently stops being able to sync

Categories

(Cloud Services :: General, defect)

x86
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 425859

People

(Reporter: joe, Unassigned)

Details

Yesterday (or the day before) I manually deleted the contents of my services.mozilla.org directory via WebDav because I was getting a red "Error" icon from Weave. Today, I find the same thing, with the same error:

2008-04-10 16:23:19	Async.Generator	ERROR	Exception caught in WeaveLockWrapper: openssl did not run successfully, error code 1

Here's some more data, but I can give whatever's necessary upon request.


2008-04-10 16:23:12	Service.Crypto	DEBUG	Decrypting data
2008-04-10 16:23:12	Service.Util	DEBUG	Running command: /Users/joe/Library/Application Support/Firefox/Profiles/pk40wdbu.default/extensions/{340c2bbc-ce74-4362-90b5-7c26312808ef}/openssl/unix/exec.sh /Users/joe/Library/Application Support/Firefox/Profiles/pk40wdbu.default/weave/tmp openssl aes-256-cbc -d -a -salt -in input -out output -pass file:pass
2008-04-10 16:23:12	Service.Crypto	DEBUG	Done decrypting data
2008-04-10 16:23:12	Service.BmkEngine	INFO	Local snapshot version: 3
2008-04-10 16:23:12	Service.BmkEngine	INFO	Server status: 0
2008-04-10 16:23:12	Service.BmkEngine	INFO	Server maxVersion: 3
2008-04-10 16:23:12	Service.BmkEngine	INFO	Server snapVersion: 0
2008-04-10 16:23:12	Service.BmkEngine	INFO	Sync complete: no changes needed on client or server
2008-04-10 16:23:12	Service.HistEngine	INFO	Beginning sync
2008-04-10 16:23:12	Service.DAV	DEBUG	GET request for user-data/
2008-04-10 16:23:13	Service.DAV	DEBUG	GET request for user-data/history/
2008-04-10 16:23:13	Service.HistEngine	DEBUG	Getting status file from server
2008-04-10 16:23:13	Service.DAV	DEBUG	GET request for user-data/history/status.json
2008-04-10 16:23:14	Service.HistEngine	INFO	Got status file from server
2008-04-10 16:23:14	Service.DAV	DEBUG	GET request for user-data/history/keys.json
2008-04-10 16:23:14	Service.Util	DEBUG	Running command: /Users/joe/Library/Application Support/Firefox/Profiles/pk40wdbu.default/extensions/{340c2bbc-ce74-4362-90b5-7c26312808ef}/openssl/unix/exec.sh /Users/joe/Library/Application Support/Firefox/Profiles/pk40wdbu.default/weave/tmp openssl base64 -d -in input -out tmp-output
2008-04-10 16:23:14	Service.Util	DEBUG	Running command: /Users/joe/Library/Application Support/Firefox/Profiles/pk40wdbu.default/extensions/{340c2bbc-ce74-4362-90b5-7c26312808ef}/openssl/unix/exec.sh /Users/joe/Library/Application Support/Firefox/Profiles/pk40wdbu.default/weave/tmp openssl rsa -in key -out tmp-key -passin file:pass
2008-04-10 16:23:14	Service.Util	DEBUG	Running command: /Users/joe/Library/Application Support/Firefox/Profiles/pk40wdbu.default/extensions/{340c2bbc-ce74-4362-90b5-7c26312808ef}/openssl/unix/exec.sh /Users/joe/Library/Application Support/Firefox/Profiles/pk40wdbu.default/weave/tmp openssl rsautl -decrypt -inkey tmp-key -in tmp-output -out output
2008-04-10 16:23:14	Service.HistEngine	INFO	Downloading server deltas
2008-04-10 16:23:14	Service.DAV	DEBUG	GET request for user-data/history/deltas.json
2008-04-10 16:23:18	Service.Crypto	DEBUG	Decrypting data
2008-04-10 16:23:18	Service.Util	DEBUG	Running command: /Users/joe/Library/Application Support/Firefox/Profiles/pk40wdbu.default/extensions/{340c2bbc-ce74-4362-90b5-7c26312808ef}/openssl/unix/exec.sh /Users/joe/Library/Application Support/Firefox/Profiles/pk40wdbu.default/weave/tmp openssl aes-256-cbc -d -a -salt -in input -out output -pass file:pass
2008-04-10 16:23:18	Service.DAV	DEBUG	UNLOCK request for 
2008-04-10 16:23:19	Async.Generator	ERROR	Exception caught in WeaveLockWrapper: openssl did not run successfully, error code 1
2008-04-10 16:23:19	Async.Generator	DEBUG	Stack trace:
JS frame :: chrome://browser/content/browser.xul :: oncommand :: line 1
JS frame :: chrome://weave/content/sync.js :: Sync_doSync :: line 260
JS frame :: file:///Users/joe/Library/Application%20Support/Firefox/Profiles/pk40wdbu.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/service.js :: WeaveSync_sync :: line 498
JS frame :: unknown (async) :: WeaveLockWrapper






JS frame :: file:///Users/joe/Library/Application%20Support/Firefox/Profiles/pk40wdbu.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/util.js :: EL_notify :: line 354
JS frame :: file:///Users/joe/Library/Application%20Support/Firefox/Profiles/pk40wdbu.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/async.js :: anonymous :: line 214
JS frame :: file:///Users/joe/Library/Application%20Support/Firefox/Profiles/pk40wdbu.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/async.js :: AsyncGen__done :: line 237
JS frame :: file:///Users/joe/Library/Application%20Support/Firefox/Profiles/pk40wdbu.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/async.js :: anonymous :: line 103
JS frame :: file:///Users/joe/Library/Application%20Support/Firefox/Profiles/pk40wdbu.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/async.js :: AsyncGen_cont :: line 188
JS frame :: file:///Users/joe/Library/Application%20Support/Firefox/Profiles/pk40wdbu.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/engines.js :: BmkEngine__getServerData :: line 564
JS frame :: unknown (async) :: Crypto_PBEdecrypt
BTW, this comes and goes pretty frequently.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425859
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.