WINNT 5.2 sb-win32-tbox Dep tinderbox need SDK / environment upgrades

VERIFIED FIXED

Status

Webtools Graveyard
Tinderbox
--
major
VERIFIED FIXED
10 years ago
4 years ago

People

(Reporter: jimm, Assigned: Fallen)

Tracking

({regression})

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
Both of these appear to be missing the Vista 6.0 SDK and are broken at the moment. See bug 424159 for a similar problem with win32 unit test.
(Reporter)

Updated

10 years ago
Blocks: 412374
(Reporter)

Updated

10 years ago
OS: Windows Vista → Windows Server 2003

Comment 2

10 years ago
Maybe Bug 392438 will solve this too.
(Assignee)

Comment 3

10 years ago
Created attachment 314537 [details] [diff] [review]
Disable parental controls on sb-win32-tbox

Alternatively, we can just disable parental controls until we have code that uses the service.
Assignee: build → philipp
Status: NEW → ASSIGNED
Attachment #314537 - Flags: review?(ause)
(Assignee)

Comment 4

10 years ago
Created attachment 314539 [details] [diff] [review]
Disable parental controls on sb-win32-tbox
[Checkin: Comment 5]

Sorry, was missing the other bits.
Attachment #314537 - Attachment is obsolete: true
Attachment #314539 - Flags: review?(ause)
Attachment #314537 - Flags: review?(ause)

Updated

10 years ago
Attachment #314539 - Flags: review?(ause) → review+
(Assignee)

Comment 5

10 years ago
Checked in on HEAD
 tinderbox-configs/sunbird/win32/mozconfig: 1.34 -> 1.35.
 tinderbox-configs/lightning/win32/mozconfig: 1.4 -> 1.5.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Wouldn't it have been better to disable parental controls in Calendar's build config, rather than in the tinderbox configs specifically?
Oh, I didn't realize it was a specific machine config issue, ignore my last comment.
(Reporter)

Comment 8

10 years ago
I'm not as fan of marking this as resolved fixed. The problem isn't fixed. The machines have the wrong sdk installed on them. Disabling a feature doesn't prevent this breakage from happening again in the future.
(Assignee)

Comment 9

10 years ago
I'm fine with reopening this bug, I was (maybe falsely) assuming the rest of this bug will be fixed by bug 392438. Until either resolved as duplicate or taken care, REOP.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 10

10 years ago
I guess if "community Windows machines" includes these, we can close this out again. I just wanted to make sure it was open somewhere so they get updated at some point.
This regressed "again":

<http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-l10n/1208356457.1208357099.2976.gz>
{{
WINNT 5.2 sb-win32-tbox Clobber Sb-Trunk-l10n on 2008/04/16 07:34:17

Build Error Summary

configure: error: System header atlbase.h is not available. See http://developer.mozilla.org/en/docs/atlbase.h for details on fixing this problem.

Build Error Log

checking for mmintrin.h... (cached) no
checking for oleacc.idl... (cached) no
checking for atlbase.h... (cached) no
checking for wpcapi.h... (cached) no
}}

Benjamin,
this looks very similar to bug 428683 comment 4...
Depends on: 426065
Keywords: regression

Comment 12

10 years ago
Yes it does... what SDK is installed on this machine, and which compiler is it using? Is there a tinderbox log from a clobber build? And, it may be necessary to get ahold of the config.log from that box (from a clobber build)... is that possible?

Comment 13

10 years ago
don't know what Platform SDK is installed but the compiler is a .net 2005

------
Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 14.00.50727.42 for 80x86
Copyright (C) Microsoft Corporation.  All rights reserved.
------

professional with atl headers at their place and INCLUDE seems to reference them correct.

Comment 14

10 years ago
the cause seems to be that the build environment is still cygwin based.
in configure the following lines (around line 6677) generated by AC_CHECK_HEADERS
---------
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
{ (eval echo configure:6678: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
---------
don't work as the second grep command doesn't accept the dos lineend in the compiler output...

Updated

10 years ago
Depends on: 392438
Blocks: 428683
Benjamin,
dumb question:
is the build process still supposed to support (both msys and) cygwin,
or is it only these boxes which have not yet been upgraded to a/the currently supported environment ?

Comment 16

10 years ago
Created attachment 316429 [details] [diff] [review]
Skip header checks on cygwin... feh
[Checkin: Comment 21-22]

ause, could you please try this patch? You will need to 1) regenerate configure using autoconf-2.13 and 2) remove config.cache
Attachment #316429 - Flags: review?(ted.mielczarek)
Comment on attachment 316429 [details] [diff] [review]
Skip header checks on cygwin... feh
[Checkin: Comment 21-22]

works for me.
Attachment #316429 - Flags: review?(ted.mielczarek) → review+

Comment 18

10 years ago
(In reply to comment #16)
> Created an attachment (id=316429) [details]
> Skip header checks on cygwin... feh
> 
> ause, could you please try this patch? You will need to 1) regenerate configure
> using autoconf-2.13 and 2) remove config.cache
> 
would probably work fine but i found out that there is no autoconf on that machine at all. will have to workaround that...

Comment 19

10 years ago
configure generated with this patch applied gives me a complete build again. (http://tinderbox.mozilla.org/showlog.cgi?log=Sunbird/1208533440.1208539912.19074.gz)
Confirmed:
The comment 11 (failing) check for the 4 files is replaced by
<http://tinderbox.mozilla.org/showlog.cgi?log=Sunbird/1208533440.1208539912.19074.gz&fulltext=1>
{{
WINNT 5.2 sb-win32-tbox Depend Sb-Nightly on 2008/04/18 08:44:00

configure: warning: Using a cygwin build environment is unsupported. Configure cannot check for the presence of neceesary headers. Please upgrade to MozillaBuild; see http://developer.mozilla.org/en/docs/Windows_Build_Prerequisites
}}
Comment on attachment 316429 [details] [diff] [review]
Skip header checks on cygwin... feh
[Checkin: Comment 21-22]

>+        AC_MSG_WARN([Using a cygwin build environment is unsupported. Configure cannot check for the presence of neceesary headers. Please upgrade to MozillaBuild; see http://developer.mozilla.org/en/docs/Windows_Build_Prerequisites])

Nit: s/neceesary/necessary/

Comment 22

10 years ago
Landed the configure change on trunk. Does that mean this bug is FIXED or needs to stay open for the refplatform upgrade?
ummm... what refplatform upgrade? The patches above are for mozconfig, configure.in files, which are checked in.

...or maybe I'm missing something obvious?

Comment 24

10 years ago
(In reply to comment #23)
> ummm... what refplatform upgrade? The patches above are for mozconfig,
> configure.in files, which are checked in.
> 
> ...or maybe I'm missing something obvious?

Which is all a workaround, pending bug 392438.

(In reply to comment #20)
> Confirmed:

"WINNT 5.2 sb-win32-tbox Depend Sb-Nightly on 2008/04/18 17:36:00":
stayed green up to this build.

"WINNT 5.2 sb-win32-tbox Depend Sb-Nightly on 2008/04/18 18:58:00"
to
"WINNT 5.2 sb-win32-tbox Depend Sb-Nightly on 2008/04/21 06:11:00":
is red again, with previous "altbase.h missing" error.
ause, did you locally "unapply" the "test" patch ?

Current build has picked up the cvs checkin:
waiting for result.

***

"WINNT 5.2 sb-win32-tbox Depend Lt-Nightly on 2008/04/16 07:23:00":
went red too ... and should go green on next build too.
Attachment #316429 - Attachment description: Skip header checks on cygwin... feh → Skip header checks on cygwin... feh [Checkin: Comment 21-22]
Attachment #314539 - Attachment description: Disable parental controls on sb-win32-tbox → Disable parental controls on sb-win32-tbox [Checkin: Comment 5]
(In reply to comment #22)
> Does that mean this bug is FIXED or needs
> to stay open for the refplatform upgrade?

I would answer "yes, this box should still upgrade to the new environment".

Comment 27

10 years ago
(In reply to comment #25)
> (In reply to comment #20)
> > Confirmed:
> 
> "WINNT 5.2 sb-win32-tbox Depend Sb-Nightly on 2008/04/18 17:36:00":
> stayed green up to this build.
> 
> "WINNT 5.2 sb-win32-tbox Depend Sb-Nightly on 2008/04/18 18:58:00"
> to
> "WINNT 5.2 sb-win32-tbox Depend Sb-Nightly on 2008/04/21 06:11:00":
> is red again, with previous "altbase.h missing" error.
> ause, did you locally "unapply" the "test" patch ?
it did unapply with the next clobber build

Comment 28

10 years ago
(In reply to comment #23)
> ummm... what refplatform upgrade? The patches above are for mozconfig,
> configure.in files, which are checked in.
> 
> ...or maybe I'm missing something obvious?
> 
it's a cygwin related problem. refplatform will be based on msys.

Comment 29

10 years ago
this bug is FIXED and helping all builds that, for whatever reason, are still cygwin based.
there is still Bug 392438 which will handle the upgrade.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
I ran into this myself and actually I was glad it was fatal.  I had no idea that my Cygwin builds had been disabling features because configure had decided the required header files were missing until the error became fatal.

The better fix for Cygwin builds is to install the gnuwin32 version of grep and make sure that is earlier than the cygwin supplied grep in the path in your build environment.

Bill: no features were silently disabled, that was the whole point of these checks. Unfortunately these checks break with Cygwin, so instead your build will fail when it reaches the code that you don't have headers for. But really, there's no reason not to install MozillaBuild.
Status: RESOLVED → VERIFIED
(In reply to comment #31)
> Bill: no features were silently disabled, that was the whole point of these
> checks. Unfortunately these checks break with Cygwin, so instead your build
> will fail when it reaches the code that you don't have headers for. But really,
> there's no reason not to install MozillaBuild.
> 

I was not referring to the recently added checks.  When I discovered what was wrong it became obvious that other checks that have been in configure for a long time have been incorrectly determining that header files are absent when in fact they are not.
(In reply to comment #29)
> this bug is FIXED and helping all builds that, for whatever reason, are still
> cygwin based.
> there is still Bug 392438 which will handle the upgrade.

ause, coop: 

Ah, thanks. 

I thought "needs to stay open for the refplatform upgrade?" in comment#22 meant  "we need to produce a newly revised version of the ref platform".... hence my question. Instead it meant "move sunbird and other users to supported refplatform".

Glad there's no need to produce a new refplatform - sorry for the noise.

"WINNT 5.2 sb-win32-tbox Depend Lt-Nightly on 2008/04/21 09:59:00"
and
"WINNT 5.2 sb-win32-tbox Depend Sb-Nightly on 2008/04/21 08:14:00"
both went green :-)

Comment 35

10 years ago
Comment on attachment 316429 [details] [diff] [review]
Skip header checks on cygwin... feh
[Checkin: Comment 21-22]

>+    case "$host_os" in
>+    cygwin*)

$host_os doesn't necessarily contain "cygwin" on cygwin systems, it might just be "i586-pc-msvc" like in the case of tpol in bug 428683.

I think actually everything but "mingw" in the host string means we are on cygwin, actually...

Updated

7 years ago
Component: Tinderbox Configuration → Tinderbox
Product: mozilla.org → Webtools
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.