Firefox 3 Tab Replace All Tabs Option Not Available

RESOLVED DUPLICATE of bug 395024

Status

()

RESOLVED DUPLICATE of bug 395024
11 years ago
9 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

({regression})

unspecified
regression
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4

In Firefox 2, it was possible to configure Firefox so that when a group of tabs was open, you could choose choose a bookmark group and choose "Open All In Tabs", and it would replace all tabs with a new set of tabs  (I believe that was the default behaviour in Firefox 2).  This option is not available as far as I can tell in the Firefox 3 builds, and should at least be an option.  As pointed out in bug 395024, the browser.tabs.loadFolderAndReplace option does not work any more.

Reproducible: Always

Steps to Reproduce:
1. Open a group of tabs
2.  Choose a bookmark folder
3.  Choose "Open All In Tabs"
  
Actual Results:  
The new tabs are appended instead of replaced

Expected Results:  
If this option is set, the tabs should be replaced with the new tab set.
(Reporter)

Comment 1

11 years ago
It looks like the old behaviour was modified in bug 175124.
Probably a dupe of Bug 424265, which is possibly a duplicate of another bug.

Comment 3

11 years ago
I can confirm this bug was in rc5 

This has completely ruined firefox for me. I desparately want/need a way for it to work the old way or Firefox is unusable for me. My method of surfing is to open groups of taps from 10 to 15 at a time. Now I can no longer navigate through my groups. When I have 15 open and I click on the next group I now have 25 open. Then if I navigate to the next group I have 40 open. Who came up with this bright idea!!!

Help, is there an option to set somewhere so that it works like Firefox always has. Otherwise it looks like I’ll be forced back to IE!!! NOoooooo!!!

Comment 4

11 years ago
There is a big discussion and argument going on resulting in making browser.tabs.loadFolderAndReplace obsoleted !!!

I do not want to go to the core of the argument "should open in tabs" overwrite existing open tabs or append. Both sides are valid and legitimate uses.

Make one option a default - that would make supporters of one argument happy.
Keep browser.tabs.loadFolderAndReplace working so supporters of another argument can be happy too.

This may be silly but a lot of people are very unhappy with your arbitrary decision to go one way and lock out everybody else who do not agree with your choice. I am one of them and this alone may make me to stop using FF.

I cannot believe what I am writing here but in 2008 a community driven project behaves like Stalin in 1938. Get a grip, please.

Updated

11 years ago
Flags: blocking-firefox3?

Comment 5

11 years ago
I agree. Everyday I visit lots of sites, and I open them in blocks based on folder of bookmarks. I find it correct and comfortable for the "Open all in tabs" command to overwrite existing tabs, so that when I change the bookmark block, the tabs I already opened disappear.
Not going to block.  Yes, this is a change.  It would be good to fix, but not something we'll block on.
Flags: blocking-firefox3? → blocking-firefox3-

Comment 7

11 years ago
What does "not going to block" mean? Does that mean you are going to release without fixing this. How hard could it be to make a prior option functional again?

How can you release a non-dot-release that fundamentally changes how tabbed browsing works for millions of users without allowing them to set an option that puts it back the old way? I don't understand this. As a committed tabbed-browsing user, you are fundamentally breaking firefox for me and making it unusable for its primary purpose.

Comment 8

11 years ago
Summary :
A feature is added (loadfolderandreplace = true).
Peoples use this feature.
A bug (or something) is discovered with the feature.
The feature is removed. The bug is removed.

Result : peoples lose the feature. Peoples loses their interrest into the new other features.

I agree in the principle of not confusing newcomers with this option (loadfolderandreplace = false).
I find it strange to simply remove it or considering it as useless.

Do the masses have to make petitions to find out what feature they want or do not want ?

I'm waiting the release of the final to see how much will switch from 3 to 2 (also, how this will be handled).

Blocker is too much, major is totally true.

Comment 9

11 years ago
For those interested, I've posted the best workaround for this that i know about on my blog here:

http://www.daleisphere.com/work-around-for-firefox-3s-open-in-tabs-overwrite-bug/

If anyone discovers a plugin or ANYTHING that allows us to get back the old function, please post in the comment section of my blog or here. I'll monitor both. I still can't believe this is not getting fixed. I've been using RC1 for a couple weeks now and it **** me off a dozen times every day!

...Dale

Comment 10

11 years ago
There is a second way around this.

The extension Tab Mix Plus (the latest beta) will work properly in allowing the old behavior; I'm using it currently. Granted, Tab Mix Plus is still not finalized for Firefox 3, but at least it works.

I find it abhorrent that Mozilla decided to exclude this simple option, which should be at the discretion of the user. I mean, isn't that exactly what Firefox is about?

Comment 11

11 years ago
ajm786, 

I've got the latest Tab Mix Plus extension 0.3.6.1.080416 and I don't see an option that makes opening a set of tabs overwrite existing tabs? The best I can get it to do (as per my workaround that I linked above) is to close all tabs by middle clicking on an open tab and then opening your new set of tabs. And even that leaves one extra tab open on the left that I don't want.  Can you tell us how you got Tab Mix Plus to work the old way (opening a new set of tabs overwrites open tabs). Or maybe you were just referring to my multi-step work-around?

...Dale

Comment 12

11 years ago
OK. I'm not sure bugzilla should be the area to discuss of Tab Mix. The Dale's blog would be a better place. (two posts up)

As for the bug. I think it should be switched to opened.
Or else, Bug 395024 should be invoked instead

Comment 13

11 years ago
Hey foxensys ... I'm good with that ... I'm not looking to spam this board ... I'm just looking for the best possible solution to a FF3 bug that adversely affects me dozens of times a day. As soon as anything comes out that solves the problem, I'll post it on my blog and I'll stop posting here. I invite anyone else to post idas/options/work-arounds there too until we have a solution.

...Dale

Comment 14

11 years ago
(In reply to comment #13)
> ... I'm not looking to spam this board ...

It's ok for me. I didn't thought so.
I just think your blog is a better place to talk of Tab Mix, and Bugzilla is about bugs.

A way to keep things clear.

(Btw, I didn't noticed you were the one asking for help. Hioups !)

Comment 15

11 years ago
I also just downloaded Firefox 3 and I am gretly missing the feature of opening grouped tabs, that replaces the old ones.

I think this option is vital for many users, and hops that this feature will bea available again. If not, i'm personally is going back to Firefox 2.

Another thing - Why remove it in the first place - the loadfolderandreplace has always been an OPTION! Then people can decide on there own, what they want.

You broke my firefox:-(

/Morten

Comment 16

11 years ago
I realize that this is not the place to discuss add-ons, but, as I said previously, Tab Mix Plus extension 0.3.6.1.080416 works perfectly. I don't know what option specifically inside it controls the tab overwrite feature; it might be of a different wording. All I know is that it works. I'm using it right now both at work and at home, and it works flawlessly. When I open 6 tabs using the "Open all in tabs" option, it REPLACES (overwrites) any/all tabs that may be open at the time; similarly, when those tabs are open, and I open any other group of tabs, they overwrite the ones that are already open, so that I don't end up with more than the amount of tabs that I'm requesting to open at any given time.

Another factor? Well, when I disable the plugin, Firefox 3 goes back to the append behavior. So I am absolutely 100% sure that the Tab Mix Plus extension 0.3.6.1.080416 works for what you want it to.

Comment 17

11 years ago
Well I wish you would tell us how? What settings did you set. I have (well had) that extension (the exact version) and it did NOT do what you say in its default. As I wrote in my piece above I could get it to do the 'two step' method but I didn't find any option to make it work the way FireFox 2 did. Can you tell us EXACTLY how you configured it so we can try your approach. Or, as discussed post in my blog exactly what options you changed to maake it work that way. As per my blog post, I moved to the "Tab Clicking Options 0.6.9" to do the two-step approach I had gotten Tam Mix Plus to do. I did that because its smaller extension with much less overhead. But, if Tab Mix Plus really could work the way FF used to work (ie: 1 middle click on any tab group overwrites existing tabs) I'd go back and use it.

...Dale

Comment 18

11 years ago
I can't do that, because I said I don't really recognize all the settings. Frankly, there's literally hundreds of settings I can set. 

What I CAN do is send you my settings for Tab Mix Plus. If you recall, Tab Mix Plus has an option to export settings. Perhaps if you give me your e-mail address, I can send you an export of my settings, and you can give it a shot. This way it should work, because all I did was UPGRADE the Tab Mix Plus when I moved from FF2 to FF3. So in effect, my settings carried over from my previous install.

Comment 19

11 years ago
OK, please do send them to info@daledietrich.com ... if I can figure out a way to import your settings into Tab Mix Plus I'll give that a try and do some sleuthing. 

Thanks.

Comment 20

11 years ago
ajm786's Tab Mix Plus workaround works. It is still a two-click solution but its faster and easier than the others so far. I updated my post to show how it works:

http://www.daleisphere.com/work-around-for-firefox-3s-open-in-tabs-overwrite-bug/

Thanks ajm and Francois X (who sent me a follow-up email) for helping me figure this out. It's the best work-around to date.

...Dale

Comment 21

11 years ago
confirming - seem to be quite a lot of requests for this.
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Linux → All
Hardware: PC → All

Comment 22

10 years ago
confirmed here.  Please fix this - "open all in tabs" was my most-used feature in FF2; now it's not just useless, it's destructive.

Comment 23

10 years ago
I would really like a one click solution to this

Comment 24

10 years ago
Right now, "Open in Tabs" does not "only append, leave this tab clear."  Instead it "take this end tab, and append the rest."

FF2 did "only append, leave the rest clear."  I'd like that option back, please.

Comment 25

10 years ago
Hi, 
i'd like to see this old behavior back in FF3.
Please excuse my poor english ;)

bye.

Comment 26

10 years ago
Please add this old behavior back in FF3. I don't want to be stuck using FF2 :(

Comment 27

10 years ago
I have been testing FF3 and I am really disappointed.
FF2: I open 5 tabs in 1 window, after I open 5 other tabs. The first 5 are closed and the new 5 tabs are opened in the same window.
FF3 opens the new 5 in the same window as the old 5 and that means there are now 10 tabs in 1 window.
Dear Mozilla - Firefox team,
Why do I have to now open a new window in FF3 each time?
Sorry, I will not upgrade before that tab/window problem is solved.
FF2 works fine and is an excellent browser.

Comment 28

10 years ago
Yes. A real pitty.

Please note a workaround exists (7 lines up).

More info over there :
http://www.daleisphere.com/work-around-for-firefox-3s-open-in-tabs-overwrite-bug/

This way, one can benefits from FF3 added features with the former tabs behaviour.

Comment 29

10 years ago
I found this extension that solved it:
https://addons.mozilla.org/en-US/firefox/addon/8254

Install it, and the next time you load a bookmark folder all the existing tabs will be replaced :)

Comment 30

10 years ago
I have the inverse, where I want all the tabs to append and NOT replace a single one.  I didn't need an extension to do that.  I've installed Tab Mix Plus to do it.
have you tried with CTRL(or CMD)+SHIFT+CLICK on the container?

Comment 32

10 years ago
(In reply to comment #31)
> have you tried with CTRL(or CMD)+SHIFT+CLICK on the container?

We all have.  It replaces the tab you have currently selected with the first bookmark in the folder you select.  If you had N tabs and your folder had X tabs, you end up with N + X -1 tabs.

Most people used to FF2 behaviour find this a problem.  They expect N + X tabs.
no reason to have 2 bugs about the same  problem.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395024
You need to log in before you can comment on or make changes to this bug.