Open with (do this automatically) broken

RESOLVED DUPLICATE of bug 285976

Status

()

RESOLVED DUPLICATE of bug 285976
11 years ago
11 years ago

People

(Reporter: vargvik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

When opening certain files from certain websites, the Open With (even though the do this automatically for files of this type... button is ENABLED) - the Open with dialog still shows. What even more strange is that the Open with dialog has the 'Do this automatically...' checked, so it probably isn't even checking that setting or something.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
We really need to know the types of files you're trying to open in order to adequately triage this bug.  But, it sounds like you're reporting the same issue that was reported in 427063, so I'm marking this bug as a duplicate of that one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 427063
(Reporter)

Comment 2

11 years ago
I don't think this is a duplicate of bug 427063, because in this case media type is known. Look at the screenshot below. Even after selecting 'Do this automatically...' and uTorrent is selected as the default application and Firefox recognizes the file as a torrent file, it still pops up the Open with dialog everytime. Note that this does not happen on all sites.
This is the site where I tried this: http://btjunkie.org/torrent/Music-Video-Hits-2007/4032291f10635c4f34e5721787ab9e439aad3af817ec

But I noticed it happens almost always for .wmv files
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

11 years ago
I forgot the link to the screenshot: http://img2.freeimagehosting.net/uploads/445bc9fb06.jpg

Comment 4

11 years ago
Examination of the Http headers from the server on the download link shows:

content-disposition: attachment; filename="Music_Video_Hits_2007.torrent"

This instructs the browser to explicitly prompt the user for further action, so doing something automatically will violate RFC 2183, see https://bugzilla.mozilla.org/show_bug.cgi?id=285976#c4

Comment 5

11 years ago
Yeah, we're discussing how to handle content-disposition: attachment in bug 285976.  So, this is actually a dupe of that.  Thanks for clarifying the issue!

Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 285976
You need to log in before you can comment on or make changes to this bug.