contents of other regions or windows showing up while loading a new page (offscreen buffer residual)

VERIFIED DUPLICATE of bug 34283

Status

()

Core
Layout
P1
normal
VERIFIED DUPLICATE of bug 34283
18 years ago
17 years ago

People

(Reporter: hirata masakazu, Assigned: Marc Attinasi)

Tracking

({polish})

Trunk
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
Have 2 browser windows (A and B) showing different contents.  (Better to be on a
slow machine with low memory.)

Say window A is in the front and B is in the back.
Load a new page in A and switch to window B while A is loading a new page. Make
sure a part of A is visible.

You can see that the window A clears and then shows the content of B before
displaying the content of new page.


Wouldn't it make it much with less memory, if Mozilla did not do this?

Comment 1

18 years ago
over to layout for further investigation.  This is probably easily duped against
some other bug but I didn't see it.
Assignee: asa → clayton
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen

Comment 2

18 years ago
Mark, can you please triage this from Clayton's list.
Assignee: clayton → attinasi
(Assignee)

Comment 3

18 years ago
The problem is that the offscreen buffer used to render into is shared across 
all of the windows. When the new window is being updated, if the connection is 
too slow, there is nothing new to paint the first time through the update so it 
ends up painting whatever was left in the offscreen buffer. This is a know 
problem. I'll search for the duplicate now...
(Assignee)

Comment 4

18 years ago
OK - I couldn't find the duplicate, so this will become the reference bug 
against which future incarnations will be dupe'd. 

A related bug is bug 31981, however it is much more specific than this general 
description. It does point to the most likely solution to the problem, however.
Severity: major → normal
Status: NEW → ASSIGNED
OS: Mac System 8.6 → All
Hardware: Macintosh → All
Summary: contents of one window showing up in another while loading a new page → contents of other regions or windows showing up while loading a new page (offscreen buffer residual)
Target Milestone: --- → M20
(Assignee)

Comment 5

18 years ago
depends on (at least partially) bug 31981
Depends on: 31981
(Assignee)

Comment 6

18 years ago
Marking beta3 - if not then, when? 

Also, CC'd Waterson since he has a broad view of the system. It looks like there 
are potentially many ways this could be happening...

From discussion I've had (with kmccluck) the problem stems from (synchronous ?) 
painting occuring before there are any frames to paint, and the back-buffer is 
merely dumping what it has in it already (from the last page presumably).
Keywords: nsbeta3
(Assignee)

Updated

18 years ago
Keywords: polish
(Assignee)

Comment 7

18 years ago
Approving for beta3: this has to be fixed because it is so ugly.

McClusky is working on it too so We'll work on it together.
Whiteboard: [nsbeta3+]
(Assignee)

Updated

18 years ago
Priority: P3 → P1
(Assignee)

Comment 8

18 years ago
*** Bug 48273 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

18 years ago
This is actually a dup of bug 34283, owned by kmcclusk. The issues are outlined 
in that bug.

*** This bug has been marked as a duplicate of 34283 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 10

18 years ago
Marking verified dup of 34283.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.