Last Comment Bug 426292 - Add support for Hildon (Maemo) filepicker
: Add support for Hildon (Maemo) filepicker
Status: RESOLVED FIXED
: mobile
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: Trunk
: Other Maemo
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://maemo.org/development/document...
Depends on:
Blocks: n800
  Show dependency treegraph
 
Reported: 2008-03-31 21:07 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2010-09-19 15:51 PDT (History)
10 users (show)
pavlov: wanted‑fennec1.0+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Adding a hildon menu with a file picker (6.02 KB, patch)
2009-02-22 03:36 PST, Joone Hur
no flags Details | Diff | Splinter Review
Adding a feature of opening a local file (1.17 KB, patch)
2009-02-22 03:41 PST, Joone Hur
no flags Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2008-03-31 21:07:00 PDT
Maemo applications, mobile Nokia n810, for example, have a native file picker dialog that is not the sameas the normal GTK file picker. It is designed for smaller screens. Supporting the Hildon file picker is pretty important for any Mozilla mobile work on that platform, from a widget standpoint.
Comment 1 Joone Hur 2009-02-22 03:36:02 PST
Created attachment 363557 [details] [diff] [review]
Adding a hildon menu with a file picker
Comment 2 Joone Hur 2009-02-22 03:41:33 PST
Created attachment 363558 [details] [diff] [review]
Adding a feature of opening a local file
Comment 3 Joone Hur 2009-02-22 04:10:04 PST
These patches implemented a feature of opening a local file using the hildon system menu & file chooser widget.

But, I'm not sure if this is a right approach because the menu was implemented in a native way instead of using XUL. So we seem to need some mobile specific XUL elements.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2010-09-19 15:51:32 PDT
This feature has already landed in bug 511290

Note You need to log in before you can comment on or make changes to this bug.