Closed Bug 426384 Opened 12 years ago Closed 12 years ago

FF3b4 incorrect claims org.w3c.svg support w/o full text and filter support

Categories

(Core :: SVG, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 322724

People

(Reporter: mozilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_2; en-us) AppleWebKit/525.13 (KHTML, like Gecko) Version/3.1 Safari/525.13
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

FF3b4 incorrect claims org.w3c.svg support w/o full text and filter support

Gecko makes the following feature string claims:
http://trac.webkit.org/projects/webkit/browser/trunk/LayoutTests/svg/custom/svg-features.html?format=raw

"org.w3c.svg", "1.0": true, true
"org.w3c.svg.static", "1.0": false, false
"org.w3c.svg.animation", "1.0": false, false
"org.w3c.svg.dynamic", "1.0": false, false
"org.w3c.dom", "1.0": false, false
"org.w3c.dom.svg", "1.0": true, true
"org.w3c.dom.svg.static", "1.0": false, false
"org.w3c.dom.svg.animation", "1.0": false, false
"org.w3c.dom.svg.dynamic", "1.0": false, false
"org.w3c.svg.all", "1.0": false, false
"org.w3c.dom.svg.all", "1.0": false, false
"http://www.w3.org/TR/SVG11/feature#SVG", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#SVGDOM", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#SVG-static", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#SVGDOM-static", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#SVG-animation", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#SVGDOM-animation", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#SVG-dynamic", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#SVGDOM-dynamic", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#CoreAttribute", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Structure", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#BasicStructure", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#ContainerAttribute", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#ConditionalProcessing", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Image", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Style", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#ViewportAttribute", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Shape", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Text", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#BasicText", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#PaintAttribute", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#BasicPaintAttribute", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#OpacityAttribute", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#GraphicsAttribute", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#BaseGraphicsAttribute", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#Marker", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#ColorProfile", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#Gradient", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Pattern", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Clip", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#BasicClip", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Mask", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Filter", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#BasicFilter", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#DocumentEventsAttribute", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#GraphicalEventsAttribute", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#AnimationEventsAttribute", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#Cursor", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Hyperlinking", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#XlinkAttribute", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#ExternalResourcesRequired", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#View", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#Script", "1.1": true, true
"http://www.w3.org/TR/SVG11/feature#Animation", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#Font", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#BasicFont", "1.1": false, false
"http://www.w3.org/TR/SVG11/feature#Extensibility", "1.1": true, true


Most important:
"org.w3c.svg", "1.0": true, true

can't be true w/o at least one of 
"org.w3c.svg.static", "1.0": false, false
"org.w3c.svg.animation", "1.0": false, false
"org.w3c.svg.dynamic", "1.0": false, false

being true.  .static is the easiest to make true.  But Gecko is missing at least <altGlyph> support, and likely other tags which make it impossible to claim support.

WebKit has turned off a bunch of these feature strings due to bugs similar to this one.  Now we're starting to get bugs where "why doesn't Safari work at this SVG site" due to FF returning true, and us (correctly, according to the spec) returning false for org.w3c.svg.

I don't really care too strongly.  But mostly WebKit and Gecko should agree.  And according to the spec, we should both return false for org.w3c.svg.

In general, Gecko's SVG feature strings need an audit.  I'm not familiar enough with the details of your current support to tell you what should be on/off though.

Reproducible: Always
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322724
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.