Add POPFile to "Trust junk mail headers set by" option

RESOLVED FIXED in Thunderbird 11.0

Status

MailNews Core
Filters
--
enhancement
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: Erik Harris, Unassigned)

Tracking

unspecified
Thunderbird 11.0

Firefox Tracking Flags

(Not tracked)

Details

([Fixed by bug 687520], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Add POPFile to "Trust junk mail headers set by" option

I've been using POPFile as my SPAM filter for a handful of years, and its accuracy has consistently been around 99.5%.  All sources I've investigated point to it being considerably better than the built-in junk filter, and it's also much more flexible (it can be used to mark messages of any arbitrary type, not just "SPAM" or "Not-SPAM").  Unfortunately, using POPFile with Thunderbird is a little bit difficult, requiring the Mnenhy extension to expose the "X-POPFile-Link" header, disabling Thunderbird's junk filtering entirely, and reproducing the junk filtering by hand (manually creating the Junk folder, setting up filters, configuring Mnenhy to display the link header, etc).  I'd like to see Thunderbird include POPFile support.

Reproducible: Always

Steps to Reproduce:
1. Install POPFile
2. Install Thunderbird
3. See them not play together without the help of Mnenhy and manual configuration.


Expected Results:  
It could be as simple as relying on some of POPFile's default settings:

- Trust junk mail headers set by: POPFile

- Look for header: "X-Text-Classification: spam"
If found, set as Junk, else ignore and send to Inbox (for other POPFile buckets, if applicable, to be sorted with filters)

- "Junk / Not Junk" button behavior: Follow link found in the "X-POPFile-Link" header.  From there, user will be able to update POPFile's training database.  Users experienced enough to use more than 3 buckets (inbox, spam, unclassified) will also be experienced enough to know that this button will let them assign other buckets.

POPFile can be found at http://popfile.sourceforg.net/ or http://getpopfile.org/. POPFile is a cross-platform, perl-based Baysean message filter (that is, it works on any OS when Perl is installed), so this request affects all operating systems Thunderbird currently supports or may support in the future.
(Reporter)

Updated

9 years ago
Summary: POPFile is an incredibly robust and accurate mail sorter, but it's difficult to integrate into Thunderbird without using extensions → Add POPFile to "Trust junk mail headers set by" option

Comment 1

9 years ago
Some documentation: http://getpopfile.org/docs/faq:whathappens and http://getpopfile.org/docs/faq:howmanybuckets

Would be a simple fix. Is it used widely enough for it to be worth to include it?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

9 years ago
I'm not sure how popular POPFile is.  They're moving away from SourceForge, according to their homepage, and the download link no longer points to Sourceforge, so the download stats on SourceForge are not reliable, but they list almost 26,000 downloads for the 1.0 version.  It's impossible to say how many copies have also been downloaded from getpopfile.org or other download sites that mirror it.  The prior version lists over 57,000 downloads, which is probably more truly indicative of the number of times that version (0.22.5) was downloaded.  0.22.4 had well over 200,000 downloads.  Since POPFile doesn't automatically prompt users to upgrade, and old versions generally sort just as well as the newer versions (or almost as well), the declining download numbers don't necessarily indicate a declining userbase.  It could mean that a large number of users are still using old versions.
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Depends on: 687520
This has been fixed by bug 687520
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Fixed by bug 687520]
Target Milestone: --- → Thunderbird 11.0
You need to log in before you can comment on or make changes to this bug.