Closed Bug 427184 Opened 14 years ago Closed 9 years ago

replace pop-up cookie prompt dialog with use of information bar

Categories

(Firefox :: General, enhancement)

x86
Windows Vista
enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: sschinke, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

With cookies set to "ask me every time", the cookie prompt can interrupt browsing, sometimes to the point of distraction or even fustration, particularly if the "remember my choice for all cookies from this site" check-box is not checked.

Anytime a cookie from a new site is sent to the browser, all browsing activity must stop until this prompt has been answered. Sometimes several must be answered.

A better interface (IMO) would be to re-use the pop-up blocker (and add-on prompting) interface to allow uninterrupted surfing, with some default behaviour  taking place to allow the page to render fully. Answering the less-intrusive prompt and changing any preference for any of the cookies can reload the page at that time.

My suggestion for a default behaviour would be to cache the cookies so that if preferences are changed through the prompt, the cached cookies could be properly stored with their new preference in place (rejected, accepted, session-only). This caching should probably not result in any cookies being returned while the page is initially loading -- if a page breaks because the cookies are not returned, this is a clear indication that the user needs to allow cookies on that site.

This prompt would also be able to expose information about all of the cookies a page has sent rather than prompting for each one after the other.

The prompt could also be ignored if a site is being visited one time only and happens to function fine under the default behaviour. I surf with cookies set to "ask me every time" and find that my "Exceptions" list gets very long very quickly because there is no practical way for me to briefly visit a site without having to make a permanently saved decision about cookies for that site (unless I want to click dozens of cookie prompts without the "remember" check-box). In reality, though, it really doesn't matter what happens to many of these cookies -- I have no account on the site, and have set no preferences there. However, selecting "block" and "remember" means that if I do decide to create an account at the site I then have to go digging deeper into the cookie UI and find whatever domains I need to unblock in the exceptions list (and this domain may not be obvious if the cookie is set to an unpredictable subdomain).

I don't suppose that a cookies exception list with hundreds or thousands of sites stored on it is a performance booster either.

Regards,
Sam

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 310492
this doesn't have much to do with bug 310492; reopening.

i've posted to mozilla.dev.apps.firefox and made a wiki page at https://wiki.mozilla.org/Cookies:prompting_ui to foster discussion on this. any comments there would be appreciated.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
Whiteboard: [CLOSEME 2010-11-01]
Still a MAJOR problem for me, Ffox10, on Debian Linux.
#2: a great page, thanks - 
on bug 469260 comment #14 please find my suggestion for a smaller bar.
related: 
bug 420155 Large number of cookies come in and the active dialog does not always have the focus 
 bug 420512 The Cookie LEARN option cannot be stopped at once and begs many times until website stops setting cookies
 bug 434971 Multiple cookie "confirmations" requested for same site with "ask me every time" 
 bug 430006 – Infinite dialog loop for cookie permission
 bug 515521 – All pending cookie popups for a given domain should be handled when one of them is in the cookie confirmation dialog
 bug 616843 A number of modal prompts should be made tab-modal
 bug 633763 Cookie confirmation dialogs should be tab-modal
Bug 469260 was added to tracking bug 851698
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 469260
We're not going to add this kind of notification to Firefox proper, since the audience that this is relevant to is small. Add-ons have a great opportunity to explore this problem space, though!
Status: NEW → RESOLVED
Closed: 14 years ago9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.