Closed Bug 428019 Opened 12 years ago Closed 10 years ago

Submit button rendered incorrectly.

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86
Windows Server 2003
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: worfspenis, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

The submit button for logging in to the site is rendered improperly.

Reproducible: Always

Steps to Reproduce:
1.Go to https://www.bankofamerica.com/
2. Look at the submit button.
3.
Actual Results:  
The button shows up differently than it should.

Expected Results:  
Show the button the same way other browsers do.
I see no submit button, but I do see several other strangely designed buttons; Enroll, Sign in, Go, Search.
This was caused by bug 300030 on 7 Dec 2006.
Component: General → Layout
Keywords: regression
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
I see this only if Javascript is enabled.  It looks like if JS is disabled there is actually a button there.  With JS it is a div with a link in it and those are styled to look like a button.  
I also see this in Windows XP.  It displays as they intended it in IE, but not in Firefox, or in Safari, which displays it essentially the same unintended way as Firefox.

JavaScript must be enabled to reproduce it.


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042506 Minefield/3.0pre ID:2008042506

Status: UNCONFIRMED → NEW
Ever confirmed: true
They are setting the width on the link to 100%.  Browsers other than IE ignore this correctly for an inline element.  But I'm trying to figure what's different between FF2 and FF3.  For the enroll button the computed font size shown by DOMi is 11px in FF2.  In FF3 it is 11.7px.  Yet comparing the screenshots the word enroll is narrower in FF3.  In FF3 the TD which contains the div and the link has a computed width of 51px while in FF2 it is 43 pixels. I'm not sure why it's different but this looks to me to be a Tech Evang bug because of the incorrect assumption they are making about sizing an inline element.  Opera also matches our rendering.  
Assignee: nobody → english-us
Component: Layout → English US
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Version: Trunk → unspecified
Also if you decrease the text size a few times you can see the problem in FF2 for the enroll button.  
Duplicate of this bug: 443823
Duplicate of this bug: 445908
I don't think this is reproducible anymore, because the Bank of America homepage has changed.  Since this is a tech evangelism bug, how should this be resolved?
I don't see anything significantly different from two or three years ago on BoA's home page, but I also don't see any differences in rendering between a recent Camino nightly and Safari 5, so I'm going to call this FIXED by a presumed site change in the interim.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.