Last Comment Bug 428110 - quick and dirty changes to speed up crash analysis
: quick and dirty changes to speed up crash analysis
Status: RESOLVED FIXED
:
Product: Socorro
Classification: Server Software
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Austin King [:ozten]
: socorro
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 15:26 PDT by chris hofmann
Modified: 2011-12-28 10:40 PST (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description chris hofmann 2008-04-09 15:26:46 PDT
First change:

on a stack signature summary report like

http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=contains&range_unit=weeks&version=Firefox%3A3.0b5&signature=RtlEnterCriticalSection&range_value=1

we currently land on graph tab.   we should land on the "reports" tab since that has the data that we are really after...

we could also combine "graph" and "table" tabs if that makes life easier or faster.


Second Change:

on the individual crash report pages like:

http://crash-stats.mozilla.com/report/index/6ac97075-04bb-11dd-b92b-001b78bc73ea

we should land on the "frames" page.  

content from the "details" page could also be combined onto the top "frames" page to help put the stack trace into context..


when plowing though several hundred reports to chase down crashes these few changes would help to reduce a lot of clicks...

setting to 0.6 since ted thought these would be easy...  change the target milestone if not...
Comment 1 chris hofmann 2008-09-10 09:12:37 PDT
wwwwhhhhhaaa...  no target milestone for this now...  my hands start hurting everytime I spend any amount of time doing crash analysis.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2008-09-10 10:38:50 PDT
We are re-triaging today. Morgamic is just resetting things in light of the php rewrite of the reporter.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2008-10-24 07:24:11 PDT
Austin, could you see what's left to do here? Should be simple stuff.
Comment 4 Wayne Mery (:wsmwk, NI for questions) 2009-01-22 09:49:48 PST
WFM both items
Comment 5 chris hofmann 2009-01-22 12:58:07 PST
landing on frames works for me too now, but on the first change I still get the graph page and not "reports"
Comment 6 Austin King [:ozten] 2009-01-22 16:07:34 PST
I will make this change, so that query results page will display the list of crash reports, instead of the OS/Build graph. We are working on release currently and I will put it in.
Comment 7 Austin King [:ozten] 2009-02-27 10:33:37 PST
These changes shipped. There is a regression of the frames tab, being tracked in 
https://bugzilla.mozilla.org/show_bug.cgi?id=480501

Note You need to log in before you can comment on or make changes to this bug.