If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Restore tabs after an update

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
--
enhancement
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Joe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

I had multiple tabs open, one needed a plug in that I allowed it to do, I have my home page set to last session and followed the instructions on installing the plug in not realizing that the plug in page was the last one open because it said close down all other browsers and lost all the links that I previously had open and not saved. Is there any way to expand the open last session to be the open browser and not the plug in download instructions?

Reproducible: Always

Steps to Reproduce:
1.see missing plug in
2.download missing plug in- read "close down open browser" 
3.close current open browser with multiple tabs
4.open browser after download/install is complete
5.Last session with multiple tabs is lost forever.

Comment 1

10 years ago
This seems very similar to Bug 428086 in its intention, even though this is marked as an enhancement and the other is marked as a bug.  This was posted to Bugzilla within a day of the other.  Duplicate?

From what I understand, after installing an extension or a plugin, there is nothing in the code intended to NOT allow you to have your tabs restored, outside of a bug existing.  In other words, this should already theoretically work, so I wouldn't say this is an enhancement issue, but a bug.

Comment 2

9 years ago
Joe: Closing browser windows individually will inevitably lead to all but the last browser window being lost - that's by design. Please close multiple browser windows through File -> Exit instead. -> WORKSFORME

You might want to file a new bug against the plug-in finder (or whatever is displaying the "close down open browser" message) to be more explicit about using File -> Exit, though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.