Last Comment Bug 428657 - stop using deprecated winable.h, use winuser.h instead
: stop using deprecated winable.h, use winuser.h instead
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: x86 Windows Vista
: -- normal (vote)
: mozilla8
Assigned To: Trevor Saunders (:tbsaunde)
:
Mentors:
http://forums.microsoft.com/MSDN/Show...
Depends on:
Blocks: cleana11y
  Show dependency treegraph
 
Reported: 2008-04-12 05:53 PDT by Mike Beltzner [:beltzner, not reading bugmail]
Modified: 2011-07-29 10:56 PDT (History)
6 users (show)
mbeltzner: wanted‑next+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.73 KB, patch)
2011-07-26 08:00 PDT, Trevor Saunders (:tbsaunde)
dbolter: review+
mzehe: feedback+
Details | Diff | Review

Description Mike Beltzner [:beltzner, not reading bugmail] 2008-04-12 05:53:53 PDT
We now require the Windows Vista SDK, which no longer includes winable.h. According to MSDN (see URL) this library has been duplicated in winuser.h since January 2005. We should be using this library, instead.

This impacts people who are building on Windows, as after downloading the required SDKs, they need to source and manually add winable.h to get a working build with accessibility.
Comment 1 Benjamin Smedberg [:bsmedberg] 2008-04-13 08:04:18 PDT
"January 2005" is which SDK release? The three SDKs in question are

* win2k3 SDK
* vista SDK (version 6.0)
* win2k8 SDK (version 6.1)
Comment 2 Mike Beltzner [:beltzner, not reading bugmail] 2008-04-14 08:12:06 PDT
The MSDN article implies that it was part of the Windows 2003 Server SDK R2 release.
Comment 3 David Bolter [:davidb] 2009-06-16 12:00:18 PDT
Mass un-assigning bugs assigned to Aaron.
Comment 4 Trevor Saunders (:tbsaunde) 2011-07-26 08:00:25 PDT
Created attachment 548460 [details] [diff] [review]
patch

assuming this bug is still relavent.    This builds fine on try, not sure if I should check anything else

Review:
Comment 5 Marco Zehe (:MarcoZ) 2011-07-26 08:23:22 PDT
The Win2K3R2 SDK is still needed if someone builds with an MSVC Express release which does not include ATL which in turn includes oleacc and other accessibility-related libraries and headers. Since W2K3R2 SDK is the oldest one we allow (and only as a dependent SDK on top of the Windows 7 SDK), if winable.h has been deprecated in that one, I'm sure we're not even using that ifdef any more.
I'm building with a VC++ express + Windows 7 SDK + Win2K3R2 SDK and this patch to see if I encounter any problems.
Comment 6 Marco Zehe (:MarcoZ) 2011-07-26 10:00:59 PDT
Comment on attachment 548460 [details] [diff] [review]
patch

Building, working. I assume we haven't used winable.h in our includes for years since that define never was true.
Comment 7 alexander :surkov 2011-07-27 21:39:17 PDT
(In reply to comment #5)
> The Win2K3R2 SDK is still needed if someone builds with an MSVC Express
> release which does not include ATL which in turn includes oleacc and other
> accessibility-related libraries and headers.

Gecko accessibility doesn't require atl for years (see bug 325070). We use oleacc directly. The page https://developer.mozilla.org/en/atlbase.h states that accessibility only uses it and should be fixed. That makes Mozilla builds to not require Windows 2003 SDK longer.
Comment 8 alexander :surkov 2011-07-27 21:40:39 PDT
Comment on attachment 548460 [details] [diff] [review]
patch

David, any specific reason why you asked me for additional review?
Comment 9 Marco Zehe (:MarcoZ) 2011-07-28 03:01:30 PDT
But we still require oleacc.h, which is not part of the Windows 7 SDK IIRC, but comes with the Professional editions of Visual Studio, but not the express editions of Visual C++. So for that, the Win2K3  R2 SDK is still required.
Comment 10 alexander :surkov 2011-07-28 03:40:57 PDT
(In reply to comment #9)
> But we still require oleacc.h, which is not part of the Windows 7 SDK IIRC

it is, just checked it, oleacc.h and oleacc.lib are part of 7.0 SDK
Comment 11 alexander :surkov 2011-07-28 04:27:07 PDT
(In reply to comment #10)
> (In reply to comment #9)
> > But we still require oleacc.h, which is not part of the Windows 7 SDK IIRC
> 
> it is, just checked it, oleacc.h and oleacc.lib are part of 7.0 SDK

I filed bug 674870 for this.
Comment 12 Trevor Saunders (:tbsaunde) 2011-07-28 19:23:05 PDT
landed http://hg.mozilla.org/integration/mozilla-inbound/799636ad8a0d
Comment 13 :Ehsan Akhgari (busy, don't ask for review please) 2011-07-29 10:56:34 PDT
http://hg.mozilla.org/mozilla-central/rev/799636ad8a0d

Note You need to log in before you can comment on or make changes to this bug.