Closed Bug 674870 Opened 11 years ago Closed 10 years ago

update config and docs to not require atlbase.h for accessibility

Categories

(Firefox Build System :: General, defect)

All
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 669829

People

(Reporter: surkov, Unassigned)

References

Details

(Keywords: access)

ATL is no longer required to build accessibility (fixed in bug bug 325070), but still required by config, see http://mxr.mozilla.org/mozilla-central/source/configure.in#5751.

This should be reflected at page https://developer.mozilla.org/en/atlbase.h

oleacc.h/idl/lib are part of 6.0A and 7.0 Windows SDK, windows 2003 SDK is not needed, thus the following pages should be updated:
https://developer.mozilla.org/en/oleacc.idl
https://developer.mozilla.org/En/Windows_SDK_versions
Component: Build Config → Documentation Requests
Product: Core → Mozilla Developer Network
QA Contact: build-config → doc-request
Ted, it's not only documentation change request, configure.in should be fixed too, that was a reason I filed the bug against Build Config component.
Ok.
Component: Documentation Requests → Build Config
Product: Mozilla Developer Network → Core
QA Contact: doc-request → build-config
There is a proposed patch for configure.in in Bug 669829
See Also: → 669829
Keywords: access
Yes, it looks like bug 669829 fixed this.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669829
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.