Cancel in download dialog should ask user to abort download

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
3 years ago

People

(Reporter: bugzilla, Assigned: law)

Tracking

({dataloss})

Trunk
Future
dataloss

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
When you press the Cancel button in the download dialog (when you save files) 
should ask the user if he/she want to cancel the download.
(Reporter)

Comment 1

19 years ago
Created attachment 10275 [details] [diff] [review]
Hooking up the cancel button in the download dialog.

Updated

19 years ago
Keywords: patch
Component: XP Apps → XP Apps: GUI Features

Comment 2

19 years ago
law, m19
Assignee: don → law
Target Milestone: --- → M19
This looks to me like a dupe of Bug 32108

Comment 4

19 years ago
This is a dupe of 32108, marking so. Moving patch over.

*** This bug has been marked as a duplicate of 32108 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
okay, vrfy dup.
Status: RESOLVED → VERIFIED
This is not a duplicate of bug 32108 which is about the XPInstall download 
dialog.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 7

18 years ago
Henrik, does that code work OK now?  All platforms?  Presuming it does, I'm
nominating this.
Keywords: nsbeta1
->all
OS: Windows 2000 → All
Hardware: PC → All

Comment 9

18 years ago
nav triage team:

Marking nsbeta1-, not a beta stopper
Keywords: nsbeta1 → nsbeta1-
how is this patch? could we review/test it and check it in if it's good? thx!
Keywords: nsCatFood, review
(Assignee)

Comment 11

18 years ago
No, the patch isn't right.  The window.confirm is wrong.  It should use
nsICommonDialogs with a pretty confirm dialog.

I'll see about doing this as part of my overhaul of the progress dialog(s).
okay, thx!
Keywords: mozilla0.9.1
nav triage: this does not fit the catfood criteria of frequency of occurrence. 
also catfood nominations shd have the reasoning behind the nomination if 
possible. 
Keywords: nsCatFood → nsCatFood-
Target Milestone: --- → Future
bill, i know the patch is old... has it bit-rotted quite a bit?

Updated

18 years ago
Keywords: dataloss
spam: over to File Handling.
Component: XP Apps: GUI Features → File Handling
This has been implemented for a long time now.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.