crash in ocsp_RemoveCacheItemFromLinkedList during shutdown

RESOLVED WORKSFORME

Status

P1
normal
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: kaie, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

trunk
3.12.1
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
We recently worked on a fix for Firefox.
There was a hang on exit, a deadlock.

As part of that bug, we used a test case that involved a lot of parallel SSL connections, involving OCSP checks, and exiting the application while several of these are still active.

Now, the deadlock appears to be fixed, and we continued to try what happens when we run that test.

Occassionally, I get a crash.

I got this assertion:
Assertion failure: item->moreRecent->lessRecent == item, at ocsp.c:454

And I'll attach the stack.
(Reporter)

Updated

11 years ago
Keywords: crash
I wonder if this bug is a side effect of the cause of bug 433594, which is
now fixed.
Kai, can you determine if this bug persists, now that bug 433594 is fixed?
Priority: -- → P1
Target Milestone: --- → 3.12.1
Having heard nothing more about this bug in 9 months, I'm assuming it's 
no longer a bug.  If it is still a bug, we need new evidence.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.