Windows icon: library window navigation icons can not reference toolbar.png anymore

RESOLVED FIXED in Firefox 3

Status

()

Firefox
Theme
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: faaborg, Assigned: dao)

Tracking

Trunk
Firefox 3
All
Windows XP
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

10 years ago
Previously the navigation buttons in the library window have been located in toolbar.png.  We are switching the icons in toolbar.png to be round so that they look correct when the user is in icons + text mode.  The navigation icons for the library window will be:

/winstripe/browser/places/libraryNavigation.png
/winstripe/browser/places/libraryNavigation-aero.png

This files will be included in the next icon drop.  I'll update this bug when they have landed.
(Reporter)

Updated

10 years ago
Summary: Library window navigation icons can not reference toolbar.png anymore → Windows icon: library window navigation icons can not reference toolbar.png anymore
Alex: what will the dimensions and image format be?
Mano: can you patch the appropriate CSS for this?
Flags: blocking-firefox3+
(Reporter)

Comment 2

10 years ago
Created attachment 315915 [details]
libraryNavigation.png
(Reporter)

Comment 3

10 years ago
Created attachment 315916 [details]
libraryNavigation-aero.png
(Reporter)

Comment 4

10 years ago
Land these two icons to /winstripe/browser/places
Assignee: nobody → mano
Target Milestone: --- → Firefox 3
I'll find an owner for this, Mano's got a ton on his plate already.
Assignee: mano → mconnor
(Assignee)

Comment 6

10 years ago
should be trivial
Assignee: mconnor → dao
(Assignee)

Comment 7

10 years ago
Created attachment 316579 [details] [diff] [review]
patch
Attachment #315915 - Attachment is obsolete: true
Attachment #315916 - Attachment is obsolete: true
Attachment #316579 - Flags: review?(gavin.sharp)
(Assignee)

Updated

10 years ago
Attachment #316579 - Flags: review?(gavin.sharp) → review?(dietrich)
Comment on attachment 316579 [details] [diff] [review]
patch

r=mano
Attachment #316579 - Flags: review?(dietrich) → review+
(Assignee)

Updated

10 years ago
Attachment #316579 - Flags: approval1.9?
Comment on attachment 316579 [details] [diff] [review]
patch

a=mconnor on behalf of 1.9 drivers
Attachment #316579 - Flags: approval1.9? → approval1.9+

Updated

10 years ago
Keywords: checkin-needed
Whiteboard: [has patch][has reviews]
mozilla/browser/themes/winstripe/browser/places/organizer.css 	1.12
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [has patch][has reviews]

Comment 11

10 years ago
Why is the new image not a chrome URL, like all others in organizer.css?
(Assignee)

Comment 12

10 years ago
URLs in a CSS file are relative to that file by default, which makes the path redundant in this case. Is there anything wrong with that?

Comment 13

10 years ago
(In reply to comment #12)
> URLs in a CSS file are relative to that file by default, which makes the path
> redundant in this case. Is there anything wrong with that?
> 

Nah, just wondering. I don't know about coding style in the theme and consistency rules, though.

Updated

10 years ago
Duplicate of this bug: 420739
You need to log in before you can comment on or make changes to this bug.