From address is split when it contains a comma

RESOLVED DUPLICATE of bug 254519

Status

RESOLVED DUPLICATE of bug 254519
11 years ago
11 years ago

People

(Reporter: frank, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080316 SUSE/2.0.0.13-0.1 Firefox/2.0.0.13
Build Identifier: 2.0.0.12 (20080226)

The name in the From field is split when it contains a comma.
For example, if the from header is From: "Doe, John" <john.doe@somewhat.com>, the name only is displayed as Doe, iso Doe, John.
When replying to this mail you get 2 addresses : 

Doe
John <john.doe@somewhat.com>

It looks like Thunderbird is not looking at the quotes around the name.


Reproducible: Always

Steps to Reproduce:
1. 
2.
3.


Expected Results:  
From: Doe, John
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254519
You need to log in before you can comment on or make changes to this bug.