Closed Bug 428997 Opened 14 years ago Closed 14 years ago

Unable to upload photos to Facebook with Java tool on Mac

Categories

(Plugins Graveyard :: Java (Java Embedding Plugin), defect)

All
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 421855

People

(Reporter: tchung, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008041404 Minefield/3.0pre
Build Identifier: 

Uploading pictures in the facebook application does not work on trunk.  A "failed to upload" error is the result.

This works fine on firefox 2.0.0.13

Reproducible: Always

Steps to Reproduce:
1. install latest nightly
2. goto facebook, log into your profile, and try to upload photos
3. Verify uploading photos fail
Actual Results:  
Uploading photos fail

Expected Results:  
uploading photos should work.
Bug 357179 suggests this might be a problem with your configuration, Tony, rather than a TE bug.
The Java upload tool fails on Camino trunk 2008041301. The Simple Uploader works fine.

IIRC, the Java tool has been problematic in the past with Camino, so that may not be a particularly useful test ;)

Tony, have you tried a Firefox 3 beta? I'm mostly wondering why this was filed under TE, since I see nothing to indicate it's broken because of something Facebook did wrong.
Possibly related Console messages from around the time this happened:

14/04/2008 16:01:11 [0x0-0x2a02a].org.mozilla.camino[597] initialization error: Can't load class netscape/javascript/JSObject 
14/04/2008 16:01:11 [0x0-0x2a02a].org.mozilla.camino[597] initialization error: Can't load class java/lang/Object 
14/04/2008 16:01:11 [0x0-0x2a02a].org.mozilla.camino[597] LiveConnect was unable to reflect one or more components of the Java runtime. 
14/04/2008 16:01:11 [0x0-0x2a02a].org.mozilla.camino[597] Go to http://bugzilla.mozilla.org/show_bug.cgi?id=5369 for details. 
14/04/2008 16:01:11 [0x0-0x2a02a].org.mozilla.camino[597] Total weirdness:   No JSJavaVM wrapper ever created for JavaVM 0x0a4e2260 
14/04/2008 16:02:41 [0x0-0x2a02a].org.mozilla.camino[597] objc[597]: unable to add properties from category QLPreviewViewExtensions... 
14/04/2008 16:02:41 [0x0-0x2a02a].org.mozilla.camino[597] objc[597]: class `NSView' must be recompiled
Based on some digging Tony and I have done on IRC, this is definitely a problem on the Mac, and may be a problem on all non-Windows platforms. It does *not* happen on Windows.
OS: All → Mac OS X
Summary: Unable to upload photos in facebook application → Unable to upload photos to Facebook with Java tool on Mac
Java uploader seems to work on windows XP nightly builds.   is this related to bug 421855?   Attaching a screenshot of the error.
Depends on: 421855
looks like a dupe.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 421855
Agreed. Moving to Core where it belongs while verifying.
Status: RESOLVED → VERIFIED
Component: English US → Java Embedding Plugin
Product: Tech Evangelism → Core
Version: unspecified → Trunk
it does happen on windows platfrom.
Component: Java Embedding Plugin → Java (Java Embedding Plugin)
Product: Core → Plugins
QA Contact: english-us → jep-java
Version: Trunk → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.