Closed Bug 429029 Opened 13 years ago Closed 13 years ago

Right click on WMP plugin and Properties or Options doesn't work

Categories

(Core :: Widget: Win32, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: stevee, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [fixed by backout of 427259])

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041406 Minefield/3.0pre ID:2008041406

1. New profile, start firefox
2. Go to http://www.gametrailers.com/player/32661.html?type=wmv
3. Wait for the WMP plugin to appear and right click on the plugin to get the plugin's context menu
4. Select menu item "Properties" or "Options"

Expected:
- A WMP-related dialog appears

Actual:
- It looks like the dialog appears and then disappears really quickly for no apparent reason

Works: 20080407_2058_firefox-3.0pre.en-US.win32
Broken: 20080408_0216_firefox-3.0pre.en-US.win32

Checkins to module PhoenixTinderbox between 2008-04-07 20:58 and 2008-04-08 02:16 :
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-04-07+20%3A58&maxdate=2008-04-08+02%3A16&cvsroot=%2Fcvsroot
Flags: blocking-firefox3?
I'm using npdisplay.dll v3.0.2.629 apparently.
Backing out the patch for bug 427259 seems to fix this.
Blocks: 427259
Component: General → Widget: Win32
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → win32
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+
Whiteboard: [fixed by backout of 427259]
Looks like this plugin looks for a MozillaDialogClass.  Since the change fixes a ton of problems with screen readers (and a regression from Firefox 2.0), is it possible to work with the plugin developers to not depend on the MozillaDialogClass string?
Fixed by backout of bug 427259.
Checking in widget/src/windows/nsWindow.h;
/cvsroot/mozilla/widget/src/windows/nsWindow.h,v  <--  nsWindow.h
new revision: 3.253; previous revision: 3.252
done
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified fixed, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041506 Minefield/3.0pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.