Last Comment Bug 429161 - Sandbox the Fasterfox addon, lures users into false sense of 'faster browsing'
: Sandbox the Fasterfox addon, lures users into false sense of 'faster browsing'
Status: RESOLVED FIXED
:
Product: addons.mozilla.org Graveyard
Classification: Graveyard
Component: Administration (show other bugs)
: unspecified
: All All
: -- major
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 411808
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 10:11 PDT by Noah (oldtimer) [:Noah]
Modified: 2016-03-07 07:30 PST (History)
12 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Noah (oldtimer) [:Noah] 2008-04-15 10:11:48 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032714 Minefield/3.0pre
Build Identifier: 

Fasterfox has been plaguing us for many years now. Causing probably 95% of slow down surfing bugs filed against firefox. Since uninstall of Fasterfox does not reset the about:config prefs it changes, notably the pipelining ones. Users are always left wondering why their setup is still running slow and attribute it to Firefox itself. We need to do damage control.

I say it's time to remove them entirely from AMO, as we should of done at least 2 yrs ago, or we need to sandbox it.

Reproducible: Always
Comment 1 Mardeg 2008-05-02 13:20:40 PDT
*** This bug has been confirmed by popular vote. ***
Comment 2 Dave Garrett 2008-05-03 14:05:39 PDT
There really needs to be an uninstall API so extensions like this can clean out what they've done.  (preferably at the user's discretion)

Personally, I think we just need to force it to be split into a Fasterfox and Fasterfox Lite.  Sandbox/remove the full version and have a simple lite version that ONLY tweaks the basic set of settings (connections & cache) and ONLY sets them within sane specs.  (no pipelining, prefetching, timer, or any of that other junk)  Of course, then what little this extension does to speed things up goes away, but I guess that's sorta the point.  ;)

If that's not possible, then sandboxing seems perfectly valid to me.  The whole point of the sandbox is to put extensions that may cause glitches and issues in another area, and this extension falls under that category.

Fasterfox is not yet compatible with Firefox 3, so I suggest something be done about this soon, if at all.  Besides, FF3 has tweaked some of these settings a tiny bit itself.
Comment 3 Dave Garrett 2008-05-09 02:15:46 PDT
Also see bug 411808

This extension may just be fully abandoned and never updated for FF3 at this rate, in which case none of this really matters.  (though, old profiles would still have old tweaked prefs; yet another reason why you should make a new profile for FF3)
Comment 4 Basil Hashem [:baz] 2008-05-13 01:47:52 PDT
Many folks at Mozilla have reached out to the author with no response. I'll leave this open but at this point, I don't believe that this add-on will get updated for Firefox 3.
Comment 5 Dave Garrett 2008-05-23 14:24:07 PDT
No need to do anything more if it's dying off naturally.  Closing as WFM.

Might still want to sandbox it if too many people try to resurrect it along with other incompatible extensions, but that's another issue entirely.

If Fasterfox ever comes out with a Firefox 3 version, please re-open.
Comment 6 Kai Liu 2008-05-23 14:33:37 PDT
I think it may still be worthwhile to somehow signal to the users the ill effects of this addon, and I think sandboxing will accomplish that.  This will reduce the cases of users installing it for Firefox 2 and then having some of the settings persist into 3 (although most of the damage has already been done) and the cases of users asking about why the extension isn't available for 3.  So I still think there's a case for sandboxing, from a communicate-with-the-user-base perspective.
Comment 7 Noah (oldtimer) [:Noah] 2008-06-20 16:39:08 PDT
Well you just HAD to leave it open.... didn't you? Dave you got your wish, it's been updated by someone in the review section of the Fasterfox page at AMO.

********Quoted Review**********
    FASTERFOX FASTERFU_CK Firefox 3 Release

    http://rapidshare.com/files/123696045/FasterFox_Firefox3.xpi.html it will work up to firefox 5 ;) http://www.megaupload.com/?d=APSX02I1 http://www.sendspace.com/file/nbvlvn
********************************

Stop worrying about hurting someone's feelings and sandbox it already, citing 'it will die naturally' is an ignorant statement because tons of addons are not compatible for Firefox 3 and people simply google search for how to disable compatibility checking and install it anyway. Much less all the fools out there that think firefox is 'slow' and needs a 'boost' will google search: firefox make speed faster / firefox speed tweaks / firefox speed addon / etc

This will terminate the majority of fasterfox users from entering irc.mozilla.org's #firefox support channel with problems induced by it and also save bugzilla from half-assed bugs being filed about Fasterfox. END IT HERE!
Comment 8 Dave Townsend [:mossop] 2008-06-20 16:55:31 PDT
We should just remove the review, sandboxing the addon actually has no effect for the case you quote.
Comment 9 Basil Hashem [:baz] 2008-06-20 16:59:25 PDT
So, basically these versions are the same bits with a new install.rdf that has
wacky maxVersion compatibility. I'm going to end this now. Fasterfox has been
sandbox'ed.

The rudely titled comment has been removed and Fasterfox reviews that point to
crazy copies on rapidshare or Megauploader have been deleted. Also, reviews
with instructions on how to force installation via editing install.rdf have
been deleted.

Closing bug. Thanks
Comment 10 Dave Garrett 2008-06-20 17:27:24 PDT
Noah:  Idiots resurrecting incompatible add-ons is another issue entirely, and I suspect this will not be the last one along these lines.  As I said in my last comment sandboxing for this is a good idea to combat this.  (now that FF3 is out)  No need to get snippy.  :p

Thanks for sandboxing, Basil.

Could someone also please add a comment from AMO to the long description to indicate the reasoning for sanboxing?  It would be helpful to actually tell users what's going on so as to hopefully keep them from still overriding things.
Comment 11 Peter Drucker 2008-06-23 10:55:59 PDT
Could you describe what's wrong with this addon on the description-page or here?

What are simultaneous connections, pipelining, cache, DNS cache and why should they be bad?
Comment 12 Jonathan Steele 2008-06-23 12:08:26 PDT
(In reply to comment #11)
> Could you describe what's wrong with this addon on the description-page or
> here?
> 
> What are simultaneous connections, pipelining, cache, DNS cache and why should
> they be bad?
> 

Firefox 3 already upper the connection limits for a safe amount for the web. as for Fasterfox for simulaneous, it can put too strain in a certain web server. A lot of web server already did something to pipeline then it causes a few of side effect like a some of images wouldn't be load. What is a wrong with DNS Cache?
Comment 13 Fred Wenzel [:wenzel] 2008-06-23 12:23:19 PDT
Nothing's wrong with a DNS cache. To my knowledge, Firefox has one built in.
Comment 14 Dave Garrett 2008-06-23 13:00:07 PDT
There was never anything wrong with the network options themselves in Fasterfox; the problem arose when those settings were _misused_ either to put them beyond what servers would work with or just setting them completely wrong.  Fasterfox even hand one of its preset configurations listed to go beyond allowed specs, which was a good way to break things.  And when it did make things "faster" it wasn't by enough to be worth the headaches.

Fasterfox was sort of like handing a chainsaw to a 4 year old.  We really should be recommending against it at this point, especially because Firefox 3 has slightly upped settings over Firefox 2 and Fasterfox isn't going to know this.  A quick note in the desc is warranted here.  (new bug needed?)
Comment 15 Peter Drucker 2008-06-23 14:07:43 PDT
You are talking about misusing, metaphors and side effects but don't name them! Or maybe there isn't a real problem with Fasterfox?
Comment 16 TGOS 2008-07-03 08:13:30 PDT
I used Fasterfox in the past, since the developer said pipelining was disabled by default as well as keeping connections persistently opened. As far as I read the RFCs there are only recommendations anyway. This info might just have been plain wrong, I don't know. IMHO it just makes sense if a browser does not work like that "Open a connection to server, request something, close connection" and that for possible hundreds of images on a page, external CSS and JS files. So keeping a couple of connections permanently open (persistent connections) and requesting multiple files at once if possible (pipelining) seems just natural. Not only that this will improve the performance on either side, it will even lower server load, so everyone wins.

Can someone who has the appropriate knowledge (I don't want to spend hours searching the source code for it) please just provide the information how Fx3 is configured by default? E.g. will it keep persistent connections open? If so, how many? Will it pipeline request? If so, how many requests? And if it can't use persistent connections with a server, how many connections will it open to a single server at the same time and how many in total (note that these are settings you used to modify in the normal Opera pref pane when I was still using it a long time ago before Fx appeared). This information would be extremely valuable and a good argument for Fasterfox users why they don't need this extension any longer anyway.

Regarding the DNS cache, I never altered that, I hope you folks know what good settings are for this, that is you tested settings and made *wise* decisions instead of just making up numbers ;)

Then we have the cache sizes for cached content. The disk cache is available in the normal preference pane, not the memory size. I like to limit memory to a very little value. Why? My harddrive is still about hundred times faster than my Internet connection (so taking data from disk cache is still a *huge* speed-up), memory is even faster of course, but a much more limited resource (50 MB disk cache is like nothing, but 50 MB RAM, well...) - so I limit this to 4 or 8 MB what is more than enough. No big deal, can be set without about:config using this extension:

https://addons.mozilla.org/de/firefox/addon/5523

The still inoffical 0.3.7 release works with FF3 and it contains a lot of other interesting settings (I love the easy ability to disable backspace as navigation key there BTW); however nothing that could cripple your browser too badly :)

What's left then? Oh right, the link prefetching. Does FF3 still does that? If so, I dislike it. Never make my browser fetch any data I have not explicitly requested (or any page I have currently open for content updates); I also disabled the phishing/maleware protection because if this (I don't want these updates to happen in background); I consider myself as an educated user, so I can avoid falling for these myself. I still see no way to disable prefetching if still done, maybe other than using about:config - that was useful in Fasterfox. Maybe I should request an official option to disable that feature.

The key point is that if you can convince people that the network settings are all fine without Fasterfox and that every other interesting setting can either be set using a different extension or that an official item for it will be added to the prefpane, nobody is going to miss Fasterfox, nobody will wine about it and can stay away of hundreds of flames ;)
Comment 17 Fred Wenzel [:wenzel] 2008-07-03 08:38:12 PDT
Just a short side note:

(In reply to comment #16)
> Then we have the cache sizes for cached content. The disk cache is available in
> the normal preference pane, not the memory size. I like to limit memory to a
> very little value. Why? My harddrive is still about hundred times faster than
> my Internet connection (so taking data from disk cache is still a *huge*
> speed-up), memory is even faster of course, but a much more limited resource
> (50 MB disk cache is like nothing, but 50 MB RAM, well...) - so I limit this to
> 4 or 8 MB what is more than enough.

We are talking virtual memory here. In other words, there's a good chance your operating system won't keep the entire 50MB (or whatever it is set to by default) in RAM, but it will swap out pages to... you guessed it, the hard drive.
Comment 18 Dave Garrett 2008-07-03 10:39:51 PDT
FF2 vs. FF3 default network settings:
network.http.max-connections:                        24 -> 30
network.http.max-connections-per-server:              8 -> 15
network.http.max-persistent-connections-per-proxy:    4 -> 8
network.http.max-persistent-connections-per-server:   2 -> 6
I don't think there's any other changes.  (correct me if I'm wrong)

Unfortunately, I don't think any convincing is a reasonable expectation at this point.  To sum it up, I think we have 3 groups of Fasterfox users:
1) Know vaguely what they're doing. Probably reset Fasterfox's settings before uninstalling it, and can (eventually) figure out hot to make a new profile for FF3.
2) Installed Fasterfox and now it's incompatible.  Even if they want it for FF3 it's not there through the normal channels.
3) Found the sandboxed version; hunted for a dumb version bump and installed it. Promptly maxed out its settings.

Groups #1 & #2 were cut off via Fasterfox not getting updated, and the latter was reinforced by sandboxing.  (there really should be a description note, but I admit that it'd only be a formality)  Many of those in group #3 are not likely to listen to a single thing we tell them.  Some actually consider this to be some sort of evil conspiracy to hold back their browser to protect "the man" or something.  When any of these users that have a Fasterfox tweaked profile show up confused as to why things are slowing things down (all too much irony here) we'll just have to point them to a support article somewhere and that's all we can really hope to do.

Note You need to log in before you can comment on or make changes to this bug.