Closed Bug 429235 Opened 13 years ago Closed 13 years ago

Prepare Thunderbird 3 Alpha 1 release notes

Categories

(www.mozilla.org Graveyard :: Thunderbird, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gkw, Assigned: davida)

Details

Attachments

(1 file, 3 obsolete files)

As the release draws near, we have to prepare the release notes for Thunderbird 3.0 Alpha 1.

A question: where should they be hosted on, mozilla.com or mozillamessaging.com?

Someone with SVN access has to push the pages from trunk, then to staging, and finally to production when it is eventually released.
Flags: blocking-thunderbird3.0a1?
Status: NEW → ASSIGNED
Assignee: nobody → nth10sd
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Flags: blocking-thunderbird3.0a1? → blocking-thunderbird3.0a1+
FYI: we should remember to mention the new add-on manager.
Attached file TB3a1relnotes-0.1 (obsolete) —
Release notes v0.1, pre-first draft.
(Firstly, credit thanks go to Joshua Cranmer, Ron K. and Peter Weilbacher for their contributions to the pre-first draft of the release notes.)

Some notes of the pre-first draft:

1. On which site are we going to host on? (Requires different styles on different mozilla.com or mozillamessaging.com sites.)
2. Should we need a codename, e.g. Minefield for Firefox in its alphas, for the alphas of Thunderbird? - This affects the names of the directory used throughout the release notes, e.g. profile locations.
3. We would need a new System Requirements page for Thunderbird.
4. Would Thunderbird 3 overwrite existing installations on all platforms?
5. Is the profile for Linux / Unix systems (excluding Mac OS X) located at ~/.thunderbird ?
6. Will Alpha 1 detect incompatible extensions and disable them accordingly?
7. (Known issues haven't been written yet, contributions welcome)
8. Do we have a beta test mailing list?
9. The links to Thunderbird Add-ons are current as at the time of writing.
10. Some links and possibly notes are as yet uncorrected.
11. Are we calling it "Thunderbird 3 Alpha 1" or "Thunderbird 3.0 Alpha 1"?

Please feel free to comment on this pre-first draft. (I'm calling it TB3a1relnotes-0.1)
And yes, I suddenly recalled we should write something about Thunderbird no longer being a Carbon app, becoming a Cocoa app on Mac OS X now. Sheesh.
[12 Cocoa above]
13. dropping of win9x.
14. add info about using custom install - I don't think users should be forced/encouraged in the release notes to overwrite their existing program folder, where it currently states "Please note that installing Thunderbird 3 Alpha 1 will overwrite your existing installation of Thunderbird on Windows, Linux and Mac OS X. For all systems, you won't lose any of your bookmarks or browsing history, but some of your extensions and other add-ons might not work until updates for them are made available."   If we really want them to be good evaluators, then we want them to be able to easily leave 3.x and go back to 2.x in case of problems or to compare function, etc, AND, just as important, easily come back to 3.x.
Do we have a Tb 3 compatible DOM Inspector? If so, a link should be provided.
You probably know that, but just to be sure: someone should search for "firefox" in the HTML and replace it with Thunderbird. There are also some links in there that I think don't exist yet for TB, e.g. the /<?=$lang?>/firefox/system-requirements-v3.html link.
relnotes will be off of mozillamessaging.com.  I'll coordinate w/ you and
fligtar about the details.
Ref #8, sounds good.

Part of the release plan should be an announcement in mozilla.support.thunderbird with a link to the release notes and any other related source such as Rumbling Edge that may hace a change log listing.
(In reply to comment #9)
> Part of the release plan should be an announcement in
> mozilla.support.thunderbird with a link to the release notes and any other
> related source such as Rumbling Edge that may hace a change log listing.

Disclaimer: I write the Rumbling Edge, so I may actually put similar wordings in both the changelog and the release notes.

The release notes will definitely be less detailed on the changes but more detailed on the instructions and known issues though.
(In reply to comment #5)
Point 13: One item for the "Known issues" category on Windows per bug 381922, where some people apparently ran Thunderbird 1.5/2.0 in Win95/98 mode, which no longer works with TB 3.0 (setting will be inherited from previous installation): "Make sure that Windows 95/98 compatibility is disabled for the thunderbird.exe executable" or similar phrasing.

Point 14: "you won't lose any of your bookmarks or browsing history" should be replaced by "messages or address books".
As I continue to work on the draft and incorporate some of the comments / issues that have been addressed, there are still some that haven't:

2. Should we need a codename, e.g. Minefield for Firefox in its alphas, for the
alphas of Thunderbird?
-> This one is to be morphed, there's Minefield *and* Gran Paradiso for Firefox 3, so we'll need both for Thunderbird. Discussions here: http://groups.google.com/group/mozilla.dev.apps.thunderbird/browse_thread/thread/9ec84ee3da0f5eb6

Unanswered questions:
5. Is the profile for Linux / Unix systems (excluding Mac OS X) located at
~/.thunderbird ?
6. Will Alpha 1 detect incompatible extensions and disable them accordingly?
Wayne's Point 14 in comment #5: We'll need a separate default directory to install the Alpha?

(sidenotes: the style changes e.g. from Firefox to Thunderbird, can be ignored for now, I'm focusing first on the content)
(In reply to comment #12)
> Unanswered questions:
> 5. Is the profile for Linux / Unix systems (excluding Mac OS X) located at
> ~/.thunderbird ?

Yes, that won't be changing for this release

> 6. Will Alpha 1 detect incompatible extensions and disable them accordingly?

If it doesn't then the add-on manager is broken.
(In reply to comment #12)
> 2. Should we need a codename, e.g. Minefield for Firefox in its alphas, for the
> alphas of Thunderbird?
> -> This one is to be morphed, there's Minefield *and* Gran Paradiso for Firefox
> 3, so we'll need both for Thunderbird. Discussions here:
> http://groups.google.com/group/mozilla.dev.apps.thunderbird/browse_thread/thread/9ec84ee3da0f5eb6

For notes: I don't think this is something we're changing for Alpha 1. It'll still be known as Thunderbird 3 Alpha 1.

I'll have another draft out (ignoring the different styles between Firefox and Thunderbird release notes) by the status meeting next week.
I found an MAPI bug that I suggest a dependancy link to.
https://bugzilla.mozilla.org/show_bug.cgi?id=109362

I am nominating that bug as Wanted Tb 3.0  It deals with the MAPI32.DLL stub used by Moz products and how We can break some appls requiring the full MAPI to function.

A Windows specific release note is in order.  
That bug has been around since forever, but hardly affecting a lot of people. Bug 109362 comment 26 even makes me wonder if it's a bug at all in thunderbird...

(In reply to comment #11)
That bug doesn't seem like it ever affected more than a few people either. (Good to know if someone really asks though.)

What I'm saying is it doesn't make sense to include everything in the rel notes, which should be about *new* gotchas IMO.

One thing worth relnoting is the fix for bug 311657. Earlier it didn't matter if you had "Use User Name and Password" checked in the SMTP server settings even though the server doesn't support authentication, but now sending will fail if that's the case.
(In reply to comment #16 on comment #11)
> That bug doesn't seem like it ever affected more than a few people either.

Correct, there were also a couple of reports in the forums, but it's certainly not a very prominent issue. The motivation was that TB3 may not start up at all if the prior version was run in compatibility mode (bug 381922 comment #37), thus catching those people by surprise as a "semi-new" problem. If you want to include this in the release notes, it could also be just a half-sentence in the System Requirements, after the note "no longer supports versions of Windows prior to Windows 2000 (including Win95/98 compatibility modes)".
(In reply to comment #16)
> What I'm saying is it doesn't make sense to include everything in the rel
> notes, which should be about *new* gotchas IMO.

Agreed.

We should list the known *prominent* issues that people will encounter easily.
OK, will keep that in mind when I spot some other items
Attached file TB3a1relnotes-0.2 (obsolete) —
I incorporated all the comments into this TB3a1relnotes-0.2 version.

> Do we have a beta test mailing list?

I removed this line as our QA efforts continue to be ramped up, we haven't have had a beta test mailing list though. Ditto for Hendrix, I don't think any MoMo staff are reading it yet.

> Filtering on any header has been extended to news accounts.

Removed because patch for bug 16913 has been backed out due to bug 424607.

Any other obvious issues (e.g. with the tabbed interface, etc.) that should also be listed? (Known issues for Linux and Mac are still blank)

Please continue to comment away at this draft.
Attachment #316843 - Attachment is obsolete: true
Summary: Prepare Thunderbird 3.0 Alpha 1 release notes → Prepare Thunderbird 3 Alpha 1 release notes
Something I have noted about the new Add-on Manager is it refuses to install an extension if it is not sourced from a secure server. I have feedback from the Nic-Nac Project that I can hack the install.rdf to edit HTTP: to HTTPS:, as those extensions are served from both ports.  I wonder how many of the Tb extension authors know of this new requirement.
(In reply to comment #20)
* First heading is "Firefox 3 Beta Release Notes".
* AMO link does not go to /en-US/thunderbird/
* Windows profile folder could be shortened to %AppData%\Thunderbird
Attached file TB3a1relnotes-0.3 (obsolete) —
A quick update to incorporate the above 2 comments:

(In reply to comment #22)
> * First heading is "Firefox 3 Beta Release Notes".

This is a style issue which will go away with the conversion to the styles of the mozillamessaging site.

Please keep the comments coming!
Attachment #318289 - Attachment is obsolete: true
Tweaked and checked in to SVN:

URL: http://svn.mozilla.org/projects/mozillamessaging.com/trunk/en-US/thunderbird
Revision: 12621

Gary, please use that file if you need to make more changes -- there are minor changes w/ the format used for Firefox.

Still missing: known issues for Mac and Linux

Also noticed: reference to firefox tarball instead of tb tarball
 
Some broken links I'll try to fix too.
I've fixed broken links in SVN AFAIK.

The FAQ is out of date.  

  - FAQ 2 in particular should probably be changed or removed.

  - FAQ 4 is indirectly out of date.  It should mention Mozilla Messaging and the community of contributors at large.

  - FAQ 5 should result in a couple of build/QA checklist items to produce and publish a source tarball.

  - I don't believe FAQ 6 is a FAQ.

Profile for Vista is a bit off: Users\<UserName>\AppData\Thunderbird
Should be: Users\<UserName>\AppData\Roaming\Thunderbird
(In reply to comment #25)
>   - FAQ 2 in particular should probably be changed or removed.

In which way? MozillaZine has a "Thunderbird Builds" forum covering the nightly builds, which would also cover the TB 3 alphas. The Knowledge Base is focusing more on current users of the releases, i.e., TB 2.0 issues.
"FAQ #2. Where can I discuss Thunderbird 3 alpha 1 features or issues?
   General discussion takes place in the forums, particularly the Thunderbird Builds forum. You can also talk about any issue there with other users before filing a - then improved - bug report." (how about this?)
(In reply to comment #28)
> "FAQ #2. Where can I discuss Thunderbird 3 alpha 1 features or issues?
>    General discussion takes place in the forums, particularly the Thunderbird
> Builds forum. You can also talk about any issue there with other users before
> filing a - then improved - bug report." (how about this?)
> 

Discussion also takes place in user-2-user support through news://news.mozilla.org/mozilla.support.thunderbird  which is also available through the Mozilla listserv for those who prefer a e-mail kind of interface.
The listserve is linked to the newsgroup by Mailman so comments posted to group are mailed back to list subscribers.

The least reliable feedback is Hendrix, which I have commented elsewhere, is currently a dumping ground filled with Firefox comments. Specificaly the Hendrix feed to mozilla.feedback.thunderbird.prerelease 
Attached patch Another versionSplinter Review
Corrects some previous errors, tidied the wordings, etc.

Nothing done yet to the FAQ though.
Attachment #318474 - Attachment is obsolete: true
i'll take this off gary's plate.
Assignee: nth10sd → david.ascher
Status: ASSIGNED → NEW
rsx11m.pub and Ronald -- thanks, that's the kind of stuff that I want.  I'll craft something and update the FAQ, today or tomorrow.
Component: General → www.mozillamessaging.com
Product: Thunderbird → Websites
QA Contact: general → www-mozillamessaging-com
Target Milestone: --- → 3.0
Version: Trunk → unspecified
Tweaked and checked in to SVN:

URL:
http://svn.mozilla.org/projects/mozillamessaging.com/trunk/en-US/thunderbird
Revision: 12927

I've reworked a bunch of the language to be less promotional, because this is not a release about features, but a release to find out about regressions.

I've deliberately not mentioned tabs, because I don't think we really want feedback on that in its current state.

I'd love if someone could review it to see if there are any major problems.


Under System requirements, Vista has Min RAM requirements of 512 MB for Classic mode and 2GB for the Aero theme. 

An FYI, my Compaq shipped with 512MB and took ~8-10 minutes to cold boot. After a 2GB RAM upgrade boot is more respectable ~2 minutes. The bottle neck being very high usage of the Paging File which did impact Tb2 performance on my minimal hardware spec OEM Vista box.
Please see  below for an list  > ... "a list"

install <em>will overwrite</em>  >  install "defaults to overwrite"
First paragraph below <h3 id="download"> misses a space after "Alpha 1":
Mozilla provides Thunderbird&nbsp;3&nbsp;Alpha 1for Windows, ...

FAQ #2 contains now two paragraphs for comment #28 and comment #29 with redundancies (looks like the first paragraph was supposed to go).
The new features section reference to quantity of extensions is way overstated.  The AMO site has 277 approved extensions as of 20080503. The thousands quantity is true for the Fx template Our notes are leveraging. 
I don't know how many folks will read the relnotes prior to installing, but...

Installing Thunderbird 3 Alpha 1

"Please note that installing Thunderbird 3 Alpha 1 will overwrite your existing installation of Thunderbird on Windows, Linux and Mac OS X. For all systems, you won't lose any of your messages or address books, but some of your extensions and other add-ons might not work until updates for them are made available.

Users are highly encouraged to install Thunderbird 3 Alpha 1 in another folder (during Custom Install) and backup their profiles before testing Thunderbird 3 Alpha 1."

>>To protect your original installation of Thunderbird you are highy encouraged to choose "custom intall" in the installation menu, and install Thunderbird 3 Alpha1 in a separate folder.
 
(Perhaps some reference to zip builds and latest-trunk links is in order here as an alternative.)Although I don't think we have specific instruction for doing so anywhere.
I suggest to change

  even though the server does not support authentication 

to

  if the server doesn't offer any mechanism to authenticate
I've made some more changes, including changing the name to Shredder.

You can see it on the staging site at: http://localhost/en-US/thunderbird/3.0a1/releasenotes/

username: messaging
pw: m355

Feedback welcome.
sigh.  that would be http://messaging-trunk.localgho.st/en-US/thunderbird/3.0a1/releasenotes/

except if you happen to be on my box =)
Link brokenness:
* https://add-ons.mozilla.com/en-US/thunderbird/extensions/ should be https://addons.mozilla.org/en-US/thunderbird/extensions/
* https://add-ons.mozilla.com/en-US/thunderbird/themes/ should be https://addons.mozilla.org/en-US/thunderbird/themes/
* http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/3.0b1/source/ should be http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/3.0a1/source/
Misc:
* until the add-on developer explicitly upgrade their add-on. should be until the add-on developer explicitly upgrades their add-on. 
* there should be a link to the Linux system requirements
* For builds for other systems and languages not provided by Mozilla.org, should be For builds for other systems and languages not provided by Mozilla, (iirc the Mozilla.org branding was dropped five years ago.)
* (during Custom Install) should be (on Windows, this is done using Custom Install)
* slow down page display, etc. should be slow down message display, etc.
URL fixes done as per reed, because he uses big words like policy.

bielawksi: where do you think there should be a link to the linux sysreqs, other than there already is? 

Thanks for all of those fixes.

suggest "Installing..." can be simplified to one paragraph as follows.

Users are highly encouraged to install Shredder Alpha 1 in another program folder by using Custom Install option, and backup their profiles before testing Shredder Alpha 1. Otherwise, installing Shredder Alpha 1 will overwrite your existing installation of Thunderbird on Windows, Linux and Mac OS X. For all systems, you won't lose any of your messages or address books, but some of your extensions and other add-ons might not work until updates for them are made available.


Last sentence sounds awkward to me, or for that matter not sure what the first phrase of it is trying to say, but I'm brain dead at the moment and not coming up with anything better.
better?

Users are highly encouraged to install Shredder Alpha 1 in another program
folder by using Custom Install option. Otherwise, installing Shredder Alpha 1 will overwrite your existing installation of Thunderbird on Windows, Linux and Mac OS X. For all systems, installation will not cause you to lose any profile data - local messages, address books, etc - but you are advised to backup you profile before installing and testing Shredder Alpha 1. Some extensions and other add-ons might not work until updates for them are made available.

> will overwrite your existing installation of Thunderbird on Windows, Linux and Mac OS X

Do we need to mention any OS here? We only have an installer at all on windows...


(In reply to comment #47)
> better?
> 
> Users are highly encouraged to install Shredder Alpha 1 in another program
> folder by using Custom Install option. Otherwise, installing Shredder Alpha 1
> will overwrite your existing installation of Thunderbird on Windows, Linux and
> Mac OS X. For all systems, installation will not cause you to lose any profile
> data - local messages, address books, etc - but you are advised to backup you
> profile before installing and testing Shredder Alpha 1. Some extensions and
> other add-ons might not work until updates for them are made available.
> 

This is better. Nit: 'backup you' should read 'backup your'

Fabulous layout, love the presentation.

"Downloading Shredder Alpha 1

Mozilla provides Shredder Alpha 1 for Windows, Linux, and Mac OS X in a variety of languages. You can get the latest version of Shredder Alpha 1 here. For builds for other systems and languages not provided by Mozilla, see the Contributed Builds section at the end of this document."

I would like to see a Mozilla Messaging tie in for this section. It is Our Community that I view is offering the build. Thus inserting Messaging after Mozilla in line one builds our identity and Mozilla family association.

I did not see a Contributed Builds section at the end.

The link to System requirements was broken at 0211 EDT 20080509. Page not found error. 

The link _get the latest version of Shredder Alpha 1 here_ also generated a 404 Page Not found.

See my comment https://bugzilla.mozilla.org/show_bug.cgi?id=429235#c38 about the quantity of extensions at AMO. My full audit was done before AMO added a catagory listing all the localization dictionaries. 
> The link to System requirements was broken
http://messaging-trunk.localgho.st/en-US/thunderbird/system-requirements/

In line with comment #35, the system requirements appear somewhat outdated. Whatever is specified there as "minimum" one should expect that it will work.

Just wondering, did anybody try if 3.0a1 would run on a Pentium 233 MHz with
64 MB RAM running Win2k? Similar for the other platforms, also with respect to the library/package requirements on Linux.
Ronald: thanks for the broken link re: sysreqs.  Fixed.
I think i got rid of references to lots of extensions -- is there something you're still seeing?

re: sysreqs -- I'm going to defer until the Fx3 folks figure out what they want to do there, and we can riff off of that.
This sentence in the Features is still unrealistic in the quantity of Add-ons.

"The new Add-ons Manager (Tools > Add-ons) can now be used to download and install a Thunderbird customization from the thousands of Add-ons available from our community add-ons website."

The 'thousands' should read 'hundreds'.

The Shredder d/l link is still a 404, should link to a dummy page if the package is not ready to ship (anyday).

In the Known Issues section: All.
Your call on the small memory leaks being addressed on trunk that should land by 3.0a2.

My last nits.
checked in changes including addressing comment #53 and comment #54.
Calling it done, although I think for a2 we should address the problem that as dmose said, the most important bits are way too hidden.  I'd like to change the format of release notes to make them feel less like CYA and actually useful (and likely to be read!)
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
No longer depends on: 432188
filed Bug 443369 for alpha 2 release notes
Product: Websites → www.mozilla.org
Product: www.mozilla.org → www.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.