mail recipient changed when composing reply to address which is contained in own identities

RESOLVED DUPLICATE of bug 377998

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 377998
10 years ago
10 years ago

People

(Reporter: hw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 SeaMonkey/1.1.8 Mnenhy/0.7.5.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 SeaMonkey/1.1.8 Mnenhy/0.7.5.0

Replying to a message originated from an address that is used as a variant in my own identitites results in having the recipient changed to the main address of the according account.

Reproducible: Always

Steps to Reproduce:
0) have somebody@else.com amongst the identities of me@own.org
1) receive mail from somebody@else.com on my@own.org
2) reply to that message (using "reply to sender" or "reply to all")
3) recipient changed to me@own.org
Actual Results:  
recipient changes to myself

Expected Results:  
recipient should equal sender of message

somebody@else.com must be in the identities list of the account me@own.org; having  somebody@else.com in some other account doesn't produce this error.

mail coming in me@own.org via list@own.org produces the same error, the reply's recipient then being list@own.org (although return path is correctly set to "somebody@else.com").

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377998
You need to log in before you can comment on or make changes to this bug.