Closed Bug 377998 Opened 13 years ago Closed 12 years ago

wrong address when reply (for replies between account identities)

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3

People

(Reporter: deneb7000, Assigned: mkmelin)

References

Details

(Keywords: regression, Whiteboard: [workaround in comment 17])

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 2.0.0.0 (20070326)

when you try to reply to an email, the recipient address proposed in the compose window is wrong.

Reproducible: Always

Steps to Reproduce:
1. select an incoming email
2. click reply or reply to all button
3. 
Actual Results:  
the recipient address proposed is the recipient of the original email, that is my own email address

Expected Results:  
the recipient address proposed should be the sender of the original mail

previous releases of thunderbird works well
this bug appears ONLY when reply to forwarded emails
maybe the reply-to adress is different, have you checked the header of the mail ?

Maybe its a kind of:

from: a@example.com
and
reply-to: b@example.com

so the reply would go to b@examle.com
I checked the headers and ther's no reply-to.
I make an example:

a@example.com send an email to b@example.com

b@example.com forwards that email to c@example.com

when c@example.com click on reply in the compose window appears as recipient email c@example.com instead of b@example.com


In tb2 "reply to self" is treated as a follow up - so that would be expected when those are the same person;) Confusing for testing, but oh so useful for real use when replying to your own messages from the sent folder.

->INVALID
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
I don't understand your answer! For you is it not a bug?
If I reply to an email I would like it to be sent to the sender and not to myself. ;)
I saw this anomalous behavior when I tried to answer to an email (selected from inbox folder, not sent folder) that was forwarded to me.
I never replied to my own messages from the sent folder.
And what's "reply to self"? There's only "Reply" and "Reply All".
I confirm that previous releases of TB works well, so I would like also TB2 to work well.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
I just upgraded to Thunderbird 2.0.0.0 and experience the exact same issue for replies (not just forwarded mail, btw). Except, I have found the recipient of the reply only becomes the recipient of the original if the sender of the original mail is an identity of the current TB account.

Consider the following scenario:

I have E-mail address richard@example.com and my wife has debby@example.com. I have added debby@example.com as an extra identity to my TB account, so I can reply in her name to something she might forward me. Now when she sends me mail, and I reply to it, I suddenly reply to richard@example.com. This can't be right.

Additionally, I noticed that the From: line of the reply is taken literally from the To: line of the original mail. So if my identity is "Richard van den Berg <richard@example.com>" and my wife sends mail to "Richard <richard@example.com>" the From: line of the reply will become "Richard <richard@example.com>" which is taken from the original mail, not my identity list.

-> CONFIRMED
I think the "reply to self" mechanism as described in comment #4 should be restricted to the Sent folder only. Of course whatever the "Sent" folder should be looked up in the account properties under "Copies & Folders" -> "Place a copy in".
Another solution is to only change the recipient of the reply into the recipient of the original when ALL of the following conditions are met:

1. The sender of the original is an identify of the account
2. The recipient of the original is NOT an identity of the account

At the moment it looks like only the first condition needs to be true for the "reply to self" mechanism to kick in.
The "reply to self" is automatic, there is no button for it, as you have noted. 

By default it checks all identities of the account, setting mailnews.reply_to_self_check_all_ident to true can make it check all identities of all your accounts. 

> reply in her name to something she might forward me

Why would you want to reply in her name?
> Why would you want to reply in her name?

Because I want to skip the "Hi, I'm Richard (Debby's husband whom you've never mailed with before)" explanation and avoid confusion at the recipient end. But that's not the point here. The point is that the "reply to self" mechanism is rather braindead. Implementing my suggestion in comment #8 would fix this, and doesn't sound like it's hard to do.
(In reply to comment #3)
> a@example.com send an email to b@example.com
> b@example.com forwards that email to c@example.com
> when c@example.com click on reply in the compose window appears as recipient
> email c@example.com instead of b@example.com
(In reply to comment #6)
> Consider the following scenario:
> I have E-mail address richard@example.com and my wife has debby@example.com. I
> have added debby@example.com as an extra identity to my TB account, so I can
> reply in her name to something she might forward me. Now when she sends me
> mail, and I reply to it, I suddenly reply to richard@example.com. This can't be
> right.

To deneb7000@yahoo.com (Bug opener) and Richard van den Berg : 
Can you attach real mail data which can explain your problem?
 1. Save a mail as ".eml" file.
 2. Check message headers in .eml file using text editor.
    Possibly transfer with resent-to/resent-from case. 
    (different from forward as attachment or inline case).
 3. Change sensitive data (eg. mail address) to string like sender-1@server-1,
    by text editor.
 4. Attach .eml file to this bug(mime-type=text/plain, if size is accepted).

(In reply to comment #6)
> Additionally, I noticed that the From: line of the reply is taken literally
> from the To: line of the original mail.

To Richard van den Berg :
Problem in "Pre-selected From: when reply" is completely different problem from this bug, problem in "recipient address proposed in the compose window".
See Bug 327713 for current design(and a problem in current design). 
(In reply to comment #4)
> In tb2 "reply to self" is treated as a follow up - so that would be expected
> when those are the same person;)

To Magnus Melin :
Is Tb-2's latest patch related to "reply self" is one by Bug 342315?
And when Tb-1, level of Bug 85296 fixed?
Question to clarify:
Problem(or current logic) can be said as follows?
  When multiple identities are used, and if an identity forwarded a mail to
  another myown identity, proposed candidate in reply becomes main identity of
  the account.
Attached file Original mail
The original mail shown in the first attachment is a typical mail I receive from my wife. It is no forward, and she often uses Squirrelmail.
Attached file Reply to original mail
The reply in this attachment is what happens when the E-mail address of my wife is an identity of my Thunderbird account. I end up replying to myself. Please note that this has nothing to do with forwards. I believe that is just how the bug opener first came across this bug.
I think this bug is a direct result from fixing Bug 317167. The problem description in comment #12 is a bit off. I would say it is:
  When multiple identities are use, and if an identity X sends mail to another
  identity Y of the same TB account, proposed candidate in reply becomes Y instead 
  of X.
Attachment #262395 - Attachment mime type: message/rfc822 → text/plain
Attachment #262397 - Attachment mime type: message/rfc822 → text/plain
(In reply to comment #15)
> I would say it is:
>   When multiple identities are use, and if an identity X sends mail to another
>   identity Y of the same TB account, proposed candidate in reply becomes Y
>   instead of X.

Thanks for data to recreate problem and clear problem description.

Problem is re-created with Thunderbird trunk(2007/4/13, MS Win-XP SP2) and Original mail you attached which doesn't have Account-Key: header.
(X-Mozilla-Status:/X-Mozilla-Status2: are added by first compact folder.)
(X-Mozilla-Keys: is added by second compact folder.)
 1. Account(account2) has id1,id2,id3. id1=my-own-mail-addr.
     Case-1: id2=your wife's mail addr, id3=your mail addr. 
     Case-2: id2=your mail addr,        id3=your wife's mail addr.
 2. In both cases, From:/To: becomes same one as your Reply to original mail.
    From: is your mail addr with name. To: is your mail addr without name.

However, when I added "X-Account-Key: account2" header manually,
From: becomes my main identity's mail addr with name, and To: becomes your wife's mail addr(real mail sender) with name.

To deneb(bug opener) :
Is your problem in comment #0 same as Richard's case?
Does description in Comment #15 expalain your problem?
This is basically a result of bug 317167. Note that you can work around it by setting up the other address not as an identity of the same account, but as an identity of another account.
Summary: wrong address when reply → wrong address when reply (for replies between account identities)
(In reply to comment #17)
> Note that you can work around it by setting up the other address not as an identity of the same account, but as an identity of another account.

To Magnus Melin :

My test result with X-Account-Key: says ;
  This bug (Bug 377998, proposed recipient issue) won't be exposed,
  if X-Account-Key: header exists and account in the header exists.
Is it true?
(Sorry but I don't know result when account in X-Account-Key: doesn't exist.)

If it's true, I think this bug usually won't occur if mail used for reply was downloaded by Mozilla/Thunderbird which supports "Global Inbox" (Thunderbird 1.0.0 supported it). 
Is this true?
(Similar issue to Bug 327713, From: always becomes main identity's mail addr)
(when multiple identities are defined, will occur, though.)
Bug 327713 is another issue. 
This has nothing really to do with account key, and I expect to see it for all replies between identities of one account. So it would show up for testing and unusual use cases.
(In reply to comment #19)
> I expect to see it for all replies between identities of one account.
How can you explain my test result with "X-Account-Key: account2" of existing/valid account2 in comment #16?
Not sure I understood that, but X-Account-Key is needed (on pop) to know which account to go through the identities for.
Duplicate of this bug: 378193
(Correction of comment #20)
> (In reply to comment #19)
> > I expect to see it for all replies between identities of one account.
Oh sorry, your "expect to see it" was on "X-Account-Key: header".

To Richard van den Berg :
How did you obtained or created the "Original mail" you attached?
If downloaded by Thunderbird 1.0 or later, X-Account-Key: header is always added in order to support "Global Inbox". 
IMAP doesn't have an X-Account-Key... 
(In reply to comment #24)
> IMAP doesn't have an X-Account-Key...
Oh, IMAP case...
Probably always same when imported mails to "Local Folders".
To deneb7000@yahoo.com (bug opener) :

(Q1) Is your mail server IMAP?
Questions in Comment #15 again.
(Q2) Is your problem in comment #0 same as Richard's case?
(Q3) Does description in Comment #15 explain your problem?
In reply to comment #23: my wife mostly uses Squirrelmail, so I created the original E-mail use that client. I do use IMAP, btw.
Sorry for my delay, yesterday i had no possibility to answer.
I made some tests and my problem appears when i have in multiple identities the email address from whom the email is coming. Deleted that identity, it's all ok.
My server is not imap but pop3 but there is no correlation with it.
So:
a@exmaple.com sends to b@example.com
if b@example.com has among identities a@exmaple.com, then when replying, the proposed recipient is b@example.com instead of a@exmaple.com
To Magnus Melin :
Do you still think INVALID? Can you confirm this bug? I can't confirm even I got result of Comment #16 because I don't know IMAP well.
Hi,
I can confirm this is a bug unique to TB2.0 in that replying to emails does not add the senders email address in the TO: field of the reply. In previous versions (1.0 - 1.5) the sender email address was placed in the TO: field of the reply.
Steps to reproduce:
1. Install TB2.0 from the website onto Windows 98 (I've repoduced this in XP as well)
2. Setup IMAP account for user1@example.com
3. Send email TO:user1@example.com FROM:user2@example.com
4. If you REPLY to sent email and the TO: field will contain user2@example.com
5. Go to Account Settings (for the account user1@example.com) -> Manage Identies
6. Add user2 as an identity with a email address of user2@example.com
7. If you REPLY to the email sent in step 3 now the TO: field will contain user1@example.com

An assumption that a managed identity equals the account holder is wrong. If you would like use cases for why I would like reply to an identity instead of a account holder I can supply them, it may be long winded :), however I think Richard van den Berg has already provided a excellent example of this.
Ok, let's mark it NEW... Though the use cases so far are a little bit odd imo. 

Mat: I wouldn't mind hearing your use case.
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 2.0
I've got a number of identity's and I just realized something, this problem only occurs to me if the recieved email is
 * from somebody who is also an identity 
 * there is not TB account for the person
 * I am not subscribed (imap and acl's) to that account
I do have managed identies that this isn't occuring on however I am subscribed to part of that account.

To answer your question Magnus.
The only use case that I have now, assuming that I'm right in that it only occurs with no account or subscribed account present, is impersonating other people. I want to send emails that appear to come from somebody else and have the reply go back to them, if they send me a email I want to reply back to them, not myself. 

The main purpose for this with me is that I sometimes need to do something (I'm IT support/admin/mgmt/the kettle is broken/etc... btw) for somebody else that results in sending a email, it is usually easier to do that on my machine as it is setup for more tasks than that of the common user. It is infinitely easier to setup an identity to do this rather than an account, particularly if I plan to help them again later which isn't uncommon. Multiple accounts would also slow TB down (can't have that) and stress the server more than an identity would.

From my point of view identity's allow you to send a email as any name, however this reply bug assumes that you really want to reply as the account holder if that name isn't an account or subscription. I think this assumption is wrong, I (as the user) know what I want to do and I've discovered a really flexible way of working that it appears the dev's didn't consider and has now been broken (a bit). I'm not trying to be disrespectful here, just trying to make the point that I know my needs better than they do and anytime they reduce functionality they reduce the market for TB, and if they swap feature A for feature B then break something for some existing users.

My suggested solution is that if there was a case for "reply to account holder of identity", TB2.0 behavior, then there is also a case for "reply to the identity", TB 1.0 - 1.5 behavior, (me, Richard and dened7000 at least) and that maybe a setting in about:config would make everybody happy (aside from the people who don't rtm, change log, google or about:config).
My last comment was a bit misleading in that it is account or subscription dependant, the rest about impersonating stands. I'll try again
 * If I reply to a email in my imap account from ANY identity TB will reply to the account holder. Example: If support@ (subscribed to imap account in TB) sends a email to mat@ (setup imap account in TB) then when replying to that email TO: will be mat@, not support@)
 * If I reply to a email in a subscribed account from ANY identity (including the main account identity) TB will reply to the subscribed account holder. Example: If mat@ sends a email to support@ then when replying to that email TO: will be support@, not mat@)

I hope this is clearer.
I am seeing the same sort of behavior.  Specifically, if someone sends a message to my primary e-mail address, say user1@mydomain.com and they CC another of my identities, say user2@mydomain.com -- using either the reply or reply-all, the resulting response e-mail has user1@mydomain.com in the "to" field.

I would expect to have the FROM or REPLY-TO value from the first message as my new recipient, rather than myself.

This has only been apparent in TB 2 for me.
This is probably related to this bug let me know if you want a new ticket.

I sent a email from mat@ to multiple recipients with one of those recipients being somebody I impersonate (a managed identity, call him bob@), after I sent the email I found additional info that was related so I went to my sent items and selected Reply All. The TO: and CC: fields were correct in that they contained the original recipients however the FROM: field was the managed identity bob@. I then went and deleted the managed identity bob@ altogether and did Reply All to the same email, this time everything was correct FROM: was mat@ and the recipients (including bob@) were also correct.

Whatever changes were made did not anticipate the ingenuity of the user to do things differently, I hope this helps. 
This is exactly the issue happening to me, and it explains why this is a problem.  There are many reasons people may want to reply between identities -- and not have the Reply to the From e-mail address (that sent it) overridden with a reply to oneself, the address you are sending from.  I have an identity on my brother's Thunderbird and my business partner has an identity on mine, for instance-- just for the occasions when we have to use one another's computers to send an e-mail.  This reply-to-self thing is a real mess.
("this is exactly the situation" Refers to Richard van den Berg, comment #6 -- I thought I was replying directly to his comment).

To reiterate why I think this should be fixed, that it should be considered a bug, people who have a legitimate reason to have an identity of another person on their account -- say, husband and wife who occasionally swap computers for Mac/PC/different programs/locations whatever -- are also likely to e-mail one another a lot, and not reply to self.  
Whiteboard: [workaround in comment 17]
My situation is the following:
- I have two identities (examples) 1. work@domain1.fi & 2. private@domain2.fi and the two are handled as separate accounts. #1 is shown as the topmost account
- When I "Reply all" to mails coming to #1 I am myself cc:d to the reply
- When I "Reply all" to mails coming to #2 I am not cc:d

I have a huge amount of collected addresses, including both of my identities
Sorry, I found the reason: When re-creating my settings I had mis-spelled my email address in the #1 account's Identity form.

Now it works. Sorry for confusing you.
I am experiencing the same problem.

Description and purpose of using those identities I have explained in

http://forums.mozillazine.org/viewtopic.php?p=2945101

What I don't understand, why TB in first place is trying to match the "Reply" with the eMail addresses from the identities instead of just using the eMail address given in the eMail's "From:" -> isn't this the most obvious scenario for a reply? I mean, when I reply I -want- to reply to the "From:", why in the world I would want to reply to someone else?

I think this is too much of assistance, maybe an option giving the choice of how "Reply" acts would do the trick. Just taking the "From:" would do for me, really.
(In reply to comment #40)
> What I don't understand, why TB in first place is trying to match the "Reply"
> with the eMail addresses from the identities instead of just using the eMail
> address given in the eMail's "From:" -> isn't this the most obvious scenario
> for a reply? I mean, when I reply I -want- to reply to the "From:", why in the
> world I would want to reply to someone else?

Please read the bug before commenting, it's for making follow-ups to mail you sent out yourself. There is also a workaround in comment 17.
(In reply to comment #41)
> Please read the bug before commenting, it's for making follow-ups to mail you
> sent out yourself. 

Hi Magnus,
I think you are mistaken here. I have managed identities of real people, the identities on my account are used occasionally but the real people email me regularly and when I reply to these real people the reply goes back to myself.

I have to say that I agree with Robert (comment 40), I'd like to be able to reply to the sender of the email, not somebody TB thinks is the sender and I'd be happy with a if that was an option. 

Sorry if I wasn't clearer earlier.
Just to clarify the workaround described in comment 17 does work as of TB 2.0.0.4. However you can't setup managed identities on Local Folders so if you only have one account (like me, I use acl's on imap to share accounts) then you will need to create a dummy account to hold you managed identies.
Duplicate of this bug: 373749
Duplicate of this bug: 400056
This feature works on MAC and Linux...why wouldn't this get fixed for Windows?  If the MAC guy in my department finds out about this I'm gonna have to quit!
This isn't platform specific. If you don't see it on all platforms, it's something else - or you have a different setup.
We've tested version 2.0.0.6 (20070728)on multiple Windows XP boxes, Centos, Suse, and MAC and the problem is only on Windows.  This is the default install of Thunderbird with a basic imap config.  We even tried version 2.0.0.0 with the same results across platforms.

Setup seems to be the same

So, if it's something else, wouldn't this be a different bug?

Yes, it's a different problem then.
To Magnus Melin:
Fortunately, Bug 362470 is not closed as INVALID yet.
I recommend you to close this bug as DUP of Bug 362470 and confirm Bug 362470, for ease of tracking, for proper bug handling, for ease of resolving problem.
 - Bug 362470 is older report of problem.
 - Bug 362470 has clearer/simpler description on problem since initial bug open.
 - This bug is already sufficiently messy than Bug 362470, because discussion /
   analysis of "bug or not(INVALID or NEW)" is involved.   
Duplicate of this bug: 362470
Keywords: regression
I think this bug report lacks a clear description how to reproduce the behaviour. It has nothing to do with IMAP.

1. create two identities in your current account: A@example.org and B@example.org
2. create an e-mail from A to B
3. save that e-mail as a draft
4. you can move it the the inbox if you like
5. reply to that e-mail
=> A compose window pops up with B being recipient and sender at the same time, although A was the sender of the original e-mail
Like Benjamin and others I have my wife's work email address on my PC so she can send emails 'from work' on the weekend using my (Win2K) PC.  And when I reply to  an email she does actually send me from her work, I have to manually change the "To" box in order not to reply to myself.

However has anyone else noticed that in this circumstance "Reply" = "Reply All"?

If she sends an email to me and others and I press "Reply" (NOT "Reply All") the new email is addressed to me (not her) AND ALSO to all the other addressees!  "Reply All" behaves exactly the same way. 

Should this be a separate bug?  
Like Richard and others I have my wife's work email address on my PC so she can send emails 'from work' on the weekend using my (Win2K) PC.  And when I reply to  an email she does actually send me from her work, I have to manually change the "To" box in order not to reply to myself.  (Note that this is a slight variation on the instructions in comment #52: create two identities in your current account: A@exampleX.org and B@exampleY.org, ie different domains.)

I agree with Robert (comment #40); why should the "To" be anything other than the original "From"?

However has anyone else noticed that with this bug "Reply" becomes "Reply All"?

If my wife sends an email addressed to me and others and I press "Reply" (*not* "Reply All"), the new email is addressed to me (not her) _and also_ to all the other addressees!  Same as "Reply All".  Can be embarrassing!   

Should this be a separate bug report?  
This bug is really frustrating. I encounter it multiple times a day, usually when I am replying to my own sent mail to add a post script to a message I have just sent. I DO NOT want to send the message to myself, and I would prefer that the original to and cc address be preserved.  Having the mail to go me and have everyone else be cc'd is just a pain.
Attached patch proposed fixSplinter Review
Don't treat it as reply-to-self if one of the recipients is an identity.
Assignee: mscott → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #289955 - Flags: superreview?(bienvenu)
Attachment #289955 - Flags: review?(bienvenu)
Comment on attachment 289955 [details] [diff] [review]
proposed fix

thx, Magnus - bugs with 55 comments can be hard to navigate :-)
Attachment #289955 - Flags: superreview?(bienvenu)
Attachment #289955 - Flags: superreview+
Attachment #289955 - Flags: review?(bienvenu)
Attachment #289955 - Flags: review+
Checking in mailnews/compose/src/nsMsgCompose.cpp;
/cvsroot/mozilla/mailnews/compose/src/nsMsgCompose.cpp,v  <--  nsMsgCompose.cpp
new revision: 1.534; previous revision: 1.533
done

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3
Test result with Tb latest-trunk(version 3.0a1pre 2007112504, on MS Win-XP).

Environment: (same setup as problem re-creation test in comment #16)
 - Dummy POP3 account
 - Mail addresses
     main   identity : aaa-1@aaa.aaa.aaa
     second identity : aaa-2@aaa.aaa.aaa
     third  identity : aaa-3@aaa.aaa.aaa
     xxx@xxx.xxx.xxx is not defined at anywhere(unknown mail address)
 - Mail for test
   Following X-Mozilla-xxx headers. No X-Account-Key: header 
   > X-Mozilla-Status: 0001
   > X-Mozilla-Status2: 00000000
   > X-Mozilla-Keys:
Test cases:                                                                                 
 (Case-1) From: aaa-2@aaa.aaa.aaa   To: aaa-3@aaa.aaa.aaa
  Pre-set From: when Reply = aaa-3@aaa.aaa.aaa
  Pre-set To:   when Reply = aaa-2@aaa.aaa.aaa  
 (Case-2) From: xxx@xxx.xxx.xxx     To: aaa-3@aaa.aaa.aaa
  Pre-set From: when Reply = aaa-3@aaa.aaa.aaa
  Pre-set To:   when Reply = xxx@xxx.xxx.xxx 
 (Case-3) From: aaa-2@aaa.aaa.aaa   To: xxx@xxx.xxx.xxx
  Pre-set From: when Reply = aaa-1@aaa.aaa.aaa
  Pre-set To:   when Reply = xxx@xxx.xxx.xxx

"Reply-to-Self" is applied only when (case-3), as written in Comment #55.
(Sorry but I didn't check multiple To: case, CC: case, "Reply All" case.)
To bug opener and to all problem reporters:

What is you test result with latest-trunk to which the patch was applied?
Can this bug's status be changed to VERIFIED?
I made some tests with version 3.0a1pre (2007112704) on WinXP.

Accounts installed:

1. aaa@aaa.aa
   identities: bbb@bbb.bb, ccc@ccc.cc

2. bbb@bbb.bb
   identities: aaa@aaa.aa, ccc@ccc.cc

Tests:

1. Mail sent from aaa@aaa.aa to bbb@bbb.bb
   when reply 
     pre-set to:   aaa@aaa.aa
     pre-set from: bbb@bbb.bb

2. Mail sent from bbb@bbb.bb to aaa@aaa.aa
   when reply 
     pre-set to:   bbb@bbb.bb
     pre-set from: aaa@aaa.aa

3. Mail sent from ccc@ccc.cc to aaa@aaa.aa cc bbb@bbb.bb
   when reply (from aaa@aaa.aa)
     pre-set to:   ccc@ccc.cc
     pre-set from: aaa@aaa.aa

   when reply (from bbb@bbb.bb)
     pre-set to:   ccc@ccc.cc
     pre-set from: bbb@bbb.bb

   when reply to all (from aaa@aaa.aa)
     pre-set to:   ccc@ccc.cc
     pre-set cc:   bbb@bbb.bb
     pre-set from: aaa@aaa.aa

   when reply to all (from bbb@bbb.bb)
     pre-set to:   ccc@ccc.cc
     pre-set cc:   aaa@aaa.aa
     pre-set from: bbb@bbb.bb


For me it'all ok, well done!
Thanks to all.
Duplicate of this bug: 410808
Duplicate of this bug: 417499
Duplicate of this bug: 429390
Duplicate of this bug: 432871
The workaround in comment #17 creates a worse problem than this bug:

Like others, I have TB setup for myself and my wife and experience this bug.
The workaround solves the particular problem stated, but creates the situation where the person who is listed under the "dummy" account can no longer reply to any normal email with TB setting the correct "From" user.  Instead, it always defaults to the single account user.

This workaround is, unfortunately, not a valid one, it is worse than the original problem.

Better "part" workaround (just implemented, not well tested, but seems to pass initial test):
Note: For *one* of the two users you can use my "half" workaround, which is to create a TB filter so that when the To: is my wife's email address and the From: is also my wife's email address, then I know this bug has messed it up and I move the message to *my* In box.


In any case, not trying to offend anyone, but this bug is a true bug, and NOT RESOLVED.
If this bug has been fixed, I apologize.  I had read that this is by design.  Will this be in TB release 3.0?
Yes this is fixed for tb3.
Duplicate of this bug: 450103
Duplicate of this bug: 448465
Duplicate of this bug: 383597
I operate eight websites.  One of them generates a lot of email traffic.  Another generates a moderate amount of traffic.  The other six have less traffic.  They are hosted at GoDaddy.  

In my Thunderbird program (2.0.0.22) I have set up nine mail accounts, each with a different reply-to address.  For purposes of this memo, I will call the accounts Main1, and Web1 thru Web8.

Mail for the busy website is received at GoDaddy, with an automatic forward to my Web1 account at my ISP.

Mail for the seven less busy websites is received at six different mail addresses at GoDaddy, then all of it is forwarded/funnelled into my Main1 account at my ISP.  Once I have downloaded the Main1 emails to my computer, I manually redistribute them to the Inbox for the appropriate account (Web2 – Web8).  My personal mail goes directly to the Main1 address at my ISP, and I leave it in the Main1 Inbox on my computer. 

I am relatively new to Thunderbird. Until June 1 I used Mozilla Mail (“MM”).  When I switched over I imported many of my old email messages.

In Thunderbird, a problem occurs when I reply to an email which I have manually moved from the Main1 Inbox to any one of the Web2 – Web8 Inboxes.  If I then reply to that message, the reply will by default go out with the Main1 account shown as the return address, and the copy of the sent message will be placed in the Sent box of the Main1 account.  This happens despite the fact that for each of the Web2 – Web8 accounts I have entered its own unique account identity.  I am aware that before sending the message I can drop down a list of return addresses and select the correct one, but I have found it impossible to remember to do that 100% of the time.  I would prefer for the program to operate like Mozilla Mail did:  MM would use the return address associated with the account where the incoming mail was filed.  

And there is one more twist to all this.  If today I reply to a message that was filed in (for example) the Web4 Inbox back when I was using MM, Thunderbird will send that message out just like MM did – with the return address associated with Web4! 

I don’t know if this is a bug, or a deliberate design change.  But I hope that no matter which it is, you will provide an optional setting to make it operate like Mozilla Mail did.
webmaster@killthegoose.com: that has nothing to do with this bug. This is about replying to mail you=[one of your idenitities] sent to yourself.
(In reply to comment #72)
> webmaster@killthegoose.com: that has nothing to do with this bug. This is about
> replying to mail you=[one of your idenitities] sent to yourself.

The reason I thought it might be this bug is that I was looking at Comment # 3 on bug 383597 - which is listed as a duplicate of this bug - and Comment # 3 described  the problem I am having very well.   Do you know of another bug that applies?
Possibly bug 327713.
You need to log in before you can comment on or make changes to this bug.