Closed Bug 429438 Opened 12 years ago Closed 12 years ago

Allow new tabs to be opened adjacent to focused tab

Categories

(Firefox :: Tabbed Browser, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 465673

People

(Reporter: jason, Unassigned)

Details

(Keywords: uiwanted)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008040514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008040514 Firefox/3.0b5

A feature I would really like to see built into FF3 would be the option to open a tab directly next the tab that I am currently focused on, instead of to the right side of all existing tabs.

If you have many tabs open and open a new tab, it can be quite difficult to get back to your original tab. The original tab might end up buried on the far left of your tab-bar.  I constantly have users lose track of their original working tab and it always takes a few seconds of searching to pull it back up. Opening a new tab directly to the right of your focused tab helps you easily get back to where you were just working.

There is an extension to support this, however it is not currently available for FF3. The functionality seems primitive enough to be implemented in the browser itself.

Reproducible: Always
Keywords: uiwanted
OS: Linux → All
Hardware: PC → All
Summary: Allow new tabs to be opened next to a focused tab → Allow new tabs to be opened adjacent to focused tab
Sorry, but I don't think your going to see this for Fx3, the feature set for Fx3 has been long frozen. It's a nice idea, but I know developers don't like too many options cluttering the Fx UI.

I like it, so I'll make it was new, but will probably get marked as WON'TFIX, you'd probably have better luck suggesting it for SeaMonkey.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 262459
Jason, so you know, there are some people who are running various user studies looking at tabbing behaviour to help us get a bit more data on this topic. It's definitely one that we continue to think about, but for now, the decision of bug 262459 stands.
Duplicate of bug: 465673
You need to log in before you can comment on or make changes to this bug.