Input field broken (edit commands, no cursor, arrow left/right ) in Chatzilla

VERIFIED FIXED

Status

Other Applications
ChatZilla
--
major
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: whimboo, Assigned: sicking)

Tracking

({regression})

Trunk
regression
Dependency tree / graph
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008041604 Minefield/3.0pre ID:2008041604

It seems that with the current nightly build I'm not able to paste any text within the text field of Chatzilla. Must have been regressed with todays nightly build.

Steps:
1. Open Chatzilla
2. Copy some text from a webpage
3. Goto Chatzilla and hit Cmd+V inside the text field

Nothing happens. Text from within the clipboard is not pasted into the text field. Using other text fields within the browser works fine instead.
Flags: blocking1.9?

Comment 1

10 years ago
Cmp:
bug 429172
bug 428840
bug 429475

Updated

10 years ago
Severity: normal → major
OS: Mac OS X → All
Hardware: PC → All
ChatZilla 0.9.81
XULRunner 1.9pre/2008041510
Windows XP

All edit commands are disabled for the text input field.
(Reporter)

Comment 3

10 years ago
Would be nice to have a closer regression range here.
Keywords: qawanted
Summary: Paste doesn't work for Chatzilla → Edit commands (Select All/Copy/Paste) don't work in Chatzilla
Whiteboard: [need regression range]
(Reporter)

Comment 4

10 years ago
Note: All menu entries within the Edit menu are disabled!

Comment 5

10 years ago
i had the paste problem in the latest 2 nightly, also cursor keys do not work

Comment 6

10 years ago
Henrik, I am off to work now so do not have time to find the regression range. Check the hourly builds here http://hourly-archive.localgho.st/ find the last build it works, and the first build it fails and post it here along with the cached checkins for the failed range.
-'ing this for the same reason as in bug 429578 comment #4.  If this is a regression from the currently key event blockers, it'll get fixed with the 1.9 release.  Will accept a patch for 1.9, but won't block it.  Re-nom if you disagree.
Flags: blocking1.9? → blocking1.9-
(In reply to comment #7)
> -'ing this for the same reason as in bug 429578 comment #4.  If this is a
> regression from the currently key event blockers, it'll get fixed with the 1.9
> release.  Will accept a patch for 1.9, but won't block it.  Re-nom if you
> disagree.


Sorry, did you cite the wrong bug # ?  Comment 4 above is a statement that none of the right-click context menu items work, they are all dimmed out and cannot be used effectively killing the use of Chatzilla.  Unless this a Chatzilla issue only, then the regression range needs to be found and the cause for the bustage understood, or we Chatzilla users are going to lose a good extension.
I would suggest blocking on this until the issue is fully examined.  From what I've seen here so far, that has not been done.

Comment 9

10 years ago
He probably meant bug 429568 comment 4.
(Reporter)

Comment 10

10 years ago
(In reply to comment #8)
> issue only, then the regression range needs to be found and the cause for the

I'm on that right now.
(Reporter)

Comment 11

10 years ago
Regression window: 080414_1646 and 080414_1702
Cached checkins: http://hourly-archive.localgho.st/mac/20080414_1702_checkins.html

=> Regression from bug 423355. Re-asking for blocking1.9

Sadly I cannot update the depends list because of: "You are not authorized to access bug #423355.".
No longer depends on: 428840
Flags: blocking1.9- → blocking1.9?
Keywords: qawanted
Whiteboard: [need regression range]
This might have gotten fixed by the patch in bug 423269 which landed today.

Do you get any assertions when this is happening?

If not this does sound like a blocker since it's likely that other things have regressed.

That said, it's likely that there is a bad chatzilla bug in here somewhere, mutating the DOM when it's not supposed to or some such.
Flags: blocking1.9? → blocking1.9+
Assignee: rginda → jonas
(Reporter)

Comment 13

10 years ago
This breaks even a lot more as only the edit commands...

* Cursor isn't visible on startup
* Cannot enter text within the text field until selecting another element before
* Arrow left and arrow right with/without modifiers don't work
Flags: blocking1.9+ → blocking1.9?
Summary: Edit commands (Select All/Copy/Paste) don't work in Chatzilla → Input field broken (edit commands, no cursor, arrow left/right ) in Chatzilla
(Reporter)

Updated

10 years ago
Duplicate of this bug: 429568
(Reporter)

Comment 15

10 years ago
Jonas, you are right. The patch on bug 423269 has fixed this issue. All mentioned issues from comment 13 are WFM now.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008041900 Minefield/3.0pre ID:2008041900
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 423269
Resolution: --- → FIXED
Verified fixed on Vista HP SP1 
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008041902 Minefield/3.0pre Firefox/3.0 ID:2008041902 <-latest hourly

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.