IceWeasel not getting Install Link correctly

VERIFIED FIXED in 3.4.1

Status

addons.mozilla.org Graveyard
Public Pages
--
minor
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: steviex, Assigned: wenzel)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080311 Iceweasel/2.0.0.13 (Debian-2.0.0.13-0etch1) 

When Using IceWeasel(Debian version of Firefox) Addons will not give the Install link, It gives a Download link instead

Reproducible: Always

Steps to Reproduce:
1. Alter User Agent to IceWeasel Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080311 Iceweasel/2.0.0.13 (Debian-2.0.0.13-0etch1) 
2.Go to https://addons.mozilla.org/en-US/firefox/

Actual Results:  
Download Now appears in Green Box

Expected Results:  
It should be Install Now.
(Assignee)

Comment 1

10 years ago
While it's technically possible, I am unsure if we should add unofficial flavors of Firefox to the UA detection code, thus leading to their support in some parts of the page but not in others.

CCing Basil for clarification.
(Reporter)

Comment 2

10 years ago
This user asked the question in MozillaZine... http://forums.mozillazine.org/viewtopic.php?t=649852&highlight=
(Reporter)

Comment 3

10 years ago
According to the User on the above thread, unless he changes the user Agent to Firefox, IceWeasel will just Download the .xpi rather than trigger an Install.

This will affect users using Debian, Knoppix and other Linux Distros that get IceWeasel from Debian.

I guess this will also affect the Debian version of SeaMonkey (IceApe) too... 

Comment 4

10 years ago
Perhaps you shouldn't be using user-agent fields to determine whether the browser is appropriate?

Comment 5

10 years ago
(In reply to comment #4)
> Perhaps you shouldn't be using user-agent fields to determine whether the
> browser is appropriate?
... especially in view of bug 334967.

Comment 6

10 years ago
> ... especially in view of bug 334967.

Irrelevant. Browser sniffing here is necessary.
Bug 334967 is not relevant here, for the reasons explained in bug 334967 comment 22.

Comment 8

10 years ago
Our policy on AMO is that we do not support IceWeasel & IceApe - they are not official browsers in our support matrix. But, we will make an exception and make a small modification to our browser detection code so that "Add to Firefox"/"Add to SeaMonkey" buttons will appear instead of "Download Now". No other modifications will be made.
Assignee: nobody → fwenzel
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 3.4.1
(Assignee)

Comment 9

10 years ago
Code change is in r12465.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: push-needed
Hardware: PC → All
Resolution: --- → FIXED
(Reporter)

Comment 10

10 years ago
Thank you Kind sirs :) Well done.
(In reply to comment #9)
> Code change is in r12465.

The fix doesn't work, because the actual user-agent string has "Iceweasel" lower-cased: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061024 Iceweasel/2.0 (Debian-2.0+dfsg-1)

Just do s/IceWeasel/Iceweasel, and it works :-)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Version: unspecified → 3.2
(Assignee)

Comment 12

10 years ago
Meh. Thanks, stephend. Will do that. What about IceApe vs. Iceape?
(In reply to comment #12)
> Meh. Thanks, stephend. Will do that. What about IceApe vs. Iceape?

"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.13pre) Gecko/20070505 Iceape/1.0.9"
(Reporter)

Comment 14

10 years ago
My bad for causing the confusion :oops: I should have used the same capitalisation in the names as in the User Agent. Sorry for causing the confusion...
(Assignee)

Comment 15

10 years ago
(In reply to comment #14)
> My bad for causing the confusion :oops: I should have used the same
> capitalisation in the names as in the User Agent. Sorry for causing the
> confusion...

No worries, I should have checked the correct spelling before committing.

Thanks, stephend, for finding this. The fix in SVN, r12532.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Verified FIXED, yay!  Iceape gets treated as "SeaMonkey", and "Iceweasel" gets treated as "Firefox"--both display their respective "Add to SeaMonkey" and "Add to Firefox" installTrigger buttons.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.