Mozilla hangs when started when Outlook 2000 is running



18 years ago
14 years ago


(Reporter: Dameon D. Welch-Abernathy, Assigned: asa)


Windows 98

Firefox Tracking Flags

(Not tracked)




18 years ago
Win 98SE, using M16 build of Mozilla win32. If I start up Mozilla first then
start Outlook 2000, everything appears to work fine. If Outlook is running
when I try to start Mozilla, I don't even get a splash screen.

Comment 1

18 years ago
m17 200061908, win98, outlook express, it worked for me. Could you get a m17
nightly and try again?


Comment 2

18 years ago
I said Outlook *2000*, not Outlook *Express*. They are very different beasts. I
know, because I use them both. Outlook Express doesn't have the problem, Outlook
2000 does.


18 years ago
Last Resolved: 18 years ago
OS: other → Windows 98
Resolution: --- → WORKSFORME

Comment 3

18 years ago
works absolutely fine for me with win98 SE, 2000061920, Outlook 2000...


18 years ago
Keywords: verifyme

Comment 4

18 years ago
Verified   Win98SE 2000062608

Comment 5

18 years ago
Mozilla isn't the only application this occurs for. I did a little hunting on
the net (specificially on DejaNews) and older versions of InstallShield also
experience this problem (i.e. hang when Outlook is running). Someone tracked it
down to a problem with how slow Outlook is at handling MAPI events. Supposedly,
the SR-1 upgrade to Outlook solves this problem, but it does not in my case.

InstallShield resolved this issue by a small redesign. Perhaps Mozilla could
also do something similiar. 
Resolution: WORKSFORME → ---

Comment 6

18 years ago
Wfm 080908 Win98 with Outlook 2000. Due to the majority of people describing
this as wfm, resolving it as that.
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
Using the same build as you, with outlook 2000 running, Mozilla does not start. 
The moment I quit Outlook 2000, Mozilla starts up immediately. Is there some way 
I can help debug this (i.e. is there some way to run Mozilla in a debug mode and 
send the output of what the !@#!@ it's doing?)
Resolution: FIXED → ---

Comment 8

18 years ago
Removing verifyme, but if no one else can repro I'll mark it wfm again. Daemon:
could you please try and find someone that can reproduce this? I am adding
helpwanted to this.
Keywords: verifyme → helpwanted

Comment 9

18 years ago
qawanted is the correct keyword.  helpwanted is seeking help fixing the problem.
 We still havent isolated the problem.
Keywords: helpwanted → qawanted

Comment 10

18 years ago
I believe that 50238 is a dupe of this. Marking it so.

Comment 11

18 years ago
*** Bug 50238 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
I eliminated this problem by performing the following steps:

1. Quit Outlook 2000
2. rename all instances of mapi32.dll to mapi32.old
3. Start Outlook 2000 again. It will give some complaints about missing
mapi32.dll. Allow it to fix the problem.
4. Quit and restart Outlook 2000

The problem with Mozilla seemed to disappear after this. Don't ask me why.
There's an article about corrupted versions of mapi32.dll on Microsoft's site
that talks about this. 
Ok, setting this wontfix, as it is a fiel corruption outside of mozilla's range.

Just another warning that ms sucks ;)
Last Resolved: 18 years ago18 years ago
Resolution: --- → WONTFIX

Comment 14

18 years ago
I think it might be worth release noting this, however. Also, I think the Win2k
issue (which was marked as a duplicate of this) is probably not the same issue.

Comment 15

18 years ago
Keywords: relnote3, relnoteRTM

Comment 16

18 years ago
Dameon, I think that you're probably on the right track that it was extremely 
close to, if not the exact same, problem that InstallShield encountered with 
Outlook 2000.  I was plagued by that bug for a long time.  I couldn't start up 
an IS installation with Outlook 2000 running.  It would always hang at 99% 
during the preparation step.  Very good to release note.

Comment 17

18 years ago
It will be interesting to see if the fix for bug 53952 fixes this...

Comment 18

18 years ago
I came across a similar thing a while ago, and only decided to report it today
as my mind came back to it (sorry).
I started Mozilla, but nothing happened. A while later i decide to close IE,
then all of a sudden Moz launches, as if it was waiting.
This was on Win98 .. can't recall what build number.. but I'm not sure it
matters that much, as I haven't spotted it for ages... just I think it is one of
these rare occational gremlins.
But just wanted to make a record of the fact. (leaving as wfm as I can't
reproduce it myself)


17 years ago
Keywords: qawanted
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.