disjointed rollovers and animated gifs

VERIFIED WORKSFORME

Status

()

Core
Event Handling
P3
normal
VERIFIED WORKSFORME
18 years ago
4 years ago

People

(Reporter: brian donovan, Assigned: joki (gone))

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
A form of this bug was originally seen while I was checking the above site in 
Netscape 4.7 and what seems to be a much more severe manifestation was seen 
while browsing the site with M16 build of Mozilla.  I have very loose and basic 
knowledge of javascript/ecmascript, so I'm not sure whether the problem is 
actually due to the javascript churned out by Fireworks, which was used to 
produce the rollovers.

Description:  At the url identified above, mouseover the 3 vertically stacked 
menu graphics on the right side of the page.  If you're using msie 5 or 
netscape 4.7, a teensy animated gif will appear immediately to the left of the 
item under the mouse pointer.  If you're using 4.7, resize the browser window 
and mouseover again.  Only the first frame of the animated gif will appear.  In 
msie, the animated gif plays as it did before.  If you continue resizing the 
page and mousing over the menu items in Netscape 4.7, it sometimes actually 
crashes the browser.  In M16, mousing over the menu item (before any resizing 
at all) causes the gif that's present by default (ie when no mouseover activity 
is happening) to be replaced with the name of the animated gif file, sans 
extension.

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

18 years ago
Browser, not engine - reassigning to Event Handling 
Assignee: rogerl → joki
Component: Javascript Engine → Event Handling
QA Contact: pschwartau → janc

Comment 2

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer
This seems to be wroking now, so marking WORKSFORME. Tested on NT build 2000080902.

NOTE: It seems to be slow at initializing, so wait a bit before taking the mouse
over the things. If I try them *immediately* after loading the page, the whole
thing is replaced with text.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

17 years ago
Note: page at futurefamers showing the bug has been moved one level deeper into 
the futurefarmers site, but it is the same page.

On Win 98 using Seamonkey M17 (build id 200080712) and NS6PR2 (same build of 
course), this bug is still manifested.  I have tried waiting for things 
to "initialize", up to several minutes after the page has completely finished 
loading, to no effect.  As soon as I mouseover, the "hot image" in the disjoint 
animated rollover is replaced by the text name of one of the image files.

Perhaps on Win NT, waiting a sufficiently long period of time will allow the 
rollovers to function, but this is not the case for me.  Someone please take 
another look at this.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Tested on NT and Linux builds dated 20000823. On first load of document the 
rollovers don't work, the whole image gets replaced by text. If I reload the 
page they start working correctly.

This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future

Comment 6

17 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 8

17 years ago
DUP of bug 32269

Comment 9

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Comment 10

16 years ago
testing with a current Linux CVS build:
The graphics immediately display and animate.
WFM.

Updated

16 years ago
Blocks: 119597

Comment 11

16 years ago
build 2002020603 win32 trunk

tiny images appear on hover but doesn't animate

Comment 12

16 years ago
then again, stupid moz somehow turned off image animation looping on my
profile.. grrr

resolving WFM
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

15 years ago
QA Contact: rakeshmishra → trix

Comment 13

15 years ago
verified wfm
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.