Last Comment Bug 430532 - GTK+ File-Open Dialog is HORRIBLY Slow
: GTK+ File-Open Dialog is HORRIBLY Slow
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 430746 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 13:24 PDT by David F. Skoll
Modified: 2008-04-25 01:37 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description David F. Skoll 2008-04-23 13:24:46 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

The native GTK+ file open dialog is horribly slow.  It takes tens of seconds to navigate into a directory with many files.  The only way to make Firefox usable is to set ui.allow_platform_file_picker to false.

I recommend:

1) Setting ui.allow_platform_file_picker to false for 3.0-release (at least on Linux)

2) Filing a bug with the GTK+ maintainers to fix their stupid file browser.

Reproducible: Always

Steps to Reproduce:
1. Choose "File : Open"
2. Navigate to a directory with lots of files (/usr/bin, for example)
3. Sit and wait.  And wait.  And make coffee.  And wait some more.
Actual Results:  
Slowness

Expected Results:  
Quick opening of directory
Comment 1 Joe Drew (not getting mail) 2008-04-24 13:09:11 PDT
Sorry, you'll have to take it up with the GTK developers. I don't think there's any intention to turn off the GTK+ filechooser.
Comment 2 Boris Zbarsky [:bz] 2008-04-24 13:15:40 PDT
David, do you see the same issue with the GTK+ filepicker in other GTK apps, or is it specific to firefox?
Comment 3 David F. Skoll 2008-04-24 13:18:57 PDT
Boris,

I don't use many GNOME apps, but I believe the GTK+ filepicker is just plain broken... yes, in GIMP too it's painfully slow.

I'm not asking you to remove support for the GTK+ filepicker, just to make it non-default.

Regards,

David.
Comment 4 Boris Zbarsky [:bz] 2008-04-24 13:49:23 PDT
David, while I sympathize with the sentiment (and have the pref changed myself), the reality is that GNOME users seem to prefer to use that filepicker for some reason...

I do think it's worth filing a bug on it with the GTK folks.
Comment 5 David F. Skoll 2008-04-24 18:59:55 PDT
Thanks, bug filed on GTK: http://bugzilla.gnome.org/show_bug.cgi?id=529811
Comment 6 Mats Palmgren (vacation) 2008-04-25 01:37:19 PDT
*** Bug 430746 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.