bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

file opener/chooser freeze when big folders like /usr/bin/ opened

RESOLVED DUPLICATE of bug 430532

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 430532
10 years ago
10 years ago

People

(Reporter: Jonathan-david Schröder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5

Hi,
I'm on linux with Kubuntu. When using's firefox's 3 and inferior's file chooser to choose some file on the hard drive (ie : for saving as, choosing software to use to open some file...), going to folders like /usr/bin where there are many makes the computer think a long long time and then displays the file list (in the case /usr/bin/ those files are programs) as icon + text all at once. This takes 30 seconds on a core 2 duo 2*166 ghz.
This is useless to me to be able to see the whole content, for example of /usr/bin all at once, and this probably would be the case for other big folders of my hard drive.
It would be nice that this icon+filename view of a folder's contents were streamed from hard drive. And scrolling up and down should be streamed as well.

Reproducible: Always

Steps to Reproduce:
1.righ click anywhere on a web page
2.choose save page as
3.in the dialog type a folder name that has lots of file such as /usr/bin/
Actual Results:  
1.the dialog freezes, you wait a *long time*,
2.the dialog is "active" again when the folder content has been translated into a graphical list of items in the right list view of the dialog.

Expected Results:  
No freeze. Typing /usr/bin (for example) should make the first N items of the folder to display in the list.
Using the scrollbar should show the (y:y+N) (with N the length of items viewable at once in a view height and y an index of the topmost file in the current view) in a streamed way.
The already existing type filename & filter functionnality borrowed from Gnome UI should keep working smoothly as it already has been doing for all the past firefox versions I've seen.

Please if this freezing issue comes from the gnome project or a related project of the latter community, tell it to me so that I file the bug on their websites.

Thanks in advance for the hard work you've provided and keep providing !
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 430532
You need to log in before you can comment on or make changes to this bug.