New Tab & New Window Icons Shift Position on Mouseover

VERIFIED FIXED in Firefox 3

Status

()

--
minor
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: lchanady, Unassigned)

Tracking

({polish, regression})

Trunk
Firefox 3
x86
Windows XP
polish, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by 430759])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042407 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042407 Minefield/3.0pre

After this last icon change on Windows XP (I believe from this bug:)

https://bugzilla.mozilla.org/show_bug.cgi?id=429689

The new tab and new window button icons shift position on Mouseover. Large icons shift to the right and small icons shift to the right and down.



Reproducible: Always

Steps to Reproduce:
1. Mouseover New Tab or New Window Toolbar Icon
Actual Results:  
Icon shifts on Mouseover.

Expected Results:  
Icon shouldn't move.

This is using default Windows XP theme.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Comment 1

11 years ago
Confirmed.
I've checked the icons (Toolbar-small.png) and the small printer icon is also affected: 1px to the right and 1px to the right.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042407 Minefield/3.0pre

Comment 2

11 years ago
That should be; 1px to the right and 1px down.

Comment 3

11 years ago
I'm seeing odd results when hovering over the toolbar icons while in classic mode on XP and small icons enabled. The new tab icon moves down and to the right (1px respectively) when hovered over but the printer icon simply moves down (1px) when hovered over. Neither the home, refresh or stop do anything when hovered over. 
With large icons enabled, only the new tab button moves down and to the right! 

~B
this should get fixed before RC state
Blocks: 429689
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3?
Keywords: polish, regression

Comment 5

11 years ago
It appears the "Home" icon is two px smaller then all other icons.  Also, it's
not centered on mouseover, it needs to move over 1px to the left.

~B
I see the problems with new tab, new window and print, but I am not seeing what you mean with home shifting, it should be staying in the same position.
Changes to new tab, new window and print are now fixed and will be updated in
the next windows icon drop.

Comment 8

11 years ago
(In reply to comment #6)
> I see the problems with new tab, new window and print, but I am not seeing what
> you mean with home shifting, it should be staying in the same position.

Alex, the home button isn't moving. It appears to be 2px smaller (in height) then the other toolbar icons and it's not centered in the mouseover state, it's 1 px to the right in the mouseover state.

Question, why do only three of the icons shift on mouse over?  It makes it feel like the others are broken and seems inconsistent.  We have numerous inconsistencies here:

1) A few of the main toolbar buttons shift on mouseover; a few don't
2) Error console icons shift only when clicked on and not on mouseover

What is the thinking behind that?

~B 

Alex, could you provide/name a Bug# for tracking the next icon drop, please?
maybe you also can add that bug on this bug's dependency and add a note to the whiteboard :-)
There isn't any rationale behind the icons shifting, some of then just happened to be misaligned when we got the alternate states.

I usually file the bug for checking in the icons as soon as the drop is ready, looks like it will be sometime late tomorrow.  I'll resolve this bug once they land.
This will be fixed by bug 430759
Depends on: 430759
Flags: blocking-firefox3? → blocking-firefox3+
Whiteboard: [fixed by 430759]

Updated

11 years ago
Whiteboard: [fixed by 430759] → [to be fixed by 430759]
No longer blocks: 430895
indeed it is.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [to be fixed by 430759] → [fixed by 430759]

Updated

10 years ago
Duplicate of this bug: 430953
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050206 Minefield/3.0pre ID:2008050206
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 3
You need to log in before you can comment on or make changes to this bug.