If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Notification bar close button is not vertically aligned with list all tabs drop marker or up arrow when scroll bar is present

RESOLVED WONTFIX

Status

()

Firefox
General
--
trivial
RESOLVED WONTFIX
10 years ago
10 years ago

People

(Reporter: Bryan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042709 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042709 Minefield/3.0pre

Notification bar close button is not vertically aligned with list all tabs drop marker or up arrow when scroll bar is present.

Reproducible: Always

Steps to Reproduce:
1. Launch Minefield
2. Navigate to a site that forces the notification bar to load
3. Restore down the Minefield window such that a vertical scroll bar is present
4. Observe that the notification bar close button is not vertically aligned with the list all tabs drop marker or up arrow when scroll bar is present
Actual Results:  
The notification bar close button is not vertically aligned with the list all tabs drop marker or up arrow when scroll bar is present

Expected Results:  
the notification bar close button is vertically aligned with the list all tabs drop marker or up arrow when scroll bar is present.
(Reporter)

Comment 1

10 years ago
Created attachment 318058 [details]
Screenshot of issue...
(Reporter)

Updated

10 years ago
Blocks: 425582

Comment 2

10 years ago
To clarify, are you saying that you want the red line to go through the center of the close button?  If so, do we really want the button pressed that close to the edge of the screen? (or would that actually be a good thing in a Fittsy way?)

(I must be going crazy.  I thought I had commented on this bug already, but evidently, I hadn't.  Maybe I had forgotten to press submit...)
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> To clarify, are you saying that you want the red line to go through the center
> of the close button?  If so, do we really want the button pressed that close 
> to the edge of the screen? (or would that actually be a good thing in a Fittsy
> way?)

That is what I'm saying.  I think this change would be in alignment FITTS LAW as we've done this in several other areas of FF.  Also it simply looks better.

> (I must be going crazy.  I thought I had commented on this bug already, but
> evidently, I hadn't.  Maybe I had forgotten to press submit...)

It happens!

~B
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > To clarify, are you saying that you want the red line to go through the center
> > of the close button?  If so, do we really want the button pressed that close 
> > to the edge of the screen? 

Forgot to add that the List All Tabs UI element is a great example of "other areas" I mentioned previously.

~B

Comment 5

10 years ago
One concern that I have is this not balancing with the left-spacing of the close button down on the find bar.

Also, while we're on the topic of the close button for notification bars, I noticed that Gavin suggested, in bug 430905 comment 3, using the the new closeSidebar images for the notification bar as well.
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> One concern that I have is this not balancing with the left-spacing of the
> close button down on the find bar.

Well we could adjust that too for consistency.

> Also, while we're on the topic of the close button for notification bars, I
> noticed that Gavin suggested, in bug 430905 comment 3, using the the new
> closeSidebar images for the notification bar as well.

I agree with Gavin here.

~B

(Reporter)

Comment 7

10 years ago
(In reply to comment #5)
> One concern that I have is this not balancing with the left-spacing of the
> close button down on the find bar.

Or would it make sense to move the close button to the far right of the Findbar and align it under the scrollbar down arrow?  In all areas of FF/Minefield the close button is on the right.  This is the only exception.

Your thoughts?

~B

Comment 8

10 years ago
(In reply to comment #3)
> Also it simply looks better.

Any evidence for this? I assume it will look misaligned.
(Reporter)

Comment 9

10 years ago
(In reply to comment #8)
> (In reply to comment #3)
> > Also it simply looks better.
> 
> Any evidence for this? I assume it will look misaligned.

Dao, what are you suggesting would be misaligned?  Kai's patch actually resolves the alignment issue.  He was referring to the spacing the close button has on the far left of the findbar (between the button and the edge of the screen).  I agree that if we change the spacing on the notification bar it should probably be changed on the findbar as well but I also suggested that we could move the close button on the findbar to the far left (aligned under the scrollbar down arrow) as no where else in FF is the close button on the left in the UI except for the findbar.

~B
(Reporter)

Comment 10

10 years ago
> Kai's patch actually

Oops, there isn't a patch yet!  :-)  Wishful thinking.

~B
> He was referring to the spacing the close button
> has on the far left of the findbar (between the button and the edge of the
> screen).

No, he was referring to the notification bar close button in comment 2. You say pushing it to the right will look better, I say it will look worse.
(Reporter)

Comment 12

10 years ago
Created attachment 318074 [details]
Proposed change...
(Reporter)

Comment 13

10 years ago
(In reply to comment #11)
> I say it will look worse.

What do you think of that?  I played with it in Photoshop.

~B


(In reply to comment #13)
> (In reply to comment #11)
> > I say it will look worse.
> 
> What do you think of that?

Yeah, looks like a mistake to me. Don't focus on that red line, try to see the notification bar as one entity. The alignment is messed up in there.
(Reporter)

Comment 15

10 years ago
(In reply to comment #14)

> Yeah, looks like a mistake to me. Don't focus on that red line, try to see the
> notification bar as one entity. The alignment is messed up in there.

Dao, forgive me but I'm confused by your statement.  What looks like a mistake?  I added the red line to indicate the misalignment between the list all tabs drop marker, the notification bar close button and the scrollbar up arrow.

What are you referring to when you say "the alignment is messed up in there"?

~B

Not all misalignments between arbitrarily selected elements in the browser window are bugs. Dao is saying that aligning those images for the sake of aligning them actually looks worse, and I agree. They're not associated with each other so it doesn't really make sense to align them without taking into consideration how they look compared to elements they are related to (i.e. the notification close button and the notification itself).

Comment 17

10 years ago
Specifically, with the button pushed off to the edge, there is now a mismatch between the vertical gaps surrounding the button and the horizontal gap (or lack thereof) to the right of the button.  In the end, this mismatch greatly overshadows the alignment between the close button and the arrows, which is why I am also of the opinion that the close button doesn't look very good pushed off to the edge.
(Reporter)

Comment 18

10 years ago
(In reply to comment #16)
> Not all misalignments between arbitrarily selected elements in the browser
> window are bugs. Dao is saying that aligning those images for the sake of
> aligning them actually looks worse, and I agree. They're not associated with
> each other so it doesn't really make sense to align them without taking into
> consideration how they look compared to elements they are related to (i.e. the
> notification close button and the notification itself).

I agree that not all misalignments are bugs.  I disagree in that I don't believe it looks worse.  This is similar to what was done in 428817.  Different UI elements were aligned that aren't exactly related to on another.

~B
(Reporter)

Comment 19

10 years ago
Kai, I understand both yours and Gavins point.  I'll resolve this as WONTFIX, although I still believe it looks bad.  Too bad the FF notification bar isn't as elegant as the notification bar in IE which is very streamlined, efficient and dynamic.

~B
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.