Closed Bug 431111 Opened 12 years ago Closed 12 years ago

Bookmark favicons replaced when clicked on

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 326896

People

(Reporter: jarith, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

In Firefox 2, I replaced many of the favicons in my bookmarks with ones of my own design. This was more than fine in firefox 2, but in Firefox three however, there seems to be some sort of glitch. If I click on the bookmark, the favicon reverts back to the site's original favicon, loosing my custom. The strange part, is that this is not instantaneous. It takes a minute or so of browsing before it happens

Reproducible: Always

Steps to Reproduce:
1. Set a custom favicon, either with the favicon picker extension, or manually
2. Click the bookmark to go to whichever site it leads to. Note that the site must have its own favicon.

Actual Results:  
The custom will be lost

Expected Results:  
The custom should have remained
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
-> duplicate of bug 326896
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 326896
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.