Closed Bug 326896 Opened 14 years ago Closed 11 years ago

Support customized bookmark favicons

Categories

(Firefox :: Bookmarks & History, enhancement, P5)

x86
All
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 199877

People

(Reporter: ria.klaassen, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Steps to reproduce:

1. Make beautiful icons according to your taste and attach them to bookmark toolbar items so your toolbars are entirely blue-white-black.
2. Visit one of the links in the bookmarks toolbar.
3. The beautiful icon is suddenly replaced by an ugly red-orange-pink one with a terrible design.

Expected behaviour: Firefox should not change icons (at least) in the bookmarks toolbar.
I don't understand what you're trying to do here. The sites define their own favicons which are used in the bookmarks and toolbar, just like previous versions, so this behavior sounds right to me.
In Internet Explorer (always) and previously in Firefox I had the freedom to choose my own icon. The new icon will stay also when you refresh the page. 
This is not a matter of "right" or "wrong" but of free choice. And of course there are workarounds but average people who consider Firefox as a normal browser (something to browse the internet) and not as a special project of interest will see this as a regression.
How did you specify your own icon in Firefox? I'm also pretty sure that it sets the icons for bookmarks every time you visit a page, but this is just my impression from reading the code and not doing actual tests. If you can tell me how to set them, I can try it.
With the favicon picker extension, or more simple, just by changing the url and name field of an other bookmark with the icon of your choice.
Previously the icon did not change when you revisited the site, but with this new places build it changes immediately.
I see. I think both of your methods of changing favicons in Firefox are bugs. Bug 253045 is "favicon shold be reset when URL changes". The other bug appears to be problems with caching (bug 113430 has some stuff on this, but then I got tired of looking). There is no UI or officially supported way for changing site favicons, so I see this as a feature request instead of a feature parity issue.

That said, I do agree that it would be nice to specify one's own favicons. However, we can not support either of the ways you mentioned or in some cases people will feel the favicon is wrong.

The right way is to add a flag in the favicon service that indicates that the favicon is manually set and should not be updated, and possibly have some kind of icon changing UI.
Severity: normal → enhancement
OS: Windows XP → All
Priority: -- → P5
Summary: Bookmarks toolbar buttons in Places should not change after visiting links → Support customized bookmark favicons
(In reply to comment #5)
> Bug 253045 is "favicon shold be reset when URL changes". The other bug appears
> to be problems with caching (bug 113430 has some stuff on this

Now you'll see, that a bug, too minor to repair, has possibly saved Firefox. ;)
This would be nice to have for 3.0 but I'm afraid there's not much hope.
This would really be nice, especially as the favicon picker extension doesn't currently work with firefox 3
I don't know the current behaviour (if the bookmark keeps the favicon or replaces it like in comment 0) but a workaround is to put the address in a javascript URL:
javascript:location.href='http://www.cnn.com/'
This is only doable for the few bookmarks on the bookmarks toolbar of course.
Version: unspecified → Trunk
Blocks: 120352
Duplicate of this bug: 431111
Duplicate of this bug: 441130
This seems to get urgent now, or, the behavior that is normal in IE7 still needs an extension in Firefox.
Flags: blocking-firefox3.2?
Flags: blocking-firefox3.1?
This won't block the next release. I'll leave the flag for the next person, but my feeling at this time is that this level of user control isn't really needed in the main application. Copying some other people to get their opinions.
Flags: blocking-firefox3.1? → blocking-firefox3.1-
(In reply to comment #13)
> This won't block the next release. I'll leave the flag for the next person, but
> my feeling at this time is that this level of user control isn't really needed
> in the main application. Copying some other people to get their opinions.

If I read the comments correctly here, the real push isn't for the IE-style "pick an icon" UI, at least not principally. Principally, I think the request is just that we don't break third party addons which provides this support.  Ria - is that accurate?  If so, we might want to change the description to be something like, "Provide API for preserving custom favicons."

As a side note - letting users pick customized icons can be a boon for identifying that site in the future, since the strongest cues are the ones your choose for yourself.  I agree with beltzner that we probably don't want to provide an IE-style UI for this since I don't think 90% of our users would ever touch it, but "not breaking addons which offer this functionality" sounds like a more realistic goal.  :)
(In reply to comment #14)
> If I read the comments correctly here, the real push isn't for the IE-style
> "pick an icon" UI, at least not principally. Principally, I think the request
> is just that we don't break third party addons which provides this support. 
> Ria - is that accurate?  If so, we might want to change the description to be
> something like, "Provide API for preserving custom favicons."

I'm trying to provide a sort-of that in bug 480873, allowing add-ons to annotate custom icons
(In reply to comment #14)

> If I read the comments correctly here, the real push isn't for the IE-style
> "pick an icon" UI, at least not principally. Principally, I think the request
> is just that we don't break third party addons which provides this support. 
> Ria - is that accurate?  If so, we might want to change the description to be
> something like, "Provide API for preserving custom favicons."
>
 
The goal of this bug is indeed to get a "Change Favicon.." option in the Library window, next to the picture of the current bookmark favicon. The "Change Favicon.." window should show the favicon of the current site and offer to attach this icon to the bookmark instead. Also a "Browse.." option could be handy.
Ria i would dupe this to bug 264241 unless you have some different request to drive this particular bug
This bug was specific for places because places made it suddenly impossible to keep your manually changed favicons. See comment 0. And I just wanted to revert it so that it worked like Firefox 2. That won't happen anymore. 
The goal is now the same as bug 199877, a built-in interface to change favicons, like in IE. Bug 264241 is more for folders.
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: blocking-firefox3.6?
Resolution: --- → DUPLICATE
Duplicate of bug: 199877
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.