Closed Bug 431120 Opened 12 years ago Closed 10 years ago

All toolbar icons have different sizes, give them more unity

Categories

(Firefox :: Theme, defect)

3.0 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 3.7a2

People

(Reporter: ria.klaassen, Unassigned)

References

Details

Attachments

(1 file)

Attached image screenshot
All toolbar button icons have different sizes, while there is no sharp distinction between the groups of buttons that use different sizes. 
Also the bookmark button icons are more massive than the average site favicon.

Of course it is possible in a theme to use 2, 3 of even 4 different sizes, but in that case the icons have all the same shape (mostly round or roundish), so together the composition can form a unity.

So how it is now, in my humble opinion, the icons have not enough in common and my suggestion is:

a. to give all primary toolbar icons the same size/mass;
b. to give the default favicon and folder item the same average size/mass as the site favicons.
We are assuming that the core navigation controls will be placed next to each other.  The downloads icon will be smaller in the next drop to make all of the icons that are not core navigation controls have mostly similar visual weight.
Why not increase the visual weight of the navigation icons instead?  Such as making the refresh button thicker?  There is already a visual imbalance with the core navigation buttons, as they are juxtaposed with the large keyhole.  With the toolbar height now increased to 36px in Luna/Aero (to accommodate the keyhole), the core navigation icons look a little too anorexic.  I think that, as long as we are going with the big keyhole with 36px toolbar concept, the solution isn't to increase the amount of visual void in everything else, but to decrease it in the core nav buttons.  But I guess it's too late for that now...
Blocks: 425582
Depends on: 430908
I see 5 different groups, in "visual weight" order:

1. Home, Reload, Stop
2. History, New Tab, New Window, Download
3. Print
4. Copy, Paste, Cut, Bookmarks
5. Back-Forward
(In reply to comment #3)
> I see 5 different groups, in "visual weight" order:
> 1. Home, Reload, Stop
> 2. History, New Tab, New Window, Download
> 3. Print
> 4. Copy, Paste, Cut, Bookmarks
> 5. Back-Forward

Now when I make an extension, what the heck size am I supposed to use for a toolbar button.  Used to be simple, 24 pixel and the button would fit in anywhere.  Now I have to pick something in the middle of 24 pixel and 16 pixel and hope it doesn't look out of place when next to every button.  Every button needs to have the exact same height, period.
Summary: All toolbars icons have different sizes, give them more unity → All toolbar icons have different sizes, give them more unity
This is something we need to fix, but it's going to be a little more complicated than just replacing the images in toolbar.png.  Basically we need to extend the capabilities of our toolbar customization code to fall back to icons that are all equally weighted when the user begins to make major customizations to their control scheme.  Here is a rather lengthy blog post that explains the whole thing:

http://blog.mozilla.com/faaborg/2008/10/24/firefox-themes-the-contention-between-visual-hierarchy-and-toolbar-customization/
Should be fixed by bug 546098.
Status: NEW → RESOLVED
Closed: 10 years ago
Depends on: 546098
Resolution: --- → FIXED
Duplicate of this bug: 424956
Target Milestone: --- → Firefox 3.7a2
Version: Trunk → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.