Closed Bug 431147 Opened 13 years ago Closed 13 years ago

test_bug394717.js fails on Thunderbird and Sunbird (debug builds only)

Categories

(Toolkit :: Add-ons Manager, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 443367

People

(Reporter: standard8, Unassigned)

Details

When I run the xpcshell test test_bug394717.js it fails on Thunderbird and
Sunbird. The relevant part of the log is:

*** CHECK FAILED: false == true
JS frame :: /Users/moztest/mozilla/hg/mozilla/tools/test-harness/xpcshell-simple/head.js :: do_throw :: line 99
JS frame :: /Users/moztest/mozilla/hg/mozilla/tools/test-harness/xpcshell-simple/head.js :: do_check_eq :: line 114
JS frame :: /Users/moztest/mozilla/hg/mozilla/tools/test-harness/xpcshell-simple/head.js :: do_check_true :: line 118
JS frame :: ../../../../_tests/xpcshell-simple/test_extensionmanager/unit/test_bug394717.js :: run_test_pt2 :: line 82
JS frame :: /Users/moztest/mozilla/hg/mozilla/tools/test-harness/xpcshell-simple/head.js :: anonymous :: line 62
JS frame :: /Users/moztest/mozilla/hg/mozilla/tools/test-harness/xpcshell-simple/head.js :: anonymous :: line 62
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'Abort' when calling method: [nsITimerCallback::notify]"  nsresult: "0x80004004 (NS_ERROR_ABORT)"  location: "<unknown>"  data: no]
************************************************************
*** FAIL ***

I'm not yet sure if this is a problem in core or due to the way Thunderbird &
Sunbird are configured (I'm filing it to get it into tracking).
I've just tried this in a release build and the problem doesn't occur - its debug only.

Updating summary and removing from blocking the enabling of the xpcshell tests for TB & SB.
No longer blocks: 405007, 406227
Summary: test_bug394717.js fails on Thunderbird and Sunbird → test_bug394717.js fails on Thunderbird and Sunbird (debug builds only)
Assignee: bugzilla → nobody
Product: Firefox → Toolkit
Version: unspecified → Trunk
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008080202 SeaMonkey/2.0a1pre] (home, debug default) (W2Ksp4)

This test passes with SeaMonkey (Debug) on Windows.
Yet, the log is not too good, and shows bug 448861 for example.

Mark, you may want to check this test again with TB on MacOSX...
(In reply to comment #2)
> [Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre)
> Gecko/2008080202 SeaMonkey/2.0a1pre] (home, debug default) (W2Ksp4)
> 
> This test passes with SeaMonkey (Debug) on Windows.
> Yet, the log is not too good, and shows bug 448861 for example.
> 
> Mark, you may want to check this test again with TB on MacOSX...

Serge, I wouldn't normally have retested this based on a SM report that it worked given that I initially filed it about TB and SB only. However, given that the file has changed recently, I took another look at it.

The actual test now passes, but there is a failure on shutdown due to bug 431139.

Looking at timescales and logs, it seems like bug 443367 fixed this, so I'm marking as a duplicate of that, the shutdown failure issue is (as I already said) covered by bug 431139.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443367
You need to log in before you can comment on or make changes to this bug.