test_bug394717 uses timeouts and the network which leads to intermittent failures

RESOLVED FIXED in mozilla1.9.1a1

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: mossop, Assigned: mossop)

Tracking

Trunk
mozilla1.9.1a1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Created attachment 327935 [details] [diff] [review]
patch rev 1

test_bug394717 starts an update check for all installed add-ons and then delays to see if the check completed correctly. This is bogus, the more add-ons that are present the longer this will take and additionally it is letting the update checks go out to the network which is not a good idea for a deterministic test.

Seamonkey is hitting intermittent failures on this due to the presence of some 6 default add-ons present, some of which are checking for updates from AMO.

This simple patch removes the timeout and simply calls the final checks in the last callback from the update check. It also adds the test server ad makes default update pings go there to avoid touching the network.
Attachment #327935 - Flags: review?(robert.bugzilla)
(Assignee)

Updated

11 years ago
Assignee: nobody → dtownsend
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
Attachment #327935 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 1

11 years ago
Landed in changeset 5024aedbb16d
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 2

11 years ago
Thanks, could you land on 1.9.0 as well, as SeaMonkey for now is still living and running tests from there?
(Assignee)

Comment 3

11 years ago
(In reply to comment #2)
> Thanks, could you land on 1.9.0 as well, as SeaMonkey for now is still living
> and running tests from there?

Yeah, still waiting on something vaguely resembling a green tree.
(Assignee)

Comment 4

11 years ago
Landed on 1.9.0 branch

Checking in toolkit/mozapps/extensions/test/unit/test_bug394717.js;
/cvsroot/mozilla/toolkit/mozapps/extensions/test/unit/test_bug394717.js,v  <--  test_bug394717.js
new revision: 1.3; previous revision: 1.2
done
(Assignee)

Updated

11 years ago
Target Milestone: --- → Firefox 3.1a1
Product: Firefox → Toolkit
Duplicate of this bug: 431147
You need to log in before you can comment on or make changes to this bug.