drag-and-drop from LocationBar to BookmarksToolbar broken

VERIFIED DUPLICATE of bug 430948

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 430948
10 years ago
8 years ago

People

(Reporter: snowcrash+mozilla, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070831 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042806 Minefield/3.0pre

On select, drag & drop of a LocationBar's URL icon to the BookmarksToolbar, the selewctor/separator does show up in the toolbar, but, on button release NO item is added.  No error, no crash.  Just no item.

Adding the URL via the Bookmarks menu works fine.

Reproducible: Always

Steps to Reproduce:
1. Nav to any URL
2. Click/select LocationBar icon
3. Drag-n-drop selected URL icon to Bookmarks Toolbar

Actual Results:  
selector bar appears, showing drop location
no bookmark is added on release

Expected Results:  
selector bar appears, showing drop location
bookmark IS added on release
Component: Bookmarks → Places
QA Contact: bookmarks → places
Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.getFolderIdForItem]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/places/controller.js :: PCDH_canMoveContainer :: line 1390"  data: no]
Source File: chrome://global/content/nsDragAndDrop.js
Line: 397
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirming, I see this using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042806 Minefield/3.0pre on both Leopard and Tiger.
Keywords: regression
Flags: blocking-firefox3?
also confirmed on Windows XP Nightly, requesting blocking.
OS: Mac OS X → All
Hardware: Macintosh → All
Version: unspecified → Trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 430948

Comment 5

10 years ago
broke over the weekend
Status: RESOLVED → VERIFIED
Flags: blocking-firefox3?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.